summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-05-22 21:35:47 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-05-22 21:35:56 +0100
commit97214ef7618a46554ee41c475c041536dda31aa2 (patch)
tree43566b12f90d9b98dad5d0320fdadedb0a64eeb8
parentdev-perl/Chart-Math-Axis: -r bump for EAPI7 (diff)
downloadgentoo-97214ef7618a46554ee41c475c041536dda31aa2.tar.gz
gentoo-97214ef7618a46554ee41c475c041536dda31aa2.tar.bz2
gentoo-97214ef7618a46554ee41c475c041536dda31aa2.zip
sys-devel/gcc-config: always regenerate ccache cache
USE flag change or code updates can change contents n /usr/bin. The change adds ccache link regeneration. Bug: https://bugs.gentoo.org/724454 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--sys-devel/gcc-config/gcc-config-9999.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/sys-devel/gcc-config/gcc-config-9999.ebuild b/sys-devel/gcc-config/gcc-config-9999.ebuild
index b599996f2b31..e4f08729165a 100644
--- a/sys-devel/gcc-config/gcc-config-9999.ebuild
+++ b/sys-devel/gcc-config/gcc-config-9999.ebuild
@@ -38,12 +38,14 @@ src_install() {
}
pkg_postinst() {
- # Scrub eselect-compiler remains
- rm -f "${ROOT}"/etc/env.d/05compiler &
+ # Scrub eselect-compiler remains.
+ # To be removed in 2021.
+ rm -f "${ROOT}"/etc/env.d/05compiler
# We not longer use the /usr/include/g++-v3 hacks, as
# it is not needed ...
- rm -f "${ROOT}"/usr/include/g++{,-v3} &
+ # To be removed in 2021.
+ rm -f "${ROOT}"/usr/include/g++{,-v3}
# Do we have a valid multi ver setup ?
local x
@@ -51,5 +53,8 @@ pkg_postinst() {
gcc-config ${x}
done
- wait
+ # USE flag change can add or delete files in /usr/bin worth recaching
+ if [[ ! ${ROOT%/} && -f ${EPREFIX}/usr/share/eselect/modules/compiler-shadow.eselect ]] ; then
+ eselect compiler-shadow update all
+ fi
}