summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-08-24 12:50:51 +0200
committerJeroen Roovers <jer@gentoo.org>2019-08-24 12:51:52 +0200
commit979e0926594870bc12092e4c02518e4b899e1d84 (patch)
tree23b5d31e09eeb78ef778d2a61a78ad5463f81a57
parentnet-analyzer/zabbix: migrate to dev-db/mysql-connector-c (diff)
downloadgentoo-979e0926594870bc12092e4c02518e4b899e1d84.tar.gz
gentoo-979e0926594870bc12092e4c02518e4b899e1d84.tar.bz2
gentoo-979e0926594870bc12092e4c02518e4b899e1d84.zip
net-analyzer/tcpstat: EAPI=7
Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--net-analyzer/tcpstat/files/tcpstat-1.5-_DEFAULT_SOURCE.patch11
-rw-r--r--net-analyzer/tcpstat/tcpstat-1.5-r3.ebuild45
2 files changed, 56 insertions, 0 deletions
diff --git a/net-analyzer/tcpstat/files/tcpstat-1.5-_DEFAULT_SOURCE.patch b/net-analyzer/tcpstat/files/tcpstat-1.5-_DEFAULT_SOURCE.patch
new file mode 100644
index 000000000000..e3e0df933d5c
--- /dev/null
+++ b/net-analyzer/tcpstat/files/tcpstat-1.5-_DEFAULT_SOURCE.patch
@@ -0,0 +1,11 @@
+--- a/configure.in
++++ b/configure.in
+@@ -68,7 +68,7 @@
+ case $my_build_os in
+ aix*) AC_DEFINE(AIX_STRANGENESS, 1, [ defined on AIX systems. ]) ;;
+ osf1*) AC_DEFINE(TRU64_STRANGENESS, 1, [ defined on OSF systems. ]) ;;
+- linux*) AC_DEFINE(_BSD_SOURCE, 1, [ defined usually on linux systems ] ) ;;
++ linux*) AC_DEFINE(_DEFAULT_SOURCE, 1, [ defined usually on linux systems ] ) ;;
+ bsd/os*) ;;
+ freebsd*) ;;
+ sunos*) ;;
diff --git a/net-analyzer/tcpstat/tcpstat-1.5-r3.ebuild b/net-analyzer/tcpstat/tcpstat-1.5-r3.ebuild
new file mode 100644
index 000000000000..64128ffed42c
--- /dev/null
+++ b/net-analyzer/tcpstat/tcpstat-1.5-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic
+
+DESCRIPTION="Reports network interface statistics"
+HOMEPAGE="https://www.frenchfries.net/paul/tcpstat/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ipv6"
+
+DEPEND="
+ net-libs/libpcap
+"
+RDEPEND="
+ ${DEPEND}
+"
+DOCS=( AUTHORS ChangeLog NEWS README doc/Tips_and_Tricks.txt )
+PATCHES=(
+ "${FILESDIR}"/${P}-db.patch
+ "${FILESDIR}"/${P}-_DEFAULT_SOURCE.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cflags -Wall -Wextra
+ econf \
+ $(use_enable ipv6) \
+ --with-pcap-include='' \
+ --with-pcap-lib="$( $(tc-getPKG_CONFIG) --libs libpcap)"
+}
+
+src_install() {
+ default
+ dobin src/{catpcap,packetdump}
+ newdoc src/README README.src
+}