summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-01-17 11:22:13 -0500
committerVirgil Dupras <vdupras@gentoo.org>2019-01-17 11:22:13 -0500
commit9956f2c1b001d13983e46cfd0ab53c7dd39b7769 (patch)
tree74f64291189eb45b42c32def9a33328694fc9ff3
parentwww-client/opera-beta: Old (diff)
downloadgentoo-9956f2c1b001d13983e46cfd0ab53c7dd39b7769.tar.gz
gentoo-9956f2c1b001d13983e46cfd0ab53c7dd39b7769.tar.bz2
gentoo-9956f2c1b001d13983e46cfd0ab53c7dd39b7769.zip
dev-python/bleach: bump to 3.1.0
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--dev-python/bleach/Manifest1
-rw-r--r--dev-python/bleach/bleach-3.1.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/bleach/Manifest b/dev-python/bleach/Manifest
index debd39376434..69c558c4702b 100644
--- a/dev-python/bleach/Manifest
+++ b/dev-python/bleach/Manifest
@@ -1,3 +1,4 @@
DIST bleach-1.5.0.tar.gz 36502 BLAKE2B a56eb875a5becd21f7ff71a29db8178a7536a7aadfe81fe178360ba61ba599df9d4d9a782bbf72eb186b61a0b2e3f99058c483cc0d194e735a787319697c7327 SHA512 572a089691af61f096716d96517a96755fe674cc471bdbcff80615ae903eaeff72c47b918ee28a1db60ee5c0253c0c52ba02544f8535ae4f283a3a87a3061124
DIST bleach-2.1.3.tar.gz 60141 BLAKE2B 5c04269266007e31e1a01540198177afb6b13362b89815073b7cd68668da26725f2631defdb26d124ae6c74743de0d31b2975a0d19f58e032ac2332e3ea46a75 SHA512 ff74fb3646709f20c79ea02e6d0fb93e2f204d3151a05f259b703050c10d410859af76acb470405f6fb7b55c8fb64595e6f0fcf8e9cb8fd3fc3722fa30a47de5
DIST bleach-3.0.2.tar.gz 165682 BLAKE2B 26dfca08732af9eb11a27e1913ad1ed76454950d902d8f0dfd4a816dfe972d2280a29fcb7ba6c021938863f92d20d6ee3bb5ea64ee0b1f52e62cdbe12aebe009 SHA512 f5a6537c5b048a23b7834f27e30413517f82082f2abc4ad26c16a3aa4486545beec5394d2b759e82022f4cb8915e4034d8cd3383e41a3772a73f3858c283c155
+DIST bleach-3.1.0.tar.gz 167814 BLAKE2B 386d483ec9554d0436eeda70a5f558ca2191914ed90ddbfa00ae887e682505d1b84f511d21be7eceb8c98422a4dbb25ee32af49edc4b811e3816aaf9161fa4c4 SHA512 8db3a54b68fa66a07a3b4b90481557aac06e7783f9c72035a6f037909017354718b67b64153e1cd50cb2c821174b8282837c4c3e667878041a68703b141b2969
diff --git a/dev-python/bleach/bleach-3.1.0.ebuild b/dev-python/bleach/bleach-3.1.0.ebuild
new file mode 100644
index 000000000000..70494f99846f
--- /dev/null
+++ b/dev-python/bleach/bleach-3.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="an easy whitelist-based HTML-sanitizing tool"
+HOMEPAGE="https://github.com/mozilla/bleach https://pypi.org/project/bleach/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd"
+IUSE="test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/webencodings[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pytest -v || die "tests failed under ${EPYTHON}"
+}