summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-02 10:04:34 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-02 10:46:37 +0200
commit9a110cb463b82a516a929fb8a99a16128f226bc6 (patch)
treea3a495aa40b509f0e542d5e70ef4e47e0daa2462
parentdev-python/simplekv: Clean old versions up (diff)
downloadgentoo-9a110cb463b82a516a929fb8a99a16128f226bc6.tar.gz
gentoo-9a110cb463b82a516a929fb8a99a16128f226bc6.tar.bz2
gentoo-9a110cb463b82a516a929fb8a99a16128f226bc6.zip
dev-python/pygresql: Clean old versions up
-rw-r--r--dev-python/pygresql/pygresql-4.1.1-r1.ebuild73
-rw-r--r--dev-python/pygresql/pygresql-4.1.1.ebuild74
2 files changed, 0 insertions, 147 deletions
diff --git a/dev-python/pygresql/pygresql-4.1.1-r1.ebuild b/dev-python/pygresql/pygresql-4.1.1-r1.ebuild
deleted file mode 100644
index 1da441a52996..000000000000
--- a/dev-python/pygresql/pygresql-4.1.1-r1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-POSTGRES_COMPAT=( 9.{0,1,2,3} )
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-MY_P="PyGreSQL-${PV}"
-
-DESCRIPTION="A Python interface for the PostgreSQL database"
-HOMEPAGE="http://www.pygresql.org/"
-SRC_URI="mirror://pypi/P/PyGreSQL/${MY_P}.tgz"
-
-LICENSE="POSTGRESQL"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ~ppc sparc x86"
-IUSE="doc"
-
-DEPEND="|| (
- dev-db/postgresql:9.3
- dev-db/postgresql:9.2
- dev-db/postgresql:9.1
- dev-db/postgresql:9.0
-)"
-
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-# Verify that the currently selected PostgreSQL slot is set to one of
-# the slots defined in POSTGRES_COMPAT.
-postgres_check_slot() {
- if ! declare -p POSTGRES_COMPAT &>/dev/null; then
- die 'POSTGRES_COMPAT not declared.'
- fi
-
-# Don't die because we can't run postgresql-config during pretend.
-[[ "$EBUILD_PHASE" = "pretend" && -z "$(which postgresql-config 2> /dev/null)" ]] \
- && return 0
-
- local res=$(echo ${POSTGRES_COMPAT[@]} \
- | grep -c $(postgresql-config show 2> /dev/null) 2> /dev/null)
-
- if [[ "$res" -eq "0" ]] ; then
- eerror "PostgreSQL slot must be set to one of: "
- eerror " ${POSTGRES_COMPAT[@]}"
- return 1
- fi
-
- return 0
-}
-
-pkg_pretend() {
- postgres_check_slot
-}
-
-pkg_setup() {
- postgres_check_slot || die
-}
-
-python_install_all() {
- local DOCS=( docs/*.txt )
- distutils-r1_python_install_all
-
- if use doc; then
- insinto /usr/share/doc/${PF}/tutorial
- doins tutorial/*
- dohtml docs/*.{html,css}
- fi
-}
diff --git a/dev-python/pygresql/pygresql-4.1.1.ebuild b/dev-python/pygresql/pygresql-4.1.1.ebuild
deleted file mode 100644
index b85290c40f06..000000000000
--- a/dev-python/pygresql/pygresql-4.1.1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-POSTGRES_COMPAT=( 8.{3,4} 9.{0,1,2} )
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-MY_P="PyGreSQL-${PV}"
-
-DESCRIPTION="A Python interface for the PostgreSQL database"
-HOMEPAGE="http://www.pygresql.org/"
-SRC_URI="mirror://pypi/P/PyGreSQL/${MY_P}.tgz"
-
-LICENSE="POSTGRESQL"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc sparc x86"
-IUSE="doc"
-
-DEPEND="|| (
- dev-db/postgresql:8.3
- dev-db/postgresql:8.4
- dev-db/postgresql:9.0
- dev-db/postgresql:9.1
- dev-db/postgresql:9.2
-)"
-
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-# Verify that the currently selected PostgreSQL slot is set to one of
-# the slots defined in POSTGRES_COMPAT.
-postgres_check_slot() {
- if ! declare -p POSTGRES_COMPAT &>/dev/null; then
- die 'POSTGRES_COMPAT not declared.'
- fi
-
-# Don't die because we can't run postgresql-config during pretend.
-[[ "$EBUILD_PHASE" = "pretend" && -z "$(which postgresql-config 2> /dev/null)" ]] \
- && return 0
-
- local res=$(echo ${POSTGRES_COMPAT[@]} \
- | grep -c $(postgresql-config show 2> /dev/null) 2> /dev/null)
-
- if [[ "$res" -eq "0" ]] ; then
- eerror "PostgreSQL slot must be set to one of: "
- eerror " ${POSTGRES_COMPAT[@]}"
- return 1
- fi
-
- return 0
-}
-
-pkg_pretend() {
- postgres_check_slot
-}
-
-pkg_setup() {
- postgres_check_slot || die
-}
-
-python_install_all() {
- local DOCS=( docs/*.txt )
- distutils-r1_python_install_all
-
- if use doc; then
- insinto /usr/share/doc/${PF}/tutorial
- doins tutorial/*
- dohtml docs/*.{html,css}
- fi
-}