summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-07-24 19:24:33 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-07-24 19:24:51 +0100
commit9afa4142777eadfa30d803107af82c634cf0b379 (patch)
tree39fc84950160c990bec9703ca0f4da3c0390eb01
parentdev-python/python-dotenv: 0.19.0 (diff)
downloadgentoo-9afa4142777eadfa30d803107af82c634cf0b379.tar.gz
gentoo-9afa4142777eadfa30d803107af82c634cf0b379.tar.bz2
gentoo-9afa4142777eadfa30d803107af82c634cf0b379.zip
media-tv/dvbtune: respect user's CC
Fixed-by: Michael Mair-Keimberger Closes: https://bugs.gentoo.org/470068 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--media-tv/dvbtune/dvbtune-0.5-r1.ebuild14
-rw-r--r--media-tv/dvbtune/files/dvbtune-0.5-r1-gentoo.diff4
2 files changed, 12 insertions, 6 deletions
diff --git a/media-tv/dvbtune/dvbtune-0.5-r1.ebuild b/media-tv/dvbtune/dvbtune-0.5-r1.ebuild
index ccd198855ffc..e4cb2c114c24 100644
--- a/media-tv/dvbtune/dvbtune-0.5-r1.ebuild
+++ b/media-tv/dvbtune/dvbtune-0.5-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit epatch
+inherit toolchain-funcs
DESCRIPTION="simple tuning app for DVB cards"
HOMEPAGE="https://sourceforge.net/projects/dvbtools"
@@ -18,9 +18,15 @@ RDEPEND="xml? ( dev-libs/libxml2 )"
DEPEND="${RDEPEND}
virtual/linuxtv-dvb-headers"
+PATCHES=(
+ "${FILESDIR}"/${PF}-gentoo.diff
+ "${FILESDIR}"/${PN}-0.5-stdint.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${PF}-gentoo.diff
- epatch "${FILESDIR}"/${PN}-0.5-stdint.patch
+ default
+
+ tc-export CC
}
src_compile() {
diff --git a/media-tv/dvbtune/files/dvbtune-0.5-r1-gentoo.diff b/media-tv/dvbtune/files/dvbtune-0.5-r1-gentoo.diff
index a615317eb1de..f1e097fd6d1b 100644
--- a/media-tv/dvbtune/files/dvbtune-0.5-r1-gentoo.diff
+++ b/media-tv/dvbtune/files/dvbtune-0.5-r1-gentoo.diff
@@ -1,11 +1,11 @@
--- dvbtune-0.5/Makefile.orig 2006-01-06 13:01:11.973196250 +0100
+++ dvbtune-0.5/Makefile 2006-01-06 13:01:46.667364500 +0100
-@@ -1,5 +1,6 @@
+@@ -1,5 +1,5 @@
INCS=-I /usr/include/libxml2
-CFLAGS= -Wall $(INCS)
+-CC=gcc
+CFLAGS ?= -Wall
+CFLAGS += $(INCS)
- CC=gcc
all: dvbtune
@@ -33,7 +33,7 @@