summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-08-09 17:48:17 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-08-09 17:52:48 +0200
commit9b07861a704ce7c9ae61351efed990e90cd4429c (patch)
tree6d29d40fd52c7fc642355f8bd4a1d166e2f3dc83
parentdev-libs/luise: renamed by dropping -bin (diff)
downloadgentoo-9b07861a704ce7c9ae61351efed990e90cd4429c.tar.gz
gentoo-9b07861a704ce7c9ae61351efed990e90cd4429c.tar.bz2
gentoo-9b07861a704ce7c9ae61351efed990e90cd4429c.zip
sys-apps/qdirstat: bump to version 1.7
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--sys-apps/qdirstat/Manifest1
-rw-r--r--sys-apps/qdirstat/qdirstat-1.7.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-apps/qdirstat/Manifest b/sys-apps/qdirstat/Manifest
index 22f172db4ec8..d756e59cacd1 100644
--- a/sys-apps/qdirstat/Manifest
+++ b/sys-apps/qdirstat/Manifest
@@ -1 +1,2 @@
DIST qdirstat-1.6.1.tar.gz 7708491 BLAKE2B e6a92f93c76de0f602a66409a2701cd06f1744ab67c3c829938695f1d59b7244998d3a6ddd9d6cfc6408db3ac98d355f4496348ebd198c93ea345b33414c3048 SHA512 fd4c6a3582184785d935e96e884cc3e2033e3ee174ea893816b14524c5c5c62923c5a8c5869969fb8b1d0e84bbffd9dc707a68bdb53898c55dfd14fe16946110
+DIST qdirstat-1.7.tar.gz 8057173 BLAKE2B 7de2d74933dcce190240569ca043faf76925592576016090498ae21d2074a79aa9b1313fa491c270d5a841238cb35007a85ca3de9c343a353b3de9235f9e5032 SHA512 9af03c110663eab0df48f69f7d949421feebfdca1299205d25a216587cf2c9e472cbe99ad98f3cd6c783be2b02e0308cdbc2f5549bf662b3061ff5e059317b01
diff --git a/sys-apps/qdirstat/qdirstat-1.7.ebuild b/sys-apps/qdirstat/qdirstat-1.7.ebuild
new file mode 100644
index 000000000000..e4bae2ee165e
--- /dev/null
+++ b/sys-apps/qdirstat/qdirstat-1.7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg-utils
+
+DESCRIPTION="Qt-based directory statistics"
+HOMEPAGE="https://github.com/shundhammer/qdirstat"
+SRC_URI="https://github.com/shundhammer/qdirstat/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-qt/qtgui:5
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+"
+
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl
+ dev-perl/URI
+"
+
+src_prepare() {
+ default
+
+ # Fix QA warning about incorrect use of doc path
+ sed -e "/doc.path/s/${PN}/${PF}/" -i doc/doc.pro doc/stats/stats.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${ED}" install
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}