summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-02-12 12:02:56 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2021-02-12 12:02:56 +0100
commit9c086e4b01610c65f79929cb03c817653d92617e (patch)
tree4c73e4ffcbbfaac1b8d07175298bebe8684e7bb3
parentnet-wireless/wireless-regdb: mark ALLARCHES (diff)
downloadgentoo-9c086e4b01610c65f79929cb03c817653d92617e.tar.gz
gentoo-9c086e4b01610c65f79929cb03c817653d92617e.tar.bz2
gentoo-9c086e4b01610c65f79929cb03c817653d92617e.zip
media-sound/lilypond: +2.23.0, dropped guile2 use flag, updated live
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--media-sound/lilypond/Manifest1
-rw-r--r--media-sound/lilypond/files/lilypond-2.23.0-fix-font-size.patch (renamed from media-sound/lilypond/files/lilypond-9999-fix-font-size.patch)0
-rw-r--r--media-sound/lilypond/lilypond-2.23.0.ebuild138
-rw-r--r--media-sound/lilypond/lilypond-9999.ebuild9
4 files changed, 141 insertions, 7 deletions
diff --git a/media-sound/lilypond/Manifest b/media-sound/lilypond/Manifest
index 86c44eb63be8..d258c9aa11c1 100644
--- a/media-sound/lilypond/Manifest
+++ b/media-sound/lilypond/Manifest
@@ -1,2 +1,3 @@
DIST lilypond-2.21.6.tar.gz 17996701 BLAKE2B 2efbdae1bd16ab1682c14c1c0e01146d66dd408ff5d3f9b69ed38dcedd88b68c6ae3219b02e7a3967833d802488a90aecf50964f44ebb5445f887d4a532a41ad SHA512 9effceabe39a0ca5f3837e0ff1cb0d4caed87b4b76e40f7c4f618d682b2e3db8f82e461e5c9555d6c05d591be54a08370599ed8c72d1e92ba80bcabf4d21a6f7
DIST lilypond-2.22.0.tar.gz 18023031 BLAKE2B a7512629be43680c6e6bda1404c9b8e4a9bfb0b65ad565aede9dba983ae8e5fb350e8a53250cd01314b4d032d1bbe7b391bb3acd411dc6665868f4cd04f15011 SHA512 4dcc4da1bd1aa1d10ca802acbe29f2256587cd8e2643651b6d2e42cfce0b9572d0eb1139fbc59cec98ad6b86b86e7a6910becb6be7a4350ee0adfe366daa0a65
+DIST lilypond-2.23.0.tar.gz 17047610 BLAKE2B 5d19a9936893a37db3ff6de269978d586012b7546fe5f3147e86966f1d521731dd2cf074c90de5b49feff6ee6f5057c90fe6485d7ae9126a8a5810b55d2dc5b2 SHA512 0138338e9e650f1d0d96504cd31d8b191307ae3fcec839162c80b8d233b27a9ff94f5b107aa2318278a874ed14e5e47747211ac4b44839d6749337f06dc12a6d
diff --git a/media-sound/lilypond/files/lilypond-9999-fix-font-size.patch b/media-sound/lilypond/files/lilypond-2.23.0-fix-font-size.patch
index 45a3ad5e22ca..45a3ad5e22ca 100644
--- a/media-sound/lilypond/files/lilypond-9999-fix-font-size.patch
+++ b/media-sound/lilypond/files/lilypond-2.23.0-fix-font-size.patch
diff --git a/media-sound/lilypond/lilypond-2.23.0.ebuild b/media-sound/lilypond/lilypond-2.23.0.ebuild
new file mode 100644
index 000000000000..de2a548eb654
--- /dev/null
+++ b/media-sound/lilypond/lilypond-2.23.0.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit elisp-common autotools python-single-r1 toolchain-funcs xdg-utils
+
+if [[ "${PV}" = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/lilypond.git"
+else
+ MAIN_VER=$(ver_cut 1-2)
+ SRC_URI="http://lilypond.org/download/sources/v${MAIN_VER}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
+fi
+
+DESCRIPTION="GNU Music Typesetter"
+HOMEPAGE="http://lilypond.org/"
+
+LICENSE="GPL-3 FDL-1.3"
+SLOT="0"
+LANG_USE="l10n_ca l10n_cs l10n_de l10n_en l10n_fr l10n_hu l10n_it l10n_ja l10n_nl l10n_pt l10n_zh"
+IUSE="debug doc emacs profile vim-syntax ${LANG_USE}"
+unset LANG_USE
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+ dev-texlive/texlive-metapost
+ sys-apps/texinfo
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+ doc? ( app-text/texi2html )
+"
+RDEPEND="app-text/ghostscript-gpl
+ dev-scheme/guile:12=[deprecated,regex]
+ media-fonts/tex-gyre
+ media-libs/fontconfig
+ media-libs/freetype:2
+ x11-libs/pango
+ emacs? ( >=app-editors/emacs-23.1:* )
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ app-text/t1utils
+ dev-lang/perl
+ dev-libs/kpathsea
+ media-gfx/fontforge[png,python]
+ sys-devel/gettext
+ doc? (
+ dev-texlive/texlive-langcyrillic
+ l10n_cs? ( dev-texlive/texlive-xetex )
+ l10n_ja? ( dev-texlive/texlive-langjapanese )
+ l10n_zh? ( dev-texlive/texlive-langchinese )
+ )
+"
+# Correct output data for tests isn't bundled with releases
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-font-size.patch
+)
+
+DOCS=( DEDICATION HACKING README.md ROADMAP )
+
+src_prepare() {
+ default
+
+ if ! use vim-syntax ; then
+ sed -i 's/vim//' GNUmakefile.in || die
+ fi
+
+ # respect CFLAGS
+ sed -i 's/OPTIMIZE -g/OPTIMIZE/' aclocal.m4 || die
+
+ # remove bundled texinfo file (fixes bug #448560)
+ rm tex/texinfo.tex || die
+
+ eautoreconf
+
+ xdg_environment_reset #586592
+}
+
+src_configure() {
+ # fix hardcoded `ar`
+ sed -i "s/AR=ar/AR=$(tc-getAR)/g" flower/GNUmakefile || die "Failed to fix ar command"
+
+ local myeconfargs=(
+ --with-texgyre-dir=/usr/share/fonts/tex-gyre
+ --disable-optimising
+ --disable-pipe
+ $(use_enable debug debugging)
+ $(use_enable doc documentation)
+ $(use_enable profile profiling)
+ )
+
+ export VARTEXFONTS="${T}/fonts" # https://bugs.gentoo.org/692010
+
+ econf "${myeconfargs[@]}" AR="$(tc-getAR)"
+}
+
+src_compile() {
+ default
+
+ use doc && emake LANGS="${L10N}" doc info
+
+ if use emacs ; then
+ elisp-compile elisp/lilypond-{font-lock,indent,mode,what-beat}.el \
+ || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" vimdir=/usr/share/vim/vimfiles install
+
+ use doc && emake DESTDIR="${D}" install-doc
+
+ # remove elisp files since they are in the wrong directory
+ rm -r "${ED}"/usr/share/emacs || die
+
+ if use emacs ; then
+ elisp-install ${PN} elisp/*.{el,elc} elisp/out/*.el \
+ || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el
+ fi
+
+ python_fix_shebang "${ED}"
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/media-sound/lilypond/lilypond-9999.ebuild b/media-sound/lilypond/lilypond-9999.ebuild
index 4b7150162b1b..24d67598c447 100644
--- a/media-sound/lilypond/lilypond-9999.ebuild
+++ b/media-sound/lilypond/lilypond-9999.ebuild
@@ -21,7 +21,7 @@ HOMEPAGE="http://lilypond.org/"
LICENSE="GPL-3 FDL-1.3"
SLOT="0"
LANG_USE="l10n_ca l10n_cs l10n_de l10n_en l10n_fr l10n_hu l10n_it l10n_ja l10n_nl l10n_pt l10n_zh"
-IUSE="debug doc emacs guile2 profile vim-syntax ${LANG_USE}"
+IUSE="debug doc emacs profile vim-syntax ${LANG_USE}"
unset LANG_USE
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -40,11 +40,6 @@ RDEPEND="app-text/ghostscript-gpl
media-libs/freetype:2
x11-libs/pango
emacs? ( >=app-editors/emacs-23.1:* )
- guile2? ( >=dev-scheme/guile-2.2:12 )
- !guile2? (
- dev-scheme/guile:12=[deprecated,regex]
- <dev-scheme/guile-2.0:12
- )
${PYTHON_DEPS}"
DEPEND="${RDEPEND}
app-text/t1utils
@@ -63,7 +58,7 @@ DEPEND="${RDEPEND}
RESTRICT="test"
PATCHES=(
- "${FILESDIR}"/${P}-fix-font-size.patch
+ "${FILESDIR}"/${PN}-2.23.0-fix-font-size.patch
)
DOCS=( DEDICATION HACKING README.md ROADMAP )