summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James (sam_c) <sam@cmpct.info>2020-06-17 02:14:12 +0000
committerThomas Deutschmann <whissi@gentoo.org>2020-06-19 17:25:05 +0200
commit9c5f6dd9c3ac0a5feaa5a57f7525687a04b69ff5 (patch)
treeafc90271c3b89a7e47ce2f48fce538f4e5023581
parentmedia-plugins/live: consistent style (diff)
downloadgentoo-9c5f6dd9c3ac0a5feaa5a57f7525687a04b69ff5.tar.gz
gentoo-9c5f6dd9c3ac0a5feaa5a57f7525687a04b69ff5.tar.bz2
gentoo-9c5f6dd9c3ac0a5feaa5a57f7525687a04b69ff5.zip
media-plugins/live: bump to 2020.05.15
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sam James (sam_c) <sam@cmpct.info> Closes: https://github.com/gentoo/gentoo/pull/16284 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--media-plugins/live/Manifest1
-rw-r--r--media-plugins/live/live-2020.05.15.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/media-plugins/live/Manifest b/media-plugins/live/Manifest
index 2f2582b4457d..011ba93b1938 100644
--- a/media-plugins/live/Manifest
+++ b/media-plugins/live/Manifest
@@ -1 +1,2 @@
DIST live.2020.03.06.tar.gz 7231080 BLAKE2B 95a1d3cc394eba473296973a1e44160dd1ca8e2efbc322a2e0bfbdb183244cda28b219ea14a51c8d146807d829b566a9c3782b291d5abfbd306a92e030e108e4 SHA512 7da439fbdeab0da6687dee56d9a27bf7b8f8a9c84b420d72f2e2a7ff7a73d18756d1fdb920f29b36917d93efcecc9230877637322d5041eeba114882b4bf7a06
+DIST live.2020.05.15.tar.gz 7229400 BLAKE2B 74532c178aa1044750110eb52561b99cd70874574ee84992201a145b18091d4f8475e2a299a83f0fe42c7e64483d46175fb76465a22509db3ba2633aff1327f6 SHA512 d53fb7e8c586f50e561aa361567ccd45babdbbcbe96a06d95e42a04a54b23ac3f474fefcacf94a49b604008623acf06789b92238364713853babbe356eeac4aa
diff --git a/media-plugins/live/live-2020.05.15.ebuild b/media-plugins/live/live-2020.05.15.ebuild
new file mode 100644
index 000000000000..cce1f38eef20
--- /dev/null
+++ b/media-plugins/live/live-2020.05.15.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Libraries for standards-based RTP/RTCP/RTSP multimedia streaming"
+HOMEPAGE="http://www.live555.com/"
+SRC_URI="http://www.live555.com/liveMedia/public/${P/-/.}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="libressl ssl"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( "live-shared/README" )
+
+# Alexis Ballier <aballier@gentoo.org>, Sam James <sam@cmpct.info>
+# Be careful, bump this everytime you bump the package and the ABI has changed.
+# If you don't know, ask someone.
+# You may wish to use a site like https://abi-laboratory.pro/index.php?view=timeline&l=live555
+LIVE_ABI_VERSION=9
+SLOT="0/${LIVE_ABI_VERSION}"
+
+S="${WORKDIR}/live"
+
+src_prepare() {
+ default
+
+ cp "${FILESDIR}/config.gentoo-so-r3" "${S}/config.gentoo-so-r1" || die
+
+ # This is all legacy stuff which needs to be cleaned up
+ case ${CHOST} in
+ *-solaris*)
+ sed -i \
+ -e '/^COMPILE_OPTS /s/$/ -DSOLARIS -DXLOCALE_NOT_USED/' \
+ -e '/^LIBS_FOR_CONSOLE_APPLICATION /s/$/ -lsocket -lnsl/' \
+ live/config.gentoo-so-r1 \
+ || die
+ ;;
+ *-darwin*)
+ sed -i \
+ -e '/^COMPILE_OPTS /s/$/ -DBSD=1 -DHAVE_SOCKADDR_LEN=1/' \
+ -e '/^LINK /s/$/ /' \
+ -e '/^LIBRARY_LINK /s/=.*$/= $(CXX) -o /' \
+ -e '/^LIBRARY_LINK_OPTS /s:-shared.*$:-undefined suppress -flat_namespace -dynamiclib -install_name '"${EPREFIX}/usr/$(get_libdir)/"'$@:' \
+ -e '/^LIB_SUFFIX /s/so/dylib/' \
+ live/config.gentoo-so-r1 \
+ || die
+ ;;
+ esac
+}
+
+src_configure() {
+ # This ebuild uses its own build system
+ # We don't want to call ./configure or anything here.
+ # The only thing we can do is honour the user's SSL preference.
+ if use ssl ; then
+ sed -i 's/-DNO_OPENSSL=1//' "${S}/config.gentoo-so-r1" || die
+ fi
+
+ # Bug 718912
+ tc-export CC CXX
+
+ # And defer to the scripts that upstream provide.
+ ./genMakefiles gentoo-so-r1 || die
+}
+
+src_compile() {
+ export suffix="${LIVE_ABI_VERSION}.so"
+ local link_opts="$(usex ssl "$(pkg-config --libs libssl libcrypto)" '') -L. ${LDFLAGS}"
+ local lib_suffix="${suffix#.}"
+
+ einfo "Beginning shared library build"
+ emake LINK_OPTS="${link_opts}" LIB_SUFFIX="${lib_suffix}"
+
+ for i in liveMedia groupsock UsageEnvironment BasicUsageEnvironment ; do
+ cd "${S}/${i}" || die
+ ln -s "lib${i}.${suffix}" "lib${i}.so" || die
+ done
+
+ einfo "Beginning programs build"
+ for i in proxyServer mediaServer ; do
+ cd "${S}/${i}" || die
+ emake LINK_OPTS="${link_opts}"
+ done
+}
+
+src_install() {
+ for library in UsageEnvironment liveMedia BasicUsageEnvironment groupsock ; do
+ dolib.so "${S}/${library}/lib${library}.${suffix}"
+ dosym "lib${library}.${suffix}" "/usr/$(get_libdir)/lib${library}.so"
+
+ insinto /usr/include/"${library}"
+ doins "${S}/${library}"/include/*h
+ done
+
+ dobin "${S}"/mediaServer/live555MediaServer
+ dobin "${S}"/proxyServer/live555ProxyServer
+}