summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-11-24 23:18:53 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-24 23:20:31 +0100
commit9eabd6be0e49464f74bdac7948d4966d517b1efa (patch)
tree3d55218e010e978830fe851ce457230635cc041b
parentgames-rpg/manaplus: fix MissingTestRestrict, update metadata (diff)
downloadgentoo-9eabd6be0e49464f74bdac7948d4966d517b1efa.tar.gz
gentoo-9eabd6be0e49464f74bdac7948d4966d517b1efa.tar.bz2
gentoo-9eabd6be0e49464f74bdac7948d4966d517b1efa.zip
dev-python/pycodestyle: 2.5.0 version bump, EAPI-7 bump, python3_8
Also fixing tests. Closes: https://bugs.gentoo.org/690892 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-python/pycodestyle/Manifest1
-rw-r--r--dev-python/pycodestyle/pycodestyle-2.5.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pycodestyle/Manifest b/dev-python/pycodestyle/Manifest
index dc177866ba9c..5886f5c15dd9 100644
--- a/dev-python/pycodestyle/Manifest
+++ b/dev-python/pycodestyle/Manifest
@@ -1,2 +1,3 @@
DIST pycodestyle-2.3.1.tar.gz 89460 BLAKE2B 0b7e23be13830954277d521262e9504ade8a4d0275a77e6365201ccffae955a8f505a1cd5e739145e1fc5551c3b956ff9a51bb57cede819f2886ee36637f7f9e SHA512 276bc21b4e6898e379be88f3582135a21314460ad20d4b6c3e12825ac1a72082b2c08bb62099e704c3222f879a1098d0b305132fac1095aaa60ca239b9763a2d
DIST pycodestyle-2.4.0.tar.gz 96665 BLAKE2B 9c847aa9c9ffa1f401595d1c2c3f81f971f69628fb34d4e572ccb99203f8e9abe8101302d61c4ae7d330c03e7d0dd5e252d658065b7ed6660dea186880030529 SHA512 cb35238291fed30f1a4363e65b754165772d01e6006e19ce31769691aed17411cd893899fcd22dfca0455401bee899097fff6f3d63825c7656f186e37b7da3a0
+DIST pycodestyle-2.5.0.tar.gz 98802 BLAKE2B ec86642f0f37abc4da8886df6395694b54cbe4e1d0030615b2136f0bc265825df254f019483e9094feaad685e43008cefdf0e50b533df434a40de0de11aa5fa1 SHA512 84e751a7d00048393b02ca743de5d71d1641e948ee1b4daebbdf2d07e0cd8f087ca4e81f826061114b40ef41920bbcd680c9f479e7cc1a159a70188425717208
diff --git a/dev-python/pycodestyle/pycodestyle-2.5.0.ebuild b/dev-python/pycodestyle/pycodestyle-2.5.0.ebuild
new file mode 100644
index 000000000000..21ff67504ae5
--- /dev/null
+++ b/dev-python/pycodestyle/pycodestyle-2.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python2_7 python3_{5,6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python style guide checker (fka pep8)"
+HOMEPAGE="https://pypi.org/project/pycodestyle/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py -v --statistics pycodestyle.py || die
+ PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py -v --max-doc-length=72 --testsuite=testsuite || die
+ PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py --doctest -v || die
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}