summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-11-09 11:05:43 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-11-09 17:09:26 +0100
commit9ff3ec4217883d259652cb5e90bb73b81eaecffb (patch)
treeb75e889a382b05afbe9d33e7f81ac2dc4059dce0
parentsys-cluster/openmpi: bump 2.0.1 (diff)
downloadgentoo-9ff3ec4217883d259652cb5e90bb73b81eaecffb.tar.gz
gentoo-9ff3ec4217883d259652cb5e90bb73b81eaecffb.tar.bz2
gentoo-9ff3ec4217883d259652cb5e90bb73b81eaecffb.zip
dev-ml/js_of_ocaml: bump to 2.8.3
Package-Manager: portage-2.3.2
-rw-r--r--dev-ml/js_of_ocaml/Manifest1
-rw-r--r--dev-ml/js_of_ocaml/js_of_ocaml-2.8.3.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-ml/js_of_ocaml/Manifest b/dev-ml/js_of_ocaml/Manifest
index 626682d19cd4..4e0d7675838f 100644
--- a/dev-ml/js_of_ocaml/Manifest
+++ b/dev-ml/js_of_ocaml/Manifest
@@ -1 +1,2 @@
DIST js_of_ocaml-2.8.2.tar.gz 1334891 SHA256 93d55c7a4883783acb3eee4c6a126993f548f1467d1f08a8d72fa30385a673c4 SHA512 07550311b53a54ec55b5b1e63acbf8eee4757d643cf9639efb035faa029cde4b47c46d732dd2fa3ec0606edf1ef094d096a375c694b0b7255ada16e0c632c4ed WHIRLPOOL 6eac8dccd5217aaa91dc3f899a6ec949afff725dcd1d60276660b0c2e4ca71faf2d55c0a747a3cab05ca55cf7962aa4dbcd2679ec4f8639c7ccbdf414a105d56
+DIST js_of_ocaml-2.8.3.tar.gz 1335811 SHA256 a77e9d4896431742604cba69fb87f9022587de86f2c6d41a6b58e9c24b103c77 SHA512 89908f3da1846f4fe24e1109ba262507221ed67d58bec1d8b7c53ec82438febbab66bdb3bec697e2880842253777167ef1563687cae414426e8ea1dcc00a323a WHIRLPOOL b299214ed367f7aa2252a76a7d49f68f219aaf3ab9901eafa354e937a7dbe4913657a6c1c6fdc85337d63c04b90a5f835b3cf9c321840528188a496f6bfc3d37
diff --git a/dev-ml/js_of_ocaml/js_of_ocaml-2.8.3.ebuild b/dev-ml/js_of_ocaml/js_of_ocaml-2.8.3.ebuild
new file mode 100644
index 000000000000..9e1c1550b85a
--- /dev/null
+++ b/dev-ml/js_of_ocaml/js_of_ocaml-2.8.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="A compiler from OCaml bytecode to javascript"
+HOMEPAGE="http://ocsigen.org/js_of_ocaml/"
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ocsigen/js_of_ocaml"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ocsigen/js_of_ocaml/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+IUSE="+async +ocamlopt doc +deriving +ppx +ppx-deriving +react +xml X"
+
+RDEPEND="
+ >=dev-lang/ocaml-3.12:=[ocamlopt?,X?]
+ >=dev-ml/lwt-2.4.4:=
+ async? ( dev-ml/async_kernel:= )
+ react? ( dev-ml/react:= dev-ml/reactiveData:= )
+ xml? ( >=dev-ml/tyxml-4:= )
+ ppx? ( dev-ml/ppx_tools:= )
+ ppx-deriving? ( dev-ml/ppx_deriving:= )
+ dev-ml/cmdliner:=
+ dev-ml/menhir:=
+ dev-ml/ocaml-base64:=
+ dev-ml/camlp4:=
+ dev-ml/cppo:=
+ dev-ml/uchar:=
+ dev-ml/ocamlbuild:=
+ deriving? ( >=dev-ml/deriving-0.6:= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ printf "\n\n" >> Makefile.conf
+ use ocamlopt || echo "BEST := byte" >> Makefile.conf
+ use ocamlopt || echo "NATDYNLINK := NO" >> Makefile.conf
+ use deriving || echo "WITH_DERIVING := NO" >> Makefile.conf
+ use X || echo "WITH_GRAPHICS := NO" >> Makefile.conf
+ use react || echo "WITH_REACT := NO" >> Makefile.conf
+ use ppx || echo "WITH_PPX := NO" >> Makefile.conf
+ use ppx-deriving || echo "WITH_PPX_PPX_DERIVING := NO" >> Makefile.conf
+ use async || echo "WITH_ASYNC := NO" >> Makefile.conf
+}
+
+src_compile() {
+ emake -j1
+ use doc && emake doc
+}
+
+src_install() {
+ findlib_src_preinst
+ emake BINDIR="${ED}/usr/bin/" install
+ dodoc CHANGES README.md
+ use doc && dohtml -r doc/api/html/
+}