summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-05 14:36:30 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-05 17:41:10 +0100
commita1262401ea611826e2b3023aba5883d315d86299 (patch)
tree3ff8396925663cb9a397e697c30ea6c5f9471512
parentsys-devel/llvm: Set libomp as default OpenMP provider in -9999, #562990 (diff)
downloadgentoo-a1262401ea611826e2b3023aba5883d315d86299.tar.gz
gentoo-a1262401ea611826e2b3023aba5883d315d86299.tar.bz2
gentoo-a1262401ea611826e2b3023aba5883d315d86299.zip
dev-python/ipykernel: Version Bump
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/ipykernel/Manifest1
-rw-r--r--dev-python/ipykernel/ipykernel-4.2.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/ipykernel/Manifest b/dev-python/ipykernel/Manifest
index 2b027e560348..c842fd7663f9 100644
--- a/dev-python/ipykernel/Manifest
+++ b/dev-python/ipykernel/Manifest
@@ -1 +1,2 @@
DIST ipykernel-4.2.0.tar.gz 80543 SHA256 723b3d4baac20f0c9cd91fc75c3e813636ecb6c6e303fb34d628c3df078985a7 SHA512 32d3d3e594031c16b3ae4736f72e168263d44be15e1a546b4f69614bef30d80ff44db00699be086897c1c384b71600f3cd7bd702b45136f51aab526c2c018f25 WHIRLPOOL e1f335dd68068e338998ac7198db43cee6d06ce19f6f6a40c7da5509beb16fed24b86eb89dcab468fc344d8d4fd090963f74f46aa119013591abf4d3463bccfa
+DIST ipykernel-4.2.1.tar.gz 500015 SHA256 081a5d4db33db58697be2d682b92f79b2c239493445f13dd457c15bc3e52c874 SHA512 cb3b27c7e6dbc93ccd4f3a288f658c33b62da28123847729be22613f7c0112d8fd79f1113bb64dcd685a7aa096835e80a6fe788b1cfde7687dab48c5af921509 WHIRLPOOL a1868031cee21cdb07f3a74a4af905a964cf0f1fd57ff928ecabc20399955ddf435295caca19eff044c177e926d61dcc395154fe4de7a108a1bfe89104d86705
diff --git a/dev-python/ipykernel/ipykernel-4.2.1.ebuild b/dev-python/ipykernel/ipykernel-4.2.1.ebuild
new file mode 100644
index 000000000000..d3f7ae6772b9
--- /dev/null
+++ b/dev-python/ipykernel/ipykernel-4.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython Kernel for Jupyter"
+HOMEPAGE="https://github.com/ipython/ipykernel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/traitlets[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ nosetests --verbose ipykernel || die
+}