summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-02-14 11:45:45 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-02-14 11:45:45 +0100
commita12a18c62f948cdc281f801596f84c6a7fd485b9 (patch)
tree27641210ad531d43f82187bb7453100230018197
parentsys-process/cronie: fix USE=anacron mess (diff)
downloadgentoo-a12a18c62f948cdc281f801596f84c6a7fd485b9.tar.gz
gentoo-a12a18c62f948cdc281f801596f84c6a7fd485b9.tar.bz2
gentoo-a12a18c62f948cdc281f801596f84c6a7fd485b9.zip
net-misc/kea: Added live ebuild.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--net-misc/kea/kea-9999.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/net-misc/kea/kea-9999.ebuild b/net-misc/kea/kea-9999.ebuild
new file mode 100644
index 000000000000..527f6a898044
--- /dev/null
+++ b/net-misc/kea/kea-9999.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs user
+
+MY_PV="${PV//_alpha/a}"
+MY_PV="${MY_PV//_beta/b}"
+MY_PV="${MY_PV//_rc/rc}"
+MY_PV="${MY_PV//_p/-P}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="High-performance production grade DHCPv4 & DHCPv6 server"
+HOMEPAGE="http://www.isc.org/kea/"
+if [[ ${PV} = 9999* ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/isc-projects/kea.git"
+else
+ SRC_URI="ftp://ftp.isc.org/isc/kea/${MY_P}.tar.gz
+ ftp://ftp.isc.org/isc/kea/${MY_PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="ISC BSD SSLeay GPL-2" # GPL-2 only for init script
+SLOT="0"
+IUSE="openssl samples"
+
+DEPEND="
+ dev-libs/boost:=
+ dev-cpp/gtest
+ dev-libs/log4cplus
+ !openssl? ( dev-libs/botan:0= )
+ openssl? ( dev-libs/openssl:= )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ [[ ${PV} = 9999* ]] && eautoreconf
+ # Brand the version with Gentoo
+ sed -i \
+ -e "/VERSION=/s:'$: Gentoo-${PR}':" \
+ configure || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with openssl)
+ $(use_enable samples install-configurations)
+ --disable-static
+ --without-werror
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ newconfd "${FILESDIR}"/${PN}-confd ${PN}
+ newinitd "${FILESDIR}"/${PN}-initd ${PN}
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+}
+
+pkg_preinst() {
+ enewgroup dhcp
+ enewuser dhcp -1 -1 /var/lib/dhcp dhcp
+}