summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-11-12 13:09:58 +0100
committerFabian Groffen <grobian@gentoo.org>2017-11-12 13:10:14 +0100
commitaaaa952fdeda1fa2f7c7a61f21063fd42c9d47c6 (patch)
treecabd9707c770fb95ab0dd081b8c09786ee5e787a
parentmedia-gfx/wings: Drop some compiler flags (bug #630406). Fix dependencies. (diff)
downloadgentoo-aaaa952fdeda1fa2f7c7a61f21063fd42c9d47c6.tar.gz
gentoo-aaaa952fdeda1fa2f7c7a61f21063fd42c9d47c6.tar.bz2
gentoo-aaaa952fdeda1fa2f7c7a61f21063fd42c9d47c6.zip
sys-devel/m4: add patch to fix crash at runtime on Darwin 17, bug #632500
Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--sys-devel/m4/files/m4-1.4.18-darwin17-printf-n.patch30
-rw-r--r--sys-devel/m4/m4-1.4.18.ebuild7
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-devel/m4/files/m4-1.4.18-darwin17-printf-n.patch b/sys-devel/m4/files/m4-1.4.18-darwin17-printf-n.patch
new file mode 100644
index 000000000000..1c77ed773c28
--- /dev/null
+++ b/sys-devel/m4/files/m4-1.4.18-darwin17-printf-n.patch
@@ -0,0 +1,30 @@
+http://lists.gnu.org/archive/html/bug-gnulib/2017-07/txtmumXtpD69v.txt
+
+extract of only the relevant hunk to avoid irrelevant conflicts
+
+From c41f233c4c38e84023a16339782ee306f03e7f59 Mon Sep 17 00:00:00 2001
+From: Paul Eggert <address@hidden>
+Date: Fri, 7 Jul 2017 14:10:20 -0700
+Subject: [PATCH] vasnprintf: port to macOS 10.13
+
+Problem reported by comex in:
+http://lists.gnu.org/archive/html/bug-gnulib/2017-07/msg00056.html
+* lib/vasnprintf.c (VASNPRINTF): Don’t use %n on macOS.
+
+diff --git a/lib/vasnprintf.c b/lib/vasnprintf.c
+index 9c2af0e..fecaf27 100644
+--- a/lib/vasnprintf.c
++++ b/lib/vasnprintf.c
+@@ -4869,7 +4869,11 @@ VASNPRINTF (DCHAR_T *resultbuf, size_t *lengthp,
+ #endif
+ *fbp = dp->conversion;
+ #if USE_SNPRINTF
+-# if !(((__GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 3)) && !defined __UCLIBC__) || ((defined _WIN32 || defined __WIN32__) && ! defined __CYGWIN__))
++# if ! (((__GLIBC__ > 2 \
++ || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 3)) \
++ && !defined __UCLIBC__) \
++ || (defined __APPLE__ && defined __MACH__) \
++ || ((defined _WIN32 || defined __WIN32__) && ! defined __CYGWIN__))
+ fbp[1] = '%';
+ fbp[2] = 'n';
+ fbp[3] = '\0';
diff --git a/sys-devel/m4/m4-1.4.18.ebuild b/sys-devel/m4/m4-1.4.18.ebuild
index 1bb440ec6f2a..f249374d1d2b 100644
--- a/sys-devel/m4/m4-1.4.18.ebuild
+++ b/sys-devel/m4/m4-1.4.18.ebuild
@@ -3,6 +3,8 @@
EAPI="5"
+inherit eutils
+
DESCRIPTION="GNU macro processor"
HOMEPAGE="https://www.gnu.org/software/m4/m4.html"
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
@@ -16,6 +18,11 @@ IUSE="examples"
DEPEND="app-arch/xz-utils"
RDEPEND=""
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-darwin17-printf-n.patch
+ default
+}
+
src_configure() {
# Disable automagic dependency over libsigsegv; see bug #278026
export ac_cv_libsigsegv=no