summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-07-26 21:29:01 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-07-26 21:29:14 +0100
commitaaf34a56f3ed4c5f5c6f0381b9e247cb65f1d77c (patch)
treeb0963a8418c7210df199a1d889952a3639cd005b
parentwww-plugins/chrome-binary-plugins: automated update (60.0.3112.78, 61.0.3163.... (diff)
downloadgentoo-aaf34a56f3ed4c5f5c6f0381b9e247cb65f1d77c.tar.gz
gentoo-aaf34a56f3ed4c5f5c6f0381b9e247cb65f1d77c.tar.bz2
gentoo-aaf34a56f3ed4c5f5c6f0381b9e247cb65f1d77c.zip
dev-libs/nanomsg: make tests sequential
Parallel tests overwrite one another and SIGSEGV ./test binary. Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--dev-libs/nanomsg/nanomsg-1.0.0.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-libs/nanomsg/nanomsg-1.0.0.ebuild b/dev-libs/nanomsg/nanomsg-1.0.0.ebuild
index b2e2b2fb1d47..5f9fa48d2632 100644
--- a/dev-libs/nanomsg/nanomsg-1.0.0.ebuild
+++ b/dev-libs/nanomsg/nanomsg-1.0.0.ebuild
@@ -34,3 +34,12 @@ multilib_src_configure() {
fi
cmake-utils_src_configure
}
+
+multilib_src_test() {
+ local myctestargs=(
+ # All tests overwrite same ./test binary
+ # That causes SIGSEGV when ran in parallel
+ -j1
+ )
+ cmake-utils_src_test
+}