summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-01-14 17:13:20 -0500
committerMike Gilbert <floppym@gentoo.org>2016-01-14 17:14:04 -0500
commitaaf891d2b0f19dd6b9ed6d33720ad0ae477195b3 (patch)
tree0e58022012629c0073c0a2d4d53f87b15b83973c
parentnet-irc/weechat: version bump to 1.4 (diff)
downloadgentoo-aaf891d2b0f19dd6b9ed6d33720ad0ae477195b3.tar.gz
gentoo-aaf891d2b0f19dd6b9ed6d33720ad0ae477195b3.tar.bz2
gentoo-aaf891d2b0f19dd6b9ed6d33720ad0ae477195b3.zip
sys-libs/efivar: Workaround rename of linux/nvme.h
Bug: https://bugs.gentoo.org/571548 Package-Manager: portage-2.2.26_p103
-rw-r--r--sys-libs/efivar/efivar-0.21.ebuild4
-rw-r--r--sys-libs/efivar/files/0.21-nvme_ioctl.h.patch30
2 files changed, 33 insertions, 1 deletions
diff --git a/sys-libs/efivar/efivar-0.21.ebuild b/sys-libs/efivar/efivar-0.21.ebuild
index 29fb8702cd1d..9053afffe883 100644
--- a/sys-libs/efivar/efivar-0.21.ebuild
+++ b/sys-libs/efivar/efivar-0.21.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -19,6 +19,8 @@ DEPEND="${RDEPEND}"
src_prepare() {
epatch "${FILESDIR}/0.21-initializer.patch"
+ epatch "${FILESDIR}/0.21-nvme_ioctl.h.patch"
+ epatch_user
}
src_configure() {
diff --git a/sys-libs/efivar/files/0.21-nvme_ioctl.h.patch b/sys-libs/efivar/files/0.21-nvme_ioctl.h.patch
new file mode 100644
index 000000000000..221ec5a73140
--- /dev/null
+++ b/sys-libs/efivar/files/0.21-nvme_ioctl.h.patch
@@ -0,0 +1,30 @@
+From ae0869b71a90bc14e67f3c917bd9c96db25c99a6 Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Thu, 14 Jan 2016 17:02:31 -0500
+Subject: [PATCH] Workaround rename of linux/nvme.h
+
+Bug: https://bugs.gentoo.org/571548
+---
+ src/linux.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/src/linux.c b/src/linux.c
+index 5ebc151..e551377 100644
+--- a/src/linux.c
++++ b/src/linux.c
+@@ -22,7 +22,12 @@
+ #include <inttypes.h>
+ #include <limits.h>
+ #include <linux/ethtool.h>
++#include <linux/version.h>
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 4, 0)
++#include <linux/nvme_ioctl.h>
++#else
+ #include <linux/nvme.h>
++#endif
+ #include <linux/sockios.h>
+ #include <net/if.h>
+ #include <scsi/scsi.h>
+--
+2.7.0
+