summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-06-16 21:07:20 +0300
committerMart Raudsepp <leio@gentoo.org>2018-06-16 21:27:19 +0300
commitad232d5ad5f11e64951cdcd6438c5319466f0d4e (patch)
tree56f70dfab25cf8a409e25ed8903c954b005b6df7
parentmedia-plugins/gst-plugins-libav: bump to 1.14.1 (diff)
downloadgentoo-ad232d5ad5f11e64951cdcd6438c5319466f0d4e.tar.gz
gentoo-ad232d5ad5f11e64951cdcd6438c5319466f0d4e.tar.bz2
gentoo-ad232d5ad5f11e64951cdcd6438c5319466f0d4e.zip
media-plugins/gst-plugins-vaapi: bump to 1.14.1, rework OpenGL handling
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--media-plugins/gst-plugins-vaapi/Manifest1
-rw-r--r--media-plugins/gst-plugins-vaapi/files/1.14.1-fix_no_GL.patch33
-rw-r--r--media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.14.1.ebuild112
-rw-r--r--media-plugins/gst-plugins-vaapi/metadata.xml1
4 files changed, 147 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-vaapi/Manifest b/media-plugins/gst-plugins-vaapi/Manifest
index 7108b9ee3143..64a3c974198e 100644
--- a/media-plugins/gst-plugins-vaapi/Manifest
+++ b/media-plugins/gst-plugins-vaapi/Manifest
@@ -1,2 +1,3 @@
DIST gstreamer-vaapi-1.12.3.tar.xz 996360 BLAKE2B d34804f278780e073b553542258f865a93e62d48b0cd276fa7fa47e54f03a5484d7ddc61851f75e583dbcc03d6dbfce6a9c8df0e4c1c6174dfaefdcf867ca068 SHA512 c70da985b1c0c5048be8d83ba62622b9064d78193433b897d54824125de3eeabe4f9765ec0a5199a2d9eaa91d0625dfa2b7ef3d8245b23cf57361691d72b1dc4
DIST gstreamer-vaapi-1.12.4.tar.xz 998844 BLAKE2B e37d6f66054e46e421ffbd4c27362bba0fb2ad57bfccb4891ba85573dec18ca304654336768a519c202bda0e829b80ab75a5708ddfc1dc9751774b4ef783a16d SHA512 2251395f77be8d17837f4b0d38a2271155a5fbd57560fac9334660abb34a4f609dda8d9714bfa8f64395a85d3fa336f7ad1b8e8e7490b5288843fbe3d1dbd7f5
+DIST gstreamer-vaapi-1.14.1.tar.xz 1064992 BLAKE2B bae42e3cafc6d1e5799a8ef795f9e1f6a6ac60b6878aea1aed81550fd7e408c5104b5ea89d6e5f7535ac8d21fe5f14fccf061e15eb68a7c1c60c29ad4a4deabb SHA512 f1eecb61cb92439d93a47ac162a5cda8a456dbb205594f378e8adf98c45e4cd59553ccfd3bbcf1c6a568c6af5e7834bbfb0ea17610f0c7e7c9e268a4eeb5b020
diff --git a/media-plugins/gst-plugins-vaapi/files/1.14.1-fix_no_GL.patch b/media-plugins/gst-plugins-vaapi/files/1.14.1-fix_no_GL.patch
new file mode 100644
index 000000000000..d0a34b5bd0c2
--- /dev/null
+++ b/media-plugins/gst-plugins-vaapi/files/1.14.1-fix_no_GL.patch
@@ -0,0 +1,33 @@
+From 45fb111850955d9192e43b9dbcb2ef8e3974e58d Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?V=C3=ADctor=20Manuel=20J=C3=A1quez=20Leal?=
+ <vjaquez@igalia.com>
+Date: Mon, 21 May 2018 13:27:14 +0200
+Subject: plugins: guard GstGL code
+
+---
+ gst/vaapi/gstvaapipluginutil.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/gst/vaapi/gstvaapipluginutil.c b/gst/vaapi/gstvaapipluginutil.c
+index fa25131..648c91b 100644
+--- a/gst/vaapi/gstvaapipluginutil.c
++++ b/gst/vaapi/gstvaapipluginutil.c
+@@ -246,6 +246,7 @@ gst_vaapi_create_display_from_gl_context (GstObject * gl_context_object)
+ static void
+ gst_vaapi_find_gl_context (GstElement * element)
+ {
++#if USE_GST_GL_HELPERS
+ GstVaapiPluginBase *const plugin = GST_VAAPI_PLUGIN_BASE (element);
+
+ /* if the element is vaapisink or any vaapi encoder it doesn't need
+@@ -282,6 +283,7 @@ no_valid_gl_display:
+ gst_object_replace (&plugin->gl_other_context, NULL);
+ return;
+ }
++#endif
+ }
+
+ gboolean
+--
+cgit v1.1
+
diff --git a/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.14.1.ebuild b/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.14.1.ebuild
new file mode 100644
index 000000000000..46ecb7501606
--- /dev/null
+++ b/media-plugins/gst-plugins-vaapi/gst-plugins-vaapi-1.14.1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit ltprune multilib-minimal
+
+MY_PN="gstreamer-vaapi"
+DESCRIPTION="Hardware accelerated video decoding through VA-API plugin for GStreamer"
+HOMEPAGE="https://cgit.freedesktop.org/gstreamer/gstreamer-vaapi"
+SRC_URI="https://gstreamer.freedesktop.org/src/${MY_PN}/${MY_PN}-${PV}.tar.xz"
+
+LICENSE="LGPL-2.1" # TODO: Check for "or later"
+SLOT="1.0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+drm +egl gles2 +opengl wayland +X" # Keep default enabled IUSE in sync with gst-plugins-base and libva
+
+# gst-vaapi configure is based around GL platform mainly, unlike gst-plugins-bad that goes by GL API mainly; for less surprises,
+# we design gst-vaapi ebuild in terms of GL API as main choice as well, meaning that USE opengl and/or gles2 is required to
+# enable opengl support at all and choices get chained from there.
+# One or multiple video output are required: drm, x11, glx, egl and/or wayland;
+# but GL API is our main trigger, thus USE=egl should be ineffective if neither gles2 or opengl is enabled;
+# So "|| ( drm egl opengl wayland X )" would be wrong, because egl isn't built with USE="egl -opengl -gles2", ending up with no video outputs.
+# As we ensure at least one working GL output with other REQUIRED_USE, we can put gles2/opengl in REQUIRED_USE instead of egl, solving the issue.
+# gles2 API only supported windowing system (on linux) is EGL, so require it
+# opengl API only supported windowing systems (on linux) are EGL and GLX, so require one of them (glx is enabled with USE="opengl X")
+REQUIRED_USE="
+ || ( drm gles2 opengl wayland X )
+ gles2? ( egl )
+ opengl? ( || ( egl X ) )
+"
+
+# glx doesn't require libva-glx (libva[opengl]) afaics, only by tests/test-display.c
+# USE flag behavior:
+# 'drm' enables vaapi drm support
+# 'egl' enables EGL platform support (but only if also 'opengl||gles2')
+# - 'egl' is exposed as a USE flag mainly to get EGL support instead of or in addition to GLX support with desktop GL while keeping it optional for pure GLX cases;
+# it's always required with USE=gles2, thus USE="gles2 opengl X" will require and build desktop GL EGL platform support as well on top of GLX, which doesn't add extra deps at that point.
+# 'gles2' enables GLESv2 or GLESv3 based GL API support
+# 'opengl' enables desktop OpenGL based GL API support
+# 'wayland' enables non-GL Wayland support; wayland EGL support when combined with 'egl' (but only if also 'opengl||gles2')
+# 'X' enables non-GL X support; GLX support when combined with 'opengl'
+# gst-plugins-bad still needed for codecparsers (GL libraries moved to -base); checked for 1.14 (recheck for 1.16)
+GST_REQ="1.14.1"
+GL_DEPS="
+ >=media-libs/gst-plugins-base-${GST_REQ}:${SLOT}[egl?,gles2?,opengl?,wayland?,X?]
+ media-libs/mesa[gles2?,egl?,${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ >=dev-libs/glib-2.40:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${GST_REQ}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${GST_REQ}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-bad-${GST_REQ}:${SLOT}[${MULTILIB_USEDEP}]
+ >=x11-libs/libva-1.4.0:=[drm?,wayland?,X?,${MULTILIB_USEDEP}]
+ drm? (
+ >=virtual/libudev-208:=[${MULTILIB_USEDEP}]
+ >=x11-libs/libdrm-2.4.46[${MULTILIB_USEDEP}]
+ )
+ gles2? ( ${GL_DEPS} )
+ opengl? ( ${GL_DEPS} )
+ wayland? ( >=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}] )
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrandr-1.4.2[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+PATCHES=( "${FILESDIR}"/${PV}-fix_no_GL.patch )
+
+multilib_src_configure() {
+ local myconf=()
+ if use opengl || use gles2; then
+ myconf+=(
+ $(use_enable egl)
+ --with-glapi=$(usex opengl 'gl,' '')$(usex gles2 'gles2,gles3' '') # It's fine to have extra commas passed
+ )
+ else
+ myconf+=(
+ --disable-egl
+ --without-glapi
+ )
+ fi
+
+ if use opengl && use X; then
+ myconf+=( --enable-glx )
+ else
+ myconf+=( --disable-glx )
+ fi
+
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-static \
+ --disable-debug \
+ --disable-examples \
+ --enable-encoders \
+ $(use_enable drm) \
+ $(use_enable X x11) \
+ $(use_enable wayland) \
+ --without-gtk \
+ "${myconf[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --modules
+}
diff --git a/media-plugins/gst-plugins-vaapi/metadata.xml b/media-plugins/gst-plugins-vaapi/metadata.xml
index be2c01c84135..73b9785ae4dc 100644
--- a/media-plugins/gst-plugins-vaapi/metadata.xml
+++ b/media-plugins/gst-plugins-vaapi/metadata.xml
@@ -8,5 +8,6 @@
<use>
<flag name="drm">Enable DRM renderer</flag>
<flag name="egl">Enable EGL support</flag>
+ <flag name="gles2">Enable GLESv2 and GLESv3 support</flag>
</use>
</pkgmetadata>