summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2019-06-30 11:17:29 +0200
committerJohannes Huber <johu@gentoo.org>2019-06-30 11:17:58 +0200
commitb1068f2b88c0dd26dc8914e68de02b89eadb220f (patch)
tree8e0d4f314bd9a61076f1a9db86f494da8a47372d
parentdev-python/pysol_cards: 0.6.2 version bump (diff)
downloadgentoo-b1068f2b88c0dd26dc8914e68de02b89eadb220f.tar.gz
gentoo-b1068f2b88c0dd26dc8914e68de02b89eadb220f.tar.bz2
gentoo-b1068f2b88c0dd26dc8914e68de02b89eadb220f.zip
net-vpn/openfortivpn: Version bump 1.10.0
Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Johannes Huber <johu@gentoo.org>
-rw-r--r--net-vpn/openfortivpn/Manifest1
-rw-r--r--net-vpn/openfortivpn/openfortivpn-1.10.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/net-vpn/openfortivpn/Manifest b/net-vpn/openfortivpn/Manifest
index 1e95cf9ba08e..cf24e2acb8a0 100644
--- a/net-vpn/openfortivpn/Manifest
+++ b/net-vpn/openfortivpn/Manifest
@@ -1 +1,2 @@
+DIST openfortivpn-1.10.0.tar.gz 74872 BLAKE2B 98b6840aedb72592d95f12c011823119f1622154f1ebe20da867e6e0b8b2da666928a74d8712564d743d37b9c1ef24d9e1764cd11e86b53d4969594f549e68d6 SHA512 504cc489c298a59b958afe8278e3d7089fa2f5c21b0ce4c1c6e8bd99ccc670f86ba48812b844dffae04930d3398ac38e7a27768022e972f45b81f19e8400801e
DIST openfortivpn-1.9.0.tar.gz 71903 BLAKE2B 0f37b782944e96ba043b82bb172cdd90badf501a31f4ef253cdfc2ea59f4d478ccb4de15514df279059ad41ff3d872e2521ebc64af56844e5d3dd719e8965e18 SHA512 bea07d173f84562e37bbd925fc9ca1ffc4b91442792d29dd5f78849a44df7f4f677f306bb9020ca3ebdc4da1d5635bb4e746455c4ccf9ef1598c8100dcb2df7a
diff --git a/net-vpn/openfortivpn/openfortivpn-1.10.0.ebuild b/net-vpn/openfortivpn/openfortivpn-1.10.0.ebuild
new file mode 100644
index 000000000000..ceec9d12a8eb
--- /dev/null
+++ b/net-vpn/openfortivpn/openfortivpn-1.10.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools linux-info
+
+DESCRIPTION="Fortinet compatible VPN client"
+HOMEPAGE="https://github.com/adrienverge/openfortivpn"
+SRC_URI="https://github.com/adrienverge/openfortivpn/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3-with-openssl-exception openssl"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libressl"
+
+DEPEND="
+ net-dialup/ppp
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~PPP ~PPP_ASYNC"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' Makefile.am || die "Failed to remove -Werror from Makefile.am"
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ keepdir /etc/openfortivpn
+}