summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-06-30 06:35:30 +0200
committerHans de Graaff <graaff@gentoo.org>2019-06-30 06:35:30 +0200
commitb188da13ccc5ab962d5064359cefb67e2ba81c2b (patch)
tree774598c78f295bd5d6ec9b65fefd80702986ea9f
parentnet-irc/irssi: Version bump, security bug #688944 (diff)
downloadgentoo-b188da13ccc5ab962d5064359cefb67e2ba81c2b.tar.gz
gentoo-b188da13ccc5ab962d5064359cefb67e2ba81c2b.tar.bz2
gentoo-b188da13ccc5ab962d5064359cefb67e2ba81c2b.zip
dev-ruby/rspec-core: add 3.8.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
-rw-r--r--dev-ruby/rspec-core/Manifest1
-rw-r--r--dev-ruby/rspec-core/rspec-core-3.8.2.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/dev-ruby/rspec-core/Manifest b/dev-ruby/rspec-core/Manifest
index c7cd2db4380c..e52ccce19bc2 100644
--- a/dev-ruby/rspec-core/Manifest
+++ b/dev-ruby/rspec-core/Manifest
@@ -2,3 +2,4 @@ DIST rspec-core-2.99.2-git.tgz 212935 BLAKE2B 37195012f79aca3a1959f9143e2f5cbab6
DIST rspec-core-3.7.1-git.tgz 376819 BLAKE2B 6747ffd8f2d426718376b51356d8838a7db0d0246ee619e8edef30bd9f7aeeb80bd0488e4fc73b0a00d119074c35055f6b9d0cbbe6160ae78d0727ce9848a710 SHA512 1561d044281c1b8b97cc89033ad991548fa74abbc5f20d3951d3f3de754c581a027f9ccb2bd0107c05e744d3b2804555cf4cf207e72adf365b28fc7ce052dab8
DIST rspec-core-3.8.0-git.tgz 386022 BLAKE2B e827f006fe9f05f93b741d021bbb108ae3e98cd23f3388c1fdf2a87d8be349c04e91c810cbb7c47cc99ce99a00f62e13eb01a927b8b89d54dfa437ed46b1d24f SHA512 6d3f431a1f9485009f5029bea967f36cb789be8cf33722b36c40df44e12a2284674c6c8af333bfe8ba8825e032576569fd42c92f798988faad732ac3a720c5e6
DIST rspec-core-3.8.1-git.tgz 387459 BLAKE2B 34888ef32e841633710cf2ec312a2a5006cbe9bb92ad16a646b7c7ef7ebca693db12de4240f4a03bbc01ecc50bc08ee676600b708ba72e1f34ad11d007bf6377 SHA512 fb9d6098e9c43b0fb0b7344521861c6095bee09d3fcaec526bed7b67f21cdff067a4a913f7cf17af9436587a20caab172670058785f138f50103708475057941
+DIST rspec-core-3.8.2-git.tgz 387788 BLAKE2B e6cf93f5cef70f53039b6c22fc875cff58eaff4c0c7d4e75d23dedfbe16081980c6fe575d3082dbe6ed9edc8e81f0cbb9e29618da78af40a94c517a859f9d793 SHA512 2fe88ee3d66ecf134562dfa7b1001f23a1a750640c4f65cdec64d85dd735e0fde9d91479286f8f9c38064746813f41632d12d21b3926724ccd7c9ded50d2a7c8
diff --git a/dev-ruby/rspec-core/rspec-core-3.8.2.ebuild b/dev-ruby/rspec-core/rspec-core-3.8.2.ebuild
new file mode 100644
index 000000000000..5103fd0576e3
--- /dev/null
+++ b/dev-ruby/rspec-core/rspec-core-3.8.2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+# Also install this custom path since internal paths depend on it.
+RUBY_FAKEGEM_EXTRAINSTALL="exe"
+
+RUBY_FAKEGEM_GEMSPEC="rspec-core.gemspec"
+
+inherit ruby-fakegem eapi7-ver
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec-core"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="highlight"
+
+SUBVERSION="$(ver_cut 1-2)"
+
+ruby_add_rdepend "
+ =dev-ruby/rspec-support-${SUBVERSION}*
+ !!<dev-ruby/rspec-core-2.14.8-r4
+ highlight? ( >=dev-ruby/coderay-1.1.1 )
+"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/nokogiri-1.5.2
+ >=dev-ruby/coderay-1.1.1
+ dev-ruby/syntax
+ >=dev-ruby/thread_order-1.1.0
+ >=dev-ruby/rspec-expectations-3.8.0:3
+ >=dev-ruby/rspec-mocks-2.99.0:3
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Avoid dependency on cucumber since we can't run the features anyway.
+ sed -i -e '/[Cc]ucumber/ s:^:#:' Rakefile || die
+
+ # Duplicate exe also in bin. We can't change it since internal stuff
+ # also depends on this and fixing that is going to be fragile. This
+ # way we can at least install proper bin scripts.
+ cp -R exe bin || die
+
+ # Avoid unneeded dependency on git.
+ sed -i -e 's/git ls-files --/find/' rspec-core.gemspec || die
+
+ # Avoid aruba dependency so that we don't end up in dependency hell.
+ sed -i -e '/ArubaLoader/,/^end/ s:^:#:' -e '/Aruba/ s:^:#:' spec/spec_helper.rb || die
+ rm -f spec/support/aruba_support.rb || die
+ rm -f spec/integration/{bisect_runners,failed_line_detection,filtering,order,persistence_failures,suite_hooks_errors}_spec.rb || die
+ rm -f spec/integration/{spec_file_load_errors,output_stream,fail_if_no_examples}_spec.rb || die
+
+ # Avoid a spec failing due to path issues
+ sed -i -e '/does not load files in the default path when run by ruby/,/end/ s:^:#:' \
+ spec/rspec/core/configuration_spec.rb || die
+
+ # Avoid a spec that depends on dev-ruby/rspec to lessen circular
+ # dependencies, bug 662328
+ sed -i -e '/loads mocks and expectations when the constants are referenced/askip "gentoo: bug 662328"' spec/rspec/core_spec.rb || die
+
+ # Avoid a spec depending on specifics on local networks
+ # This fails when localhost resolves to ::1 which may be a
+ # ruby regression in the drb/acl code.
+ rm -f spec/rspec/core/bisect/server_spec.rb || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby -e:'${RUBY}' -e:' spec/rspec/core_spec.rb || die
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -Ilib bin/rspec spec || die "Tests failed."
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rspec /usr/bin/rspec-3 'gem "rspec", "~>3.0"'
+}