summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 23:41:57 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-10 00:08:09 -0500
commitb263f451c8bb43641886cee17cdc5540c86cad08 (patch)
tree264dacd8d96e26754c9ac9c183a252e6024b739f
parentdev-python/python-swiftclient: 3.7.0 bump (diff)
downloadgentoo-b263f451c8bb43641886cee17cdc5540c86cad08.tar.gz
gentoo-b263f451c8bb43641886cee17cdc5540c86cad08.tar.bz2
gentoo-b263f451c8bb43641886cee17cdc5540c86cad08.zip
dev-python/python-cinderclient: 4.1.0 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-python/python-cinderclient/Manifest1
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-4.1.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python-cinderclient/Manifest b/dev-python/python-cinderclient/Manifest
index 69e3a1b45453..aaade8212fbd 100644
--- a/dev-python/python-cinderclient/Manifest
+++ b/dev-python/python-cinderclient/Manifest
@@ -1,3 +1,4 @@
DIST python-cinderclient-3.1.0.tar.gz 278247 BLAKE2B d5fb6b3f74c70fd58cdc8a2cf2ea7a57935fd3246de035ebfc84d1acb037ff309ff1de2954c373a453f623e78b6c84bfca194f77273420eaa46ee291a2a97c28 SHA512 6d828a96802d9a5118ab3b463ed9c8619530a69a1ca153f0c3d737e26bd692864ad2ba4c79e74a18ebf820222a75b81a9735f63c989817797689d8f399f76394
DIST python-cinderclient-3.5.0.tar.gz 284317 BLAKE2B c231b2d67071dc01521e271cdae19d0e1bb8af387780b4f855631ae248e156110888eddd63684102d5b5769840d31e622d9db1e24ecdb90ddda06e803c6586fd SHA512 0ee11c19b404c5f335422a5a18d01529330dc8d39b58c5f8b6be28a0e682858f1fea5f21bfcfc2a272a556f1a3a61fa6a0379fadbe79b65a4ad72cccf42a6223
DIST python-cinderclient-4.0.1.tar.gz 282913 BLAKE2B 22b20bf80950dd501b7ae89350a7c1d5f44b3489f07063160f7d69b0160b3100536dfeae7b609e709ce2eb963865279faf22ef176ffb60f33b4adc6e2d527fdc SHA512 b74f0d83019ede4598490c8bf4b675bbc75c362ce08099c8590e925d419ee2d55c23ce4d4815d6c31a3aeaf6276f4e72f4801bd629b56ac045025a181030d03c
+DIST python-cinderclient-4.1.0.tar.gz 288464 BLAKE2B 492baefef164e74eca662cbde31b77ae751730420782b9926d265548d064cef08e993279482c566f1c810a62f6cda657e59680d511e5633a7c17be8dbc6fe7c1 SHA512 e895e90dd12802c5991bd05c825b712b30bded38a5dd0dc8d845949cc7e76440959a426cb680447496cccdbb0d5aa31f3b982838a91c7b36e8e31bbaa3fb7b7a
diff --git a/dev-python/python-cinderclient/python-cinderclient-4.1.0.ebuild b/dev-python/python-cinderclient/python-cinderclient-4.1.0.ebuild
new file mode 100644
index 000000000000..bd35bcef49c9
--- /dev/null
+++ b/dev-python/python-cinderclient/python-cinderclient-4.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Cinder API"
+HOMEPAGE="https://launchpad.net/python-cinderclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}