summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2018-08-21 13:20:25 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-08 10:26:52 +0200
commitb2b0b872257c6602af3eef5724403660316b8bc9 (patch)
tree22f0178cb73e1ad1fcab34ac5a6ebe6a15ee4b89
parentnet-libs/google-cloud-cpp: Add gtest dep (diff)
downloadgentoo-b2b0b872257c6602af3eef5724403660316b8bc9.tar.gz
gentoo-b2b0b872257c6602af3eef5724403660316b8bc9.tar.bz2
gentoo-b2b0b872257c6602af3eef5724403660316b8bc9.zip
net-dns/knot: bump to 2.7.2 & 2.6.9
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--net-dns/knot/Manifest2
-rw-r--r--net-dns/knot/knot-2.6.9.ebuild103
-rw-r--r--net-dns/knot/knot-2.7.2.ebuild105
-rw-r--r--net-dns/knot/metadata.xml6
4 files changed, 216 insertions, 0 deletions
diff --git a/net-dns/knot/Manifest b/net-dns/knot/Manifest
index 544eb05882eb..f7f927046c94 100644
--- a/net-dns/knot/Manifest
+++ b/net-dns/knot/Manifest
@@ -1,3 +1,5 @@
DIST knot-2.5.7.tar.xz 1084656 BLAKE2B c2d583625a19f6a61248b3b42cdf14f5bb2bdbafdb20be6b0813744095a4016a4be2eb5e2dfaff0628238c60153480175a86706db0b88569d76156f86ba33968 SHA512 96e375f556309bb89cea982dda169cef70c23d03c48282110e47a44849c1102cd37d98aa7650781b399f5d932b724b8a935f0b9e55e4920465ae7b74a0d1d55a
DIST knot-2.6.6.tar.xz 1120340 BLAKE2B 374d9b78f2ef2143d1221fced29184a52ee3773abd7cb08b6b48910f6ffc0f7c4f07c00d17d28344c93d71a709363bdf855d20587f87da622153c44d08d85fd8 SHA512 bd7a36decc74041f12971045cd69b8cc9e7ecce68f8d2b4cddc9b5f23ee96e8ed290d98fe9e6c441d6727ad4395bea615cbd9ec19cc641abce19ef8da6371972
DIST knot-2.6.8.tar.xz 1121740 BLAKE2B 2da7e20630fec53952c6892ee4002afeee0c36ef5cb271346caf1760389abaacac7f11dd0b24950ff5eedca40564ccf70c25b5c8548564bdd61c78a1bd9cf93e SHA512 3300985bd4fbf88b58fbb5ba06bdd3dcbe7a50885baa89f9db47811c071a93994a2b17a0dbd27d185feade056ed5d65eef712eedb26de5a4101da363a7c24967
+DIST knot-2.6.9.tar.xz 1126872 BLAKE2B c15b7e61ccad5417ce53f3d3895014931a2825835958735bdd9459634d9d9f39d6bb3681036772e6a510570a7f6a8afc8b0de5e77e67778831dc6415378889fe SHA512 80fcbef17c3e6685c09eb57e59001a5f298a083c18ce077dc2f2d1fadbe7c36e543c205c0820bc7971a8ed7547897aec408f51e1a9555a50dae82d047fac471b
+DIST knot-2.7.2.tar.xz 1148880 BLAKE2B bf3042d762d2b66f47dbd27a1c9ecd03d111259c7db82254c1175e660497fd8343c3f1cf1cc14e6068cb3d3618931b659888a7b97d7d6e4ba9d0e74c00540e31 SHA512 e09f8a38e975ff4f90db59db9ae8a6baaca9b0cbc9c2ecd37225febfe718b7c2038ae45481ed830dc66f2b70d8312266e2dc7cb54a0aa0fdc02c87ca42bac96d
diff --git a/net-dns/knot/knot-2.6.9.ebuild b/net-dns/knot/knot-2.6.9.ebuild
new file mode 100644
index 000000000000..e4afd6cf3d88
--- /dev/null
+++ b/net-dns/knot/knot-2.6.9.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd user
+
+DESCRIPTION="High-performance authoritative-only DNS server"
+HOMEPAGE="https://www.knot-dns.cz/"
+SRC_URI="https://secure.nic.cz/files/knot-dns/${P/_/-}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+KNOT_MODULES=(
+ "+dnsproxy"
+ "dnstap"
+ "+noudp"
+ "+onlinesign"
+ "rosedb"
+ "+rrl"
+ "+stats"
+ "+synthrecord"
+ "+whoami"
+)
+IUSE="doc caps +fastparser idn libidn2 systemd +utils ${KNOT_MODULES[@]}"
+
+RDEPEND="
+ dev-db/lmdb
+ dev-libs/libedit
+ dev-libs/userspace-rcu
+ dev-python/lmdb
+ net-libs/gnutls
+ caps? ( sys-libs/libcap-ng )
+ dnstap? (
+ dev-libs/fstrm
+ dev-libs/protobuf-c
+ )
+ idn? (
+ !libidn2? ( net-dns/libidn:* )
+ libidn2? ( net-dns/libidn2 )
+ )
+ systemd? ( sys-apps/systemd )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ local u
+ local my_conf=(
+ --with-storage="${EPREFIX}/var/lib/${PN}"
+ --with-rundir="${EPREFIX}/var/run/${PN}"
+ $(use_enable fastparser)
+ $(use_enable dnstap)
+ $(use_enable doc documentation)
+ $(use_enable utils utilities)
+ --enable-systemd=$(usex systemd)
+ $(use_with idn libidn)
+ )
+
+ for u in "${KNOT_MODULES[@]#+}"; do
+ my_conf+=("$(use_with ${u} module-${u})")
+ done
+
+ econf "${my_conf[@]}"
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ emake -C doc html
+ HTML_DOCS=( doc/_build/html/{*.html,*.js,_sources,_static} )
+ fi
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+
+ rmdir "${D}var/run/${PN}" "${D}var/run/" || die
+ keepdir /var/lib/${PN}
+
+ newinitd "${FILESDIR}/knot.init" knot
+ if use systemd; then
+ systemd_newunit "${FILESDIR}/knot-1.service" knot.service
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ enewgroup knot 53
+ enewuser knot 53 -1 /var/lib/knot knot
+}
diff --git a/net-dns/knot/knot-2.7.2.ebuild b/net-dns/knot/knot-2.7.2.ebuild
new file mode 100644
index 000000000000..2da8f50f93a2
--- /dev/null
+++ b/net-dns/knot/knot-2.7.2.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd user
+
+DESCRIPTION="High-performance authoritative-only DNS server"
+HOMEPAGE="https://www.knot-dns.cz/"
+SRC_URI="https://secure.nic.cz/files/knot-dns/${P/_/-}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+KNOT_MODULES=(
+ "+cookies"
+ "+dnsproxy"
+ "dnstap"
+ "geoip"
+ "+noudp"
+ "+onlinesign"
+ "+rrl"
+ "+stats"
+ "+synthrecord"
+ "+whoami"
+)
+IUSE="doc caps +fastparser idn libidn2 systemd +utils ${KNOT_MODULES[@]}"
+
+RDEPEND="
+ dev-db/lmdb
+ dev-libs/libedit
+ dev-libs/userspace-rcu
+ dev-python/lmdb
+ net-libs/gnutls
+ caps? ( sys-libs/libcap-ng )
+ dnstap? (
+ dev-libs/fstrm
+ dev-libs/protobuf-c
+ )
+ geoip? ( dev-libs/libmaxminddb )
+ idn? (
+ !libidn2? ( net-dns/libidn:* )
+ libidn2? ( net-dns/libidn2 )
+ )
+ systemd? ( sys-apps/systemd )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )
+"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ local u
+ local my_conf=(
+ --with-storage="${EPREFIX}/var/lib/${PN}"
+ --with-rundir="${EPREFIX}/var/run/${PN}"
+ $(use_enable fastparser)
+ $(use_enable dnstap)
+ $(use_enable doc documentation)
+ $(use_enable utils utilities)
+ --enable-systemd=$(usex systemd)
+ $(use_with idn libidn)
+ )
+
+ for u in "${KNOT_MODULES[@]#+}"; do
+ my_conf+=("$(use_with ${u} module-${u})")
+ done
+
+ econf "${my_conf[@]}"
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ emake -C doc html
+ HTML_DOCS=( doc/_build/html/{*.html,*.js,_sources,_static} )
+ fi
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+
+ rmdir "${D}var/run/${PN}" "${D}var/run/" || die
+ keepdir /var/lib/${PN}
+
+ newinitd "${FILESDIR}/knot.init" knot
+ if use systemd; then
+ systemd_newunit "${FILESDIR}/knot-1.service" knot.service
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ enewgroup knot 53
+ enewuser knot 53 -1 /var/lib/knot knot
+}
diff --git a/net-dns/knot/metadata.xml b/net-dns/knot/metadata.xml
index 9245494df34e..b4c4ececc733 100644
--- a/net-dns/knot/metadata.xml
+++ b/net-dns/knot/metadata.xml
@@ -10,6 +10,9 @@
<name>Proxy Maintainers</name>
</maintainer>
<use>
+ <flag name="cookies">
+ Enable the DNS cookie module (RFC 7873)
+ </flag>
<flag name="dnsproxy">
Enable the tiny DNS proxy module
</flag>
@@ -21,6 +24,9 @@
Use a zone file parser that is faster, but requires
more memory and CPU time to compile
</flag>
+ <flag name="geoip">
+ Enable the Geography-based responses module
+ </flag>
<flag name="libidn2">
If IDN support is enabled, use net-dns/libidn2 instead
of net-dns/libidn