summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-16 08:54:07 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-16 11:07:42 +0200
commitb33d974e27154e705aca4eb1ecbbdad17db4ae87 (patch)
tree28b171f4421ee1f98fe25f27800f55d8b9bf0449
parentsys-libs/glibc: use -mno-sdata, not -fcommon, bug #723268 (diff)
downloadgentoo-b33d974e27154e705aca4eb1ecbbdad17db4ae87.tar.gz
gentoo-b33d974e27154e705aca4eb1ecbbdad17db4ae87.tar.bz2
gentoo-b33d974e27154e705aca4eb1ecbbdad17db4ae87.zip
dev-python/setuptools: Bump to 46.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-46.3.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index 7aa256c2f626..b35bd522ad47 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -3,3 +3,4 @@ DIST setuptools-44.1.0.zip 858569 BLAKE2B f59f154e121502a731e51294ccd293d60ffcca
DIST setuptools-46.1.3.zip 862431 BLAKE2B 89d65360e15b22f535312627723ad61df84dce3ee9d5850dd0c60dace0f8c04a502ac6246afe1add1e4fbd0e0dc9530afc8bfd2a4cf058f93cde2ff4184e21f2 SHA512 7f8f99313ce2af2cbfa86ff9a3135bc3445804e9323a375b498d20dad7f8fc819481da0c2a057160397e98b6178c1eb453a093652cfdfe7896c9d31732f7ad8c
DIST setuptools-46.2.0.zip 865117 BLAKE2B 490387146003e07a5391afa798d1e45a76e9afc81c3e0c484005b3b0bff15f172db2016907199fe2216a4e17379987a53d58149d285be6dcfe7c37a64ce7c359 SHA512 d8d89a99c6a3be0a343d6a0e17117ba00393188d69c8995a5dbe9a7772c002fc301a53963288231e3f8053ffda4cafd5406edb2f4650f2036c665f8e3eb5822e
DIST setuptools-46.3.0.zip 864654 BLAKE2B ce916b8f84f777a4baf6dd7458d5a74d7afbc0ede3a60238ce1e6ddf8b4c9837cd88508d4af4577be446d811fc9b997e9361775abaf9308bc9af6f66ca173bfb SHA512 57bc3e1a585a99d9434ed55af037a71665ee7e76ac9dbf19c87260b3d4331183f9eb3c7389c3455407f379ba28a74e90e27346afc614003ae259ab92e3dc16ec
+DIST setuptools-46.3.1.zip 864714 BLAKE2B 538ede10db4e82d75eec613f909df7d9de8d2821fea74167c30d80fd6c9bf964345ac2054d74d673a2257d32a022e719a0f14db81bfcb6355fe700eace96df2e SHA512 084210cc57021eeafbed92b6419f91eb100a53f3425579331bcf1b6bae314371c3881e5f4680d923a4d4dbe8e94d881d87b3c7aa4ad60500bec68bad399caa6d
diff --git a/dev-python/setuptools/setuptools-46.3.1.ebuild b/dev-python/setuptools/setuptools-46.3.1.ebuild
new file mode 100644
index 000000000000..8562f41ff110
--- /dev/null
+++ b/dev-python/setuptools/setuptools-46.3.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://github.com/pypa/setuptools https://pypi.org/project/setuptools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ app-arch/unzip
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.7.0[${PYTHON_USEDEP}]
+ dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+ dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]"
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( {CHANGES,README}.rst docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
+
+python_prepare_all() {
+ # disable tests requiring a network connection
+ rm setuptools/tests/test_packageindex.py || die
+
+ # don't run integration tests
+ rm setuptools/tests/test_integration.py || die
+
+ # xpass-es for me on py3
+ sed -e '/xfail.*710/s:(:(six.PY2, :' \
+ -i setuptools/tests/test_archive_util.py || die
+
+ # avoid pointless dep on flake8
+ sed -i -e 's:--flake8::' pytest.ini || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" pytest -vv ${PN} || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}