summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsoredake <fdsfgs@krutt.org>2016-11-25 13:49:45 +0200
committerDavid Seifert <soap@gentoo.org>2016-11-26 13:04:36 +0100
commitb40df3fe09310190ab4075768c50f0293b4aa8b2 (patch)
tree1bc2fe3517aaf2f5a0f27c4aee05b51ac4fa8749
parentsys-libs/slang: Bump to version 2.3.1a (diff)
downloadgentoo-b40df3fe09310190ab4075768c50f0293b4aa8b2.tar.gz
gentoo-b40df3fe09310190ab4075768c50f0293b4aa8b2.tar.bz2
gentoo-b40df3fe09310190ab4075768c50f0293b4aa8b2.zip
net-misc/streamlink: new package
Closes: https://github.com/gentoo/gentoo/pull/2912
-rw-r--r--net-misc/streamlink/Manifest1
-rw-r--r--net-misc/streamlink/metadata.xml15
-rw-r--r--net-misc/streamlink/streamlink-0.1.0.ebuild40
-rw-r--r--net-misc/streamlink/streamlink-9999.ebuild40
4 files changed, 96 insertions, 0 deletions
diff --git a/net-misc/streamlink/Manifest b/net-misc/streamlink/Manifest
new file mode 100644
index 000000000000..bc0fd6172d50
--- /dev/null
+++ b/net-misc/streamlink/Manifest
@@ -0,0 +1 @@
+DIST streamlink-0.1.0.tar.gz 960622 SHA256 0a792cfe35c36f13b851bb79dc92e8a9515334c49221297258c9998f191ccecd SHA512 78b5bd9d35c2fc9c1d9fe3954b439e56cfee48f2b73a95a2c08a53c3a66143938ba162f2d2ba29c8af989565c920756cab605ae772d73828a3dd5a41fc6d30c2 WHIRLPOOL 5ba5dc69aecb06d8b1ba5372a327033b06d88bd38040278df0cac06c84663f7dcef29ae0921c4f36959a53eac7621d8df184bf9ea9bf5cbf6e5b2b2d7b4c8f23
diff --git a/net-misc/streamlink/metadata.xml b/net-misc/streamlink/metadata.xml
new file mode 100644
index 000000000000..e6798e56f53a
--- /dev/null
+++ b/net-misc/streamlink/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>fdsfgs@krutt.org</email>
+ <name>soredake</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">streamlink/streamlink</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/streamlink/streamlink-0.1.0.ebuild b/net-misc/streamlink/streamlink-0.1.0.ebuild
new file mode 100644
index 000000000000..b9d43b9776ca
--- /dev/null
+++ b/net-misc/streamlink/streamlink-0.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ media-video/rtmpdump"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND} )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/net-misc/streamlink/streamlink-9999.ebuild b/net-misc/streamlink/streamlink-9999.ebuild
new file mode 100644
index 000000000000..90849f2ac57e
--- /dev/null
+++ b/net-misc/streamlink/streamlink-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+EGIT_REPO_URI="https://github.com/${PN}/${PN}"
+
+KEYWORDS=""
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ media-video/rtmpdump"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND} )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}