summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2016-09-01 22:52:50 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-02 22:08:57 +0200
commitb451a42dd3357a2d8d00dba9b92b1032799a295e (patch)
treebb858d991b1654fe6c55cc16e98b74883138b7e8
parentsci-astronomy/skycat: Deleted EAPI 4 ebuild (diff)
downloadgentoo-b451a42dd3357a2d8d00dba9b92b1032799a295e.tar.gz
gentoo-b451a42dd3357a2d8d00dba9b92b1032799a295e.tar.bz2
gentoo-b451a42dd3357a2d8d00dba9b92b1032799a295e.zip
sci-astronomy/xfitsview: revbump (EAPI 4 -> 6)
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/2187 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sci-astronomy/xfitsview/files/xfitsview-2.2-build_system.patch8
-rw-r--r--sci-astronomy/xfitsview/xfitsview-2.2-r2.ebuild35
2 files changed, 39 insertions, 4 deletions
diff --git a/sci-astronomy/xfitsview/files/xfitsview-2.2-build_system.patch b/sci-astronomy/xfitsview/files/xfitsview-2.2-build_system.patch
index 6b010a3ea721..12eaacf4e244 100644
--- a/sci-astronomy/xfitsview/files/xfitsview-2.2-build_system.patch
+++ b/sci-astronomy/xfitsview/files/xfitsview-2.2-build_system.patch
@@ -4,8 +4,8 @@
http://bugs.gentoo.org/show_bug.cgi?id=337479
---- Makefile.in
-+++ Makefile.in
+--- a/Makefile.in
++++ b/Makefile.in
@@ -61,26 +61,26 @@
LIBDIR = lib/$(ARCH)/
CFLAGS = -Iinclude -Ifitssubs @MOTIF_CPPFLAGS@ @X_CFLAGS@ \
@@ -41,8 +41,8 @@ http://bugs.gentoo.org/show_bug.cgi?id=337479
# make gzipped tar backup of directory
backup:
---- fitssubs/Makefile.in
-+++ fitssubs/Makefile.in
+--- a/fitssubs/Makefile.in
++++ b/fitssubs/Makefile.in
@@ -69,7 +69,7 @@
diff --git a/sci-astronomy/xfitsview/xfitsview-2.2-r2.ebuild b/sci-astronomy/xfitsview/xfitsview-2.2-r2.ebuild
new file mode 100644
index 000000000000..3ac2bd2e6b37
--- /dev/null
+++ b/sci-astronomy/xfitsview/xfitsview-2.2-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN=XFITSview
+MY_P=${MY_PN}${PV}
+
+DESCRIPTION="Viewer for astronomical images in FITS format"
+HOMEPAGE="http://www.nrao.edu/software/fitsview/"
+SRC_URI="ftp://ftp.cv.nrao.edu/fits/os-support/unix/xfitsview/${PN}${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=">=x11-libs/motif-2.3:0"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_PN}
+
+DOCS=( README changes notes.text )
+PATCHES=( "${FILESDIR}"/${P}-build_system.patch )
+
+src_prepare() {
+ default
+ find "${S}" -name '*old.c' -delete || die
+}
+
+src_install() {
+ dobin XFITSview
+ einstalldocs
+}