summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2017-06-11 23:24:18 -0400
committerAlexandre Rostovtsev <tetromino@gentoo.org>2017-06-11 23:24:18 -0400
commitb7c2bc7b211b2b33dba2074547d18f99d2bc14f4 (patch)
tree0735c33f8aa0bd0e3181bdbdfb6e0dcfb9c05911
parentkde-apps/kdebase-kioslaves: Drop USE=webkit (diff)
downloadgentoo-b7c2bc7b211b2b33dba2074547d18f99d2bc14f4.tar.gz
gentoo-b7c2bc7b211b2b33dba2074547d18f99d2bc14f4.tar.bz2
gentoo-b7c2bc7b211b2b33dba2074547d18f99d2bc14f4.zip
sys-fs/vhba: fix build with kernel 4.11 and add epatch_user
Gentoo-bug: 617630, 621484 Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--sys-fs/vhba/files/vhba-20161009-linux-4.11.patch35
-rw-r--r--sys-fs/vhba/vhba-20140928.ebuild8
2 files changed, 41 insertions, 2 deletions
diff --git a/sys-fs/vhba/files/vhba-20161009-linux-4.11.patch b/sys-fs/vhba/files/vhba-20161009-linux-4.11.patch
new file mode 100644
index 000000000000..02540193f6e0
--- /dev/null
+++ b/sys-fs/vhba/files/vhba-20161009-linux-4.11.patch
@@ -0,0 +1,35 @@
+From 7dc0d29a3ef6e45455f537c8187791446ca7e1e5 Mon Sep 17 00:00:00 2001
+From: Rok Mandeljc <rok.mandeljc@gmail.com>
+Date: Sun, 26 Mar 2017 17:09:42 +0200
+Subject: VHBA: compatibility fix for upcoming kernel 4.11
+
+As per Bug #104, from 4.11-rc2 on, we need to include linux/sched/signal.h
+instead of linux/sched.h
+
+diff --git a/vhba-module/vhba.c b/vhba-module/vhba.c
+index 4a14a10e..ff30e4cb 100644
+--- a/vhba-module/vhba.c
++++ b/vhba-module/vhba.c
+@@ -18,16 +18,21 @@
+ * 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+ */
+
++#include <linux/version.h>
++
+ #include <linux/init.h>
+ #include <linux/module.h>
+ #include <linux/highmem.h>
+ #include <linux/fs.h>
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
++#include <linux/sched/signal.h>
++#else
+ #include <linux/sched.h>
++#endif
+ #include <linux/platform_device.h>
+ #include <linux/miscdevice.h>
+ #include <linux/poll.h>
+ #include <linux/slab.h>
+-#include <linux/version.h>
+ #ifdef CONFIG_COMPAT
+ #include <linux/compat.h>
+ #endif
diff --git a/sys-fs/vhba/vhba-20140928.ebuild b/sys-fs/vhba/vhba-20140928.ebuild
index 7be63eb43ae8..f8d94012113c 100644
--- a/sys-fs/vhba/vhba-20140928.ebuild
+++ b/sys-fs/vhba/vhba-20140928.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
-inherit linux-mod user udev
+inherit eutils linux-mod user udev
MY_P=vhba-module-${PV}
DESCRIPTION="Virtual (SCSI) Host Bus Adapter kernel module for the CDEmu suite"
@@ -36,6 +36,10 @@ src_prepare() {
# Avoid "make jobserver unavailable" warning and -Werror problems
sed -e '/ccflags/s/-Werror$/-Wall/' \
-i Makefile || die "sed failed"
+
+ epatch "${FILESDIR}/${PN}-20161009-linux-4.11.patch"
+
+ epatch_user
}
src_install() {