summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-07-02 23:17:25 +0200
committerMichał Górny <mgorny@gentoo.org>2016-07-02 23:19:18 +0200
commitb91283a3e1946a62683dab6a8a5d6f76dd5a2d7b (patch)
treea7ce54fb2ca20e2250e6b7b6b6f488e3c8b60de2
parentnet-misc/aria2: Add missing cond RESTRICT=test (diff)
downloadgentoo-b91283a3e1946a62683dab6a8a5d6f76dd5a2d7b.tar.gz
gentoo-b91283a3e1946a62683dab6a8a5d6f76dd5a2d7b.tar.bz2
gentoo-b91283a3e1946a62683dab6a8a5d6f76dd5a2d7b.zip
sys-apps/paludis: Drop old
Drop intermediate old versions, keeping only the stable versions using EAPI 5 and EAPI 4.
-rw-r--r--sys-apps/paludis/Manifest3
-rw-r--r--sys-apps/paludis/files/paludis-2.2.0-check-IUSE_EFFECTIVE-in-EAPI-5.patch88
-rw-r--r--sys-apps/paludis/files/paludis-2.2.0-filter-EBUILD_PHASE_FUNC.patch22
-rw-r--r--sys-apps/paludis/files/paludis-2.2.0-filter-IUSE_EFFECTIVE.patch31
-rw-r--r--sys-apps/paludis/files/paludis-2.2.0-fix-MERGE_TYPE.patch81
-rw-r--r--sys-apps/paludis/files/paludis-2.2.0-fix-PWD-handling.patch30
-rw-r--r--sys-apps/paludis/paludis-1.4.2-r1.ebuild157
-rw-r--r--sys-apps/paludis/paludis-2.2.0-r2.ebuild169
-rw-r--r--sys-apps/paludis/paludis-2.2.0.ebuild159
-rw-r--r--sys-apps/paludis/paludis-2.4.0_p20160112.ebuild154
10 files changed, 0 insertions, 894 deletions
diff --git a/sys-apps/paludis/Manifest b/sys-apps/paludis/Manifest
index a6c2d075840..ff107172607 100644
--- a/sys-apps/paludis/Manifest
+++ b/sys-apps/paludis/Manifest
@@ -1,6 +1,3 @@
-DIST paludis-1.4.2.tar.bz2 1791385 SHA256 ac342d908572e97968abcdd806ba9f390585a06f8da213b34374475972cb2611 SHA512 1176812683453e61897005612f525aad42b38063ff680e645ee840d63c3ffe866578f4c2756f85f7d8bea5be8ca70d3ad1713c0ea2de9e18a76135251126c109 WHIRLPOOL 72b7391b242cebd78883e43ad82d736825841de64a2e4675a7b43a751a51edd3da8acdf37888b5112f4c9aa22c0137502e519cb81b6a1085681a4d860dafcd1c
DIST paludis-2.0.0.tar.bz2 1787616 SHA256 9e635d86e655658d31adde5813f5fcad2982b5fe8847c3c565eca7d28a1ec639 SHA512 e1df4d0617b4e021d1b63181517c0ecb9ece55669226c6ea0bba318b6899277c09a8d8ccc11ef673a3f27e77302c84702df4ae7568b44a87e0b138e346623728 WHIRLPOOL 90dcd765ebc864d14e569a01071fe3effae3c4424cf7f3004ce1f273c721c512697c6100e3b775d34732640bd770220fe5304f4d2b5e67f2de86c9f04c9ffe97
-DIST paludis-2.2.0.tar.bz2 1786405 SHA256 0b0bcb14a6539874d274c72e6a7b9825aa80fa083c2b61e1d5b14daf24829346 SHA512 9b4dd4613ec31683021d6fc5b5eb094024ceada47c41e09d1f0cb86f1de5b621869756401ba14ec0ec5f5dd20a5f8bf5b596c3891724bb9c245400b5fef4961f WHIRLPOOL 9cd602561b38e1bb6fc3d9baa5452c63a394c1e51faf299d8d1e82dad9a53969f14be542dac3f90974fcdf08c16c267cfdf45273c5244f378f9a2b7b6288bd97
DIST paludis-2.4.0.tar.bz2 1787689 SHA256 f47b4bb5503dc127022453b15ca811dec22ee2f04c3c3b76ed1c5a83dbe1af1f SHA512 5fbb15d2285c892fdf19288b8838c51ec2439817a9abc685b8692ff4a3ddf76632d3ab51b2e0298c8eacf00f8b00f4e66b47b34db12844cd4eb77cbfb87ca32e WHIRLPOOL d9dc107886b8bf09bb203704d559dd030190b8390607964578c3f2e10a5c5cd4400146ffed894a968143761fc8149796d37597274b34b8414133b26c7252345b
-DIST paludis-2.4.0_p20160112.tar.xz 1296724 SHA256 2b209337b6a4667ffe8b3db431a88314b3b224cf0f9d57a6d4fdd8c2c00f4b19 SHA512 898853bf75e60dcfcb8aca7e45da3b7eeec2bb119db5b77a12e876282abe936bb3064bf52c27b7a7a949ab0865e7fbbfea78dc66408a09d00a02e1a2069153ae WHIRLPOOL 5167ad0d234f874ef304e0725ea78517c7bcd2e0ef09b5e8ac6b6cf4213fcbccd3b6057caf89274ed67bfd7b35efa0f33fc82d479f5b5f31937a0b7c48c37777
DIST paludis-2.6.0.tar.bz2 1885055 SHA256 bde018c89fce95c2cc793d9171e5a51748ad682d06f839fab394e233257aaf4c SHA512 78a9c0a19703dbbc07934de389b749ab83365454e29b19c323d6c03304162e35ff4d92f7ac1f28067ad853057f2422be43418b3c6a57a193c4b8dd5a4e81eba4 WHIRLPOOL dc4f4ecad0ccbb4b8e6b1b4d0a2c71772b5be244f09dc5456fe42d5510b6b7432ca087f99ae86b2bbbd05b18f70a15371dca1193ead556751faffd01ef227dd6
diff --git a/sys-apps/paludis/files/paludis-2.2.0-check-IUSE_EFFECTIVE-in-EAPI-5.patch b/sys-apps/paludis/files/paludis-2.2.0-check-IUSE_EFFECTIVE-in-EAPI-5.patch
deleted file mode 100644
index 1950f697f00..00000000000
--- a/sys-apps/paludis/files/paludis-2.2.0-check-IUSE_EFFECTIVE-in-EAPI-5.patch
+++ /dev/null
@@ -1,88 +0,0 @@
-From bfb1bd7682b4a678cfa7dccb87d1f49d842317ac Mon Sep 17 00:00:00 2001
-From: David Leverton <levertond@googlemail.com>
-Date: Sat, 21 Mar 2015 20:04:30 +0000
-Subject: Only check IUSE_EFFECTIVE for EAPI 5
-
-In other EAPIs the value isn't set by C++, and therefore may leak in
-from the calling environment.
-
-diff --git a/paludis/repositories/e/ebuild/0/list_functions.bash b/paludis/repositories/e/ebuild/0/list_functions.bash
-index 0c5d91a..4998c2b 100644
---- a/paludis/repositories/e/ebuild/0/list_functions.bash
-+++ b/paludis/repositories/e/ebuild/0/list_functions.bash
-@@ -37,13 +37,6 @@ usev()
-
- useq()
- {
-- if [[ -n "${IUSE_EFFECTIVE:+x}" ]] ; then
-- local i=( $IUSE_EFFECTIVE )
-- if ! hasq ${1#!} "${i[@]#[+-]}" ; then
-- die "Flag '${1#!}' is not included in IUSE_EFFECTIVE=\"${IUSE_EFFECTIVE}\""
-- fi
-- fi
--
- if [[ "${1:0:1}" == "!" ]] ; then
- ! hasq "${1#!}" "${USE}"
- else
-diff --git a/paludis/repositories/e/ebuild/5/Makefile.am b/paludis/repositories/e/ebuild/5/Makefile.am
-index fbcb919..ced4e53 100644
---- a/paludis/repositories/e/ebuild/5/Makefile.am
-+++ b/paludis/repositories/e/ebuild/5/Makefile.am
-@@ -7,6 +7,7 @@ libexecprog5dir = $(libexecdir)/paludis/5
- libexecprog5_SCRIPTS = \
- src_test.bash \
- usex.bash \
-+ list_functions.bash \
- output_functions.bash
-
- TESTS =
-diff --git a/paludis/repositories/e/ebuild/5/list_functions.bash b/paludis/repositories/e/ebuild/5/list_functions.bash
-new file mode 100644
-index 0000000..7cb22ad
---- /dev/null
-+++ b/paludis/repositories/e/ebuild/5/list_functions.bash
-@@ -0,0 +1,41 @@
-+#!/usr/bin/env bash
-+# vim: set sw=4 sts=4 et :
-+
-+# Copyright (c) 2006, 2009, 2012 Ciaran McCreesh
-+# Copyright (c) 2015 David Leverton
-+#
-+# Based in part upon ebuild.sh from Portage, which is Copyright 1995-2005
-+# Gentoo Foundation and distributed under the terms of the GNU General
-+# Public License v2.
-+#
-+# This file is part of the Paludis package manager. Paludis is free software;
-+# you can redistribute it and/or modify it under the terms of the GNU General
-+# Public License, version 2, as published by the Free Software Foundation.
-+#
-+# Paludis is distributed in the hope that it will be useful, but WITHOUT ANY
-+# WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
-+# FOR A PARTICULAR PURPOSE. See the GNU General Public License for more
-+# details.
-+#
-+# You should have received a copy of the GNU General Public License along with
-+# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
-+# Place, Suite 330, Boston, MA 02111-1307 USA
-+
-+ebuild_load_module --older list_functions
-+
-+useq()
-+{
-+ if [[ -n "${IUSE_EFFECTIVE:+x}" ]] ; then
-+ local i=( $IUSE_EFFECTIVE )
-+ if ! hasq ${1#!} "${i[@]#[+-]}" ; then
-+ die "Flag '${1#!}' is not included in IUSE_EFFECTIVE=\"${IUSE_EFFECTIVE}\""
-+ fi
-+ fi
-+
-+ if [[ "${1:0:1}" == "!" ]] ; then
-+ ! hasq "${1#!}" "${USE}"
-+ else
-+ hasq "${1}" "${USE}"
-+ fi
-+}
-+
---
-cgit v0.10.2
-
diff --git a/sys-apps/paludis/files/paludis-2.2.0-filter-EBUILD_PHASE_FUNC.patch b/sys-apps/paludis/files/paludis-2.2.0-filter-EBUILD_PHASE_FUNC.patch
deleted file mode 100644
index dc46726909c..00000000000
--- a/sys-apps/paludis/files/paludis-2.2.0-filter-EBUILD_PHASE_FUNC.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From dccb65acba7684c97675473fec5120e3aa55d2d0 Mon Sep 17 00:00:00 2001
-From: David Leverton <levertond@googlemail.com>
-Date: Sun, 29 Mar 2015 18:36:02 +0100
-Subject: Fix EBUILD_PHASE_FUNC leakage
-
-
-diff --git a/paludis/repositories/e/ebuild/ebuild.bash b/paludis/repositories/e/ebuild/ebuild.bash
-index 24a93d4..b856bad 100755
---- a/paludis/repositories/e/ebuild/ebuild.bash
-+++ b/paludis/repositories/e/ebuild/ebuild.bash
-@@ -76,7 +76,7 @@ ebuild_sanitise_envvars
- # fancy fake variables
- EBUILD_METADATA_VARIABLES="DEPEND RDEPEND PDEPEND IUSE IUSE_EFFECTIVE SRC_URI DOWNLOADS RESTRICT \
- LICENSE LICENCES KEYWORDS INHERITED PROVIDE HOMEPAGE DESCRIPTION DEPENDENCIES \
-- E_IUSE E_DEPEND E_RDEPEND E_PDEPEND PLATFORMS DEFINED_PHASES \
-+ E_IUSE E_DEPEND E_RDEPEND E_PDEPEND PLATFORMS DEFINED_PHASES EBUILD_PHASE_FUNC \
- MYOPTIONS E_MYOPTIONS E_DEPENDENCIES BINARY_KEYWORDS BINARY_URI \
- GENERATED_USING GENERATED_TIME GENERATED_FROM_REPOSITORY BINARY_PLATFORMS REMOTE_IDS \
- SUMMARY BUGS_TO UPSTREAM_DOCUMENTATION UPSTREAM_CHANGELOG \
---
-cgit v0.10.2
-
diff --git a/sys-apps/paludis/files/paludis-2.2.0-filter-IUSE_EFFECTIVE.patch b/sys-apps/paludis/files/paludis-2.2.0-filter-IUSE_EFFECTIVE.patch
deleted file mode 100644
index 2e56e6b3b12..00000000000
--- a/sys-apps/paludis/files/paludis-2.2.0-filter-IUSE_EFFECTIVE.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From ef6930e03428ec512c9d564886c06078e5238d45 Mon Sep 17 00:00:00 2001
-From: David Leverton <levertond@googlemail.com>
-Date: Sat, 21 Mar 2015 19:38:52 +0000
-Subject: Add IUSE_EFFECTIVE to EBUILD_METADATA_VARIABLES{,_FROM_CPLUSPLUS}
-
-
-diff --git a/paludis/repositories/e/ebuild/ebuild.bash b/paludis/repositories/e/ebuild/ebuild.bash
-index f4387e1..24a93d4 100755
---- a/paludis/repositories/e/ebuild/ebuild.bash
-+++ b/paludis/repositories/e/ebuild/ebuild.bash
-@@ -74,7 +74,7 @@ ebuild_sanitise_envvars
-
- # The list below should include all variables from all EAPIs, along with any
- # fancy fake variables
--EBUILD_METADATA_VARIABLES="DEPEND RDEPEND PDEPEND IUSE SRC_URI DOWNLOADS RESTRICT \
-+EBUILD_METADATA_VARIABLES="DEPEND RDEPEND PDEPEND IUSE IUSE_EFFECTIVE SRC_URI DOWNLOADS RESTRICT \
- LICENSE LICENCES KEYWORDS INHERITED PROVIDE HOMEPAGE DESCRIPTION DEPENDENCIES \
- E_IUSE E_DEPEND E_RDEPEND E_PDEPEND PLATFORMS DEFINED_PHASES \
- MYOPTIONS E_MYOPTIONS E_DEPENDENCIES BINARY_KEYWORDS BINARY_URI \
-@@ -82,7 +82,7 @@ EBUILD_METADATA_VARIABLES="DEPEND RDEPEND PDEPEND IUSE SRC_URI DOWNLOADS RESTRIC
- SUMMARY BUGS_TO UPSTREAM_DOCUMENTATION UPSTREAM_CHANGELOG \
- UPSTREAM_RELEASE_NOTES PROPERTIES PALUDIS_DECLARED_FUNCTIONS SLOT EAPI OPTIONS USE \
- PALUDIS_EBUILD_RDEPEND_WAS_SET PALUDIS_EBUILD_DEPEND REQUIRED_USE SCM_REVISION"
--EBUILD_METADATA_VARIABLES_FROM_CPLUSPLUS="SLOT EAPI OPTIONS USE"
-+EBUILD_METADATA_VARIABLES_FROM_CPLUSPLUS="SLOT EAPI OPTIONS USE IUSE_EFFECTIVE"
-
- shopt -s expand_aliases
- [[ -z ${PALUDIS_SHELL_OPTIONS} && unset == ${PALUDIS_SHELL_OPTIONS-unset} ]] &&
---
-cgit v0.10.2
-
diff --git a/sys-apps/paludis/files/paludis-2.2.0-fix-MERGE_TYPE.patch b/sys-apps/paludis/files/paludis-2.2.0-fix-MERGE_TYPE.patch
deleted file mode 100644
index 2ef1a48ed52..00000000000
--- a/sys-apps/paludis/files/paludis-2.2.0-fix-MERGE_TYPE.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-From 96768e54e2fdfc526edd2e939f20203e43b25a36 Mon Sep 17 00:00:00 2001
-From: David Leverton <levertond@googlemail.com>
-Date: Sun, 1 Mar 2015 15:22:32 +0000
-Subject: Fix MERGE_TYPE
-
-Unfortunately the test cases were broken in the same way as the
-feature itself, so it wasn't caught.
-
-Fixes: ticket:1323
-
-diff --git a/paludis/repositories/e/e_repository_TEST_4.cc b/paludis/repositories/e/e_repository_TEST_4.cc
-index a59014d..caccf2c 100644
---- a/paludis/repositories/e/e_repository_TEST_4.cc
-+++ b/paludis/repositories/e/e_repository_TEST_4.cc
-@@ -301,7 +301,6 @@ TEST(ERepository, EAPI4MergeType)
- n::replacing() = std::make_shared<PackageIDSequence>(),
- n::want_phase() = &want_all_phases
- ));
-- ::setenv("EXPECTED_MERGE_TYPE", "source", 1);
-
- const std::shared_ptr<const PackageID> id(*env[selection::RequireExactlyOne(generator::Matches(
- PackageDepSpec(parse_user_package_dep_spec("=cat/merge-type-4::test-repo",
-@@ -371,7 +370,6 @@ TEST(ERepository, EAPI4MergeTypeBin)
- n::replacing() = std::make_shared<PackageIDSequence>(),
- n::want_phase() = &want_all_phases
- ));
-- ::setenv("EXPECTED_MERGE_TYPE", "buildonly", 1);
-
- const std::shared_ptr<const PackageID> id(*env[selection::RequireExactlyOne(generator::Matches(
- PackageDepSpec(parse_user_package_dep_spec("=cat/merge-type-bin-4::test-repo",
-@@ -389,7 +387,6 @@ TEST(ERepository, EAPI4MergeTypeBin)
- n::replacing() = std::make_shared<PackageIDSequence>(),
- n::want_phase() = &want_all_phases
- ));
-- ::setenv("EXPECTED_MERGE_TYPE", "binary", 1);
-
- const std::shared_ptr<const PackageID> id(*env[selection::RequireExactlyOne(generator::Matches(
- PackageDepSpec(parse_user_package_dep_spec("=cat/merge-type-bin-4::binrepo",
-diff --git a/paludis/repositories/e/e_repository_TEST_4_setup.sh b/paludis/repositories/e/e_repository_TEST_4_setup.sh
-index 81b6593..0c28acc 100755
---- a/paludis/repositories/e/e_repository_TEST_4_setup.sh
-+++ b/paludis/repositories/e/e_repository_TEST_4_setup.sh
-@@ -956,6 +956,8 @@ KEYWORDS="test"
-
- S="${WORKDIR}"
-
-+EXPECTED_MERGE_TYPE=source
-+
- pkg_setup() {
- if [[ ${EXPECTED_MERGE_TYPE} != ${MERGE_TYPE} ]] ; then
- die ${EXPECTED_MERGE_TYPE} is not ${MERGE_TYPE}
-@@ -975,10 +977,13 @@ KEYWORDS="test"
-
- S="${WORKDIR}"
-
-+EXPECTED_MERGE_TYPE=buildonly
-+
- pkg_setup() {
- if [[ ${EXPECTED_MERGE_TYPE} != ${MERGE_TYPE} ]] ; then
- die ${EXPECTED_MERGE_TYPE} is not ${MERGE_TYPE}
- fi
-+ EXPECTED_MERGE_TYPE=binary
- }
- END
- mkdir -p "cat/required-use-all-good" || exit 1
-diff --git a/paludis/repositories/e/ebuild/ebuild.bash b/paludis/repositories/e/ebuild/ebuild.bash
-index a88554b..f4387e1 100755
---- a/paludis/repositories/e/ebuild/ebuild.bash
-+++ b/paludis/repositories/e/ebuild/ebuild.bash
-@@ -304,7 +304,7 @@ ebuild_scrub_environment()
- echo "\${!${PALUDIS_CLIENT_UPPER}_CMDLINE_*} ${PALUDIS_CLIENT_UPPER}_OPTIONS" )
-
- unset -v CATEGORY PN PV P PNV PVR PF PNVR
-- unset -v ebuild EBUILD
-+ unset -v ebuild EBUILD MERGE_TYPE
- unset -v $(
- for v in ${PALUDIS_SOURCE_MERGED_VARIABLES} ${PALUDIS_BRACKET_MERGED_VARIABLES} ; do
- echo E_${v}
---
-cgit v0.10.2
-
diff --git a/sys-apps/paludis/files/paludis-2.2.0-fix-PWD-handling.patch b/sys-apps/paludis/files/paludis-2.2.0-fix-PWD-handling.patch
deleted file mode 100644
index 663e94d5497..00000000000
--- a/sys-apps/paludis/files/paludis-2.2.0-fix-PWD-handling.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From f9b2434560399b00f7de479474f8f22fc0271e77 Mon Sep 17 00:00:00 2001
-From: Georgi Georgiev <chutz@gg3.net>
-Date: Tue, 10 Mar 2015 00:38:36 +0900
-Subject: PWD is a special variable, we should leave its value alone
-
-Bash sets the value of PWD to the current working directory. It is not a
-good idea to change that variable without actually changing the
-directory. This would happen if the working directory changes between
-saving and loading the environment (saving - when building a PBIN, and
-loading - when installing it for example), so better let bash handle
-this variable.
-
-Fixes: ticket:1325
-
-diff --git a/paludis/repositories/e/ebuild/source_functions.bash b/paludis/repositories/e/ebuild/source_functions.bash
-index 58b9327..5bfb251 100755
---- a/paludis/repositories/e/ebuild/source_functions.bash
-+++ b/paludis/repositories/e/ebuild/source_functions.bash
-@@ -37,7 +37,7 @@ ebuild_need_extglob()
- ebuild_safe_source()
- {
- set -- "${@}" '[^a-zA-Z_]*' '*[^a-zA-Z0-9_]*' \
-- EUID PPID UID FUNCNAME GROUPS SHELLOPTS BASHOPTS BASHPID IFS \
-+ EUID PPID UID FUNCNAME GROUPS SHELLOPTS BASHOPTS BASHPID IFS PWD \
- 'BASH_@(ARGC|ARGV|LINENO|SOURCE|VERSINFO|REMATCH)' \
- 'BASH_COMPLETION?(_DIR)' 'bash+([0-9])?([a-z])' \
- EBUILD_KILL_PID PALUDIS_LOADSAVEENV_DIR PALUDIS_DO_NOTHING_SANDBOXY SANDBOX_ACTIVE \
---
-cgit v0.10.2
-
diff --git a/sys-apps/paludis/paludis-1.4.2-r1.ebuild b/sys-apps/paludis/paludis-1.4.2-r1.ebuild
deleted file mode 100644
index 4751880ddb2..00000000000
--- a/sys-apps/paludis/paludis-1.4.2-r1.ebuild
+++ /dev/null
@@ -1,157 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit bash-completion-r1 eutils python-single-r1 user
-
-DESCRIPTION="paludis, the other package mangler"
-HOMEPAGE="http://paludis.exherbo.org/"
-SRC_URI="http://paludis.exherbo.org/download/${P}.tar.bz2"
-
-IUSE="doc pbins pink python ruby search-index test xml"
-LICENSE="GPL-2 vim"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-
-COMMON_DEPEND="
- >=app-admin/eselect-1.2.13
- >=app-shells/bash-3.2
- >=sys-devel/gcc-4.4
- dev-libs/libpcre[cxx]
- sys-apps/file
- pbins? ( >=app-arch/libarchive-3.1.2[xattr] )
- python? (
- ${PYTHON_DEPS}
- >=dev-libs/boost-1.41.0[python,${PYTHON_USEDEP}] )
- ruby? ( dev-lang/ruby:1.9 )
- xml? ( >=dev-libs/libxml2-2.6 )
- search-index? ( >=dev-db/sqlite-3 )"
-
-DEPEND="${COMMON_DEPEND}
- doc? (
- || ( >=app-doc/doxygen-1.5.3 <=app-doc/doxygen-1.5.1 )
- python? (
- dev-python/epydoc[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}] )
- ruby? ( dev-ruby/syntax )
- )
- virtual/pkgconfig
- test? ( >=dev-cpp/gtest-1.6.0-r1 )"
-
-RDEPEND="${COMMON_DEPEND}
- sys-apps/sandbox"
-
-PDEPEND="app-eselect/eselect-package-manager"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != buildonly ]]; then
- if id paludisbuild >/dev/null 2>/dev/null ; then
- if ! groups paludisbuild | grep --quiet '\<tty\>' ; then
- eerror "The 'paludisbuild' user is now expected to be a member of the"
- eerror "'tty' group. You should add the user to this group before"
- eerror "upgrading Paludis."
- die "Please add paludisbuild to tty group"
- fi
- fi
- fi
-
- if [[ ${MERGE_TYPE} != binary ]]; then
- if [[ $(gcc-major-version) -lt 4
- || ( $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 4 ) ]]
- then
- eerror "Paludis requires at least gcc 4.4 to build. Please switch the active"
- eerror "gcc version using gcc-config."
- die "Paludis requires at least gcc 4.4"
- fi
- fi
-}
-
-pkg_setup() {
- enewgroup "paludisbuild"
- enewuser "paludisbuild" -1 -1 "/var/tmp/paludis" "paludisbuild,tty"
-
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- # The package explicitly wants ruby1.9, so fix the script on it.
- # https://bugs.gentoo.org/show_bug.cgi?id=439372#c2
- sed -i -e '1s/ruby/&19/' ruby/demos/*.rb || die
-
- epatch_user
-}
-
-src_configure() {
- local myeconfargs=(
- --htmldir=/usr/share/doc/${PF}/html
-
- $(use_enable doc doxygen)
- $(use_enable pbins)
- $(use_enable pink)
- $(use_enable ruby)
- $(use ruby && use_enable doc ruby-doc)
- $(use_enable python)
- $(use python && use_enable doc python-doc)
- $(use_enable xml)
- $(use_enable search-index)
- $(use_enable test gtest)
-
- --enable-prebuilt-documentation
- --enable-vim
- --enable-visibility
- --with-config-framework=eselect
- --with-environments=default,portage
- --with-vim-install-dir=/usr/share/vim/vimfiles
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- prune_libtool_files
-
- dobashcomp bash-completion/cave
-
- insinto /usr/share/zsh/site-functions
- doins zsh-completion/_cave
-}
-
-src_test() {
- # Work around Portage bugs
- local -x PALUDIS_DO_NOTHING_SANDBOXY="portage sucks"
- local -x BASH_ENV=/dev/null
-
- if [[ ${EUID} == 0 ]] ; then
- # hate
- local -x PALUDIS_REDUCED_UID=0
- local -x PALUDIS_REDUCED_GID=0
- fi
-
- if ! nonfatal emake check ; then
- eerror "Tests failed. Looking for files for you to add to your bug report..."
- find "${S}" -type f -name '*.epicfail' -or -name '*.log' | while read a ; do
- eerror " $a"
- done
- die "Make check failed"
- fi
-}
-
-pkg_postinst() {
- local pm
- if [[ -f ${ROOT}/etc/env.d/50package-manager ]] ; then
- pm=$( source "${ROOT}"/etc/env.d/50package-manager ; echo "${PACKAGE_MANAGER}" )
- fi
-
- if [[ ${pm} != paludis ]] ; then
- elog "If you are using paludis or cave as your primary package manager,"
- elog "you should consider running:"
- elog " eselect package-manager set paludis"
- fi
-}
diff --git a/sys-apps/paludis/paludis-2.2.0-r2.ebuild b/sys-apps/paludis/paludis-2.2.0-r2.ebuild
deleted file mode 100644
index 98a4d23763b..00000000000
--- a/sys-apps/paludis/paludis-2.2.0-r2.ebuild
+++ /dev/null
@@ -1,169 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools bash-completion-r1 eutils python-single-r1 user
-
-DESCRIPTION="paludis, the other package mangler"
-HOMEPAGE="http://paludis.exherbo.org/"
-SRC_URI="http://paludis.exherbo.org/download/${P}.tar.bz2"
-
-IUSE="doc pbins pink python ruby search-index test xml"
-LICENSE="GPL-2 vim"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-
-COMMON_DEPEND="
- >=app-admin/eselect-1.2.13
- >=app-shells/bash-3.2
- dev-libs/libpcre[cxx]
- sys-apps/file
- pbins? ( >=app-arch/libarchive-3.1.2 )
- python? (
- ${PYTHON_DEPS}
- >=dev-libs/boost-1.41.0[python,${PYTHON_USEDEP}] )
- ruby? ( dev-lang/ruby:1.9 )
- search-index? ( >=dev-db/sqlite-3 )
- xml? ( >=dev-libs/libxml2-2.6 )"
-
-DEPEND="${COMMON_DEPEND}
- >=app-text/asciidoc-8.6.3
- app-text/htmltidy
- app-text/xmlto
- >=sys-devel/gcc-4.7
- doc? (
- || (
- >=app-doc/doxygen-1.5.3
- <=app-doc/doxygen-1.5.1 )
- python? (
- dev-python/sphinx[${PYTHON_USEDEP}] )
- ruby? ( dev-ruby/syntax )
- )
- virtual/pkgconfig
- test? ( >=dev-cpp/gtest-1.6.0-r1 )"
-
-RDEPEND="${COMMON_DEPEND}
- sys-apps/sandbox"
-
-PDEPEND="app-eselect/eselect-package-manager"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != buildonly ]]; then
- if id paludisbuild >/dev/null 2>/dev/null ; then
- if ! groups paludisbuild | grep --quiet '\<tty\>' ; then
- eerror "The 'paludisbuild' user is now expected to be a member of the"
- eerror "'tty' group. You should add the user to this group before"
- eerror "upgrading Paludis."
- die "Please add paludisbuild to tty group"
- fi
- fi
- fi
-
- if [[ ${MERGE_TYPE} != binary ]]; then
- if [[ $(gcc-major-version) -lt 4
- || ( $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 7 ) ]]
- then
- eerror "Paludis requires at least gcc 4.7 to build. Please switch the active"
- eerror "gcc version using gcc-config."
- die "Paludis requires at least gcc 4.7"
- fi
- fi
-}
-
-pkg_setup() {
- enewgroup "paludisbuild"
- enewuser "paludisbuild" -1 -1 "/var/tmp/paludis" "paludisbuild,tty"
-
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- # The package explicitly wants ruby1.9, so fix the script on it.
- # https://bugs.gentoo.org/show_bug.cgi?id=439372#c2
- sed -i -e '1s/ruby/&19/' ruby/demos/*.rb || die
-
- local PATCHES=(
- "${FILESDIR}"/${P}-fix-MERGE_TYPE.patch
- "${FILESDIR}"/${P}-fix-PWD-handling.patch
- "${FILESDIR}"/${P}-filter-IUSE_EFFECTIVE.patch
- "${FILESDIR}"/${P}-check-IUSE_EFFECTIVE-in-EAPI-5.patch
- "${FILESDIR}"/${P}-filter-EBUILD_PHASE_FUNC.patch
- )
-
- epatch "${PATCHES[@]}"
- epatch_user
- eautoreconf
-}
-
-src_configure() {
- local myconf=(
- --htmldir=/usr/share/doc/${PF}/html
-
- $(use_enable doc doxygen)
- $(use_enable test gtest)
- $(use_enable pbins)
- $(use_enable pink)
- $(use_enable python)
- $(use python && use_enable doc python-doc)
- $(use_enable ruby)
- $(use ruby && use_enable doc ruby-doc)
- $(use_enable search-index)
- $(use_enable xml)
-
- --enable-vim
- --with-config-framework=eselect
- --with-environments=default,portage
- --with-vim-install-dir=/usr/share/vim/vimfiles
- )
-
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- prune_libtool_files
-
- dobashcomp bash-completion/cave
-
- insinto /usr/share/zsh/site-functions
- doins zsh-completion/_cave
-}
-
-src_test() {
- # Work around Portage bugs
- local -x PALUDIS_DO_NOTHING_SANDBOXY="portage sucks"
- local -x BASH_ENV=/dev/null
-
- if [[ ${EUID} == 0 ]] ; then
- # hate
- local -x PALUDIS_REDUCED_UID=0
- local -x PALUDIS_REDUCED_GID=0
- fi
-
- if ! nonfatal emake -k check ; then
- eerror "Tests failed. Looking for files for you to add to your bug report..."
- find "${S}" -type f -name '*.epicfail' -or -name '*.log' | while read a ; do
- eerror " $a"
- done
- die "Make check failed"
- fi
-}
-
-pkg_postinst() {
- local pm
- if [[ -f ${ROOT}/etc/env.d/50package-manager ]] ; then
- pm=$( source "${ROOT}"/etc/env.d/50package-manager ; echo "${PACKAGE_MANAGER}" )
- fi
-
- if [[ ${pm} != paludis ]] ; then
- elog "If you are using paludis or cave as your primary package manager,"
- elog "you should consider running:"
- elog " eselect package-manager set paludis"
- fi
-}
diff --git a/sys-apps/paludis/paludis-2.2.0.ebuild b/sys-apps/paludis/paludis-2.2.0.ebuild
deleted file mode 100644
index d8a064be865..00000000000
--- a/sys-apps/paludis/paludis-2.2.0.ebuild
+++ /dev/null
@@ -1,159 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit bash-completion-r1 eutils python-single-r1 user
-
-DESCRIPTION="paludis, the other package mangler"
-HOMEPAGE="http://paludis.exherbo.org/"
-SRC_URI="http://paludis.exherbo.org/download/${P}.tar.bz2"
-
-IUSE="doc pbins pink python ruby search-index test xml"
-LICENSE="GPL-2 vim"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-
-COMMON_DEPEND="
- >=app-admin/eselect-1.2.13
- >=app-shells/bash-3.2
- dev-libs/libpcre[cxx]
- sys-apps/file
- pbins? ( >=app-arch/libarchive-3.1.2 )
- python? (
- ${PYTHON_DEPS}
- >=dev-libs/boost-1.41.0[python,${PYTHON_USEDEP}] )
- ruby? ( dev-lang/ruby:1.9 )
- search-index? ( >=dev-db/sqlite-3 )
- xml? ( >=dev-libs/libxml2-2.6 )"
-
-DEPEND="${COMMON_DEPEND}
- >=app-text/asciidoc-8.6.3
- app-text/htmltidy
- app-text/xmlto
- >=sys-devel/gcc-4.7
- doc? (
- || (
- >=app-doc/doxygen-1.5.3
- <=app-doc/doxygen-1.5.1 )
- python? (
- dev-python/sphinx[${PYTHON_USEDEP}] )
- ruby? ( dev-ruby/syntax )
- )
- virtual/pkgconfig
- test? ( >=dev-cpp/gtest-1.6.0-r1 )"
-
-RDEPEND="${COMMON_DEPEND}
- sys-apps/sandbox"
-
-PDEPEND="app-eselect/eselect-package-manager"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != buildonly ]]; then
- if id paludisbuild >/dev/null 2>/dev/null ; then
- if ! groups paludisbuild | grep --quiet '\<tty\>' ; then
- eerror "The 'paludisbuild' user is now expected to be a member of the"
- eerror "'tty' group. You should add the user to this group before"
- eerror "upgrading Paludis."
- die "Please add paludisbuild to tty group"
- fi
- fi
- fi
-
- if [[ ${MERGE_TYPE} != binary ]]; then
- if [[ $(gcc-major-version) -lt 4
- || ( $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 7 ) ]]
- then
- eerror "Paludis requires at least gcc 4.7 to build. Please switch the active"
- eerror "gcc version using gcc-config."
- die "Paludis requires at least gcc 4.7"
- fi
- fi
-}
-
-pkg_setup() {
- enewgroup "paludisbuild"
- enewuser "paludisbuild" -1 -1 "/var/tmp/paludis" "paludisbuild,tty"
-
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- # The package explicitly wants ruby1.9, so fix the script on it.
- # https://bugs.gentoo.org/show_bug.cgi?id=439372#c2
- sed -i -e '1s/ruby/&19/' ruby/demos/*.rb || die
-
- epatch_user
-}
-
-src_configure() {
- local myconf=(
- --htmldir=/usr/share/doc/${PF}/html
-
- $(use_enable doc doxygen)
- $(use_enable test gtest)
- $(use_enable pbins)
- $(use_enable pink)
- $(use_enable python)
- $(use python && use_enable doc python-doc)
- $(use_enable ruby)
- $(use ruby && use_enable doc ruby-doc)
- $(use_enable search-index)
- $(use_enable xml)
-
- --enable-vim
- --with-config-framework=eselect
- --with-environments=default,portage
- --with-vim-install-dir=/usr/share/vim/vimfiles
- )
-
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- prune_libtool_files
-
- dobashcomp bash-completion/cave
-
- insinto /usr/share/zsh/site-functions
- doins zsh-completion/_cave
-}
-
-src_test() {
- # Work around Portage bugs
- local -x PALUDIS_DO_NOTHING_SANDBOXY="portage sucks"
- local -x BASH_ENV=/dev/null
-
- if [[ ${EUID} == 0 ]] ; then
- # hate
- local -x PALUDIS_REDUCED_UID=0
- local -x PALUDIS_REDUCED_GID=0
- fi
-
- if ! nonfatal emake check ; then
- eerror "Tests failed. Looking for files for you to add to your bug report..."
- find "${S}" -type f -name '*.epicfail' -or -name '*.log' | while read a ; do
- eerror " $a"
- done
- die "Make check failed"
- fi
-}
-
-pkg_postinst() {
- local pm
- if [[ -f ${ROOT}/etc/env.d/50package-manager ]] ; then
- pm=$( source "${ROOT}"/etc/env.d/50package-manager ; echo "${PACKAGE_MANAGER}" )
- fi
-
- if [[ ${pm} != paludis ]] ; then
- elog "If you are using paludis or cave as your primary package manager,"
- elog "you should consider running:"
- elog " eselect package-manager set paludis"
- fi
-}
diff --git a/sys-apps/paludis/paludis-2.4.0_p20160112.ebuild b/sys-apps/paludis/paludis-2.4.0_p20160112.ebuild
deleted file mode 100644
index ef55347c6f8..00000000000
--- a/sys-apps/paludis/paludis-2.4.0_p20160112.ebuild
+++ /dev/null
@@ -1,154 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-# matching profile defaults for now
-RUBY_VER=2.0
-
-inherit bash-completion-r1 eutils python-single-r1 user
-
-DESCRIPTION="paludis, the other package mangler"
-HOMEPAGE="http://paludis.exherbo.org/"
-SRC_URI="http://dev.gentoo.org/~mgorny/dist/${P}.tar.xz"
-
-IUSE="doc pbins pink python ruby search-index test +xml"
-LICENSE="GPL-2 vim"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-
-COMMON_DEPEND="
- >=app-admin/eselect-1.2.13
- >=app-shells/bash-3.2
- dev-libs/libpcre[cxx]
- sys-apps/file
- pbins? ( >=app-arch/libarchive-3.1.2 )
- python? (
- ${PYTHON_DEPS}
- >=dev-libs/boost-1.41.0[python,${PYTHON_USEDEP}] )
- ruby? ( dev-lang/ruby:${RUBY_VER} )
- search-index? ( >=dev-db/sqlite-3 )
- xml? ( >=dev-libs/libxml2-2.6 )"
-
-DEPEND="${COMMON_DEPEND}
- app-arch/xz-utils
- >=app-text/asciidoc-8.6.3
- app-text/htmltidy
- app-text/xmlto
- >=sys-devel/gcc-4.7
- doc? (
- || (
- >=app-doc/doxygen-1.5.3
- <=app-doc/doxygen-1.5.1 )
- python? (
- dev-python/sphinx[${PYTHON_USEDEP}] )
- ruby? ( dev-ruby/syntax[ruby_targets_ruby${RUBY_VER/./}] )
- )
- virtual/pkgconfig
- test? ( >=dev-cpp/gtest-1.6.0-r1 )"
-
-RDEPEND="${COMMON_DEPEND}
- sys-apps/sandbox"
-
-PDEPEND="app-eselect/eselect-package-manager"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != buildonly ]]; then
- if id paludisbuild >/dev/null 2>/dev/null ; then
- if ! groups paludisbuild | grep --quiet '\<tty\>' ; then
- eerror "The 'paludisbuild' user is now expected to be a member of the"
- eerror "'tty' group. You should add the user to this group before"
- eerror "upgrading Paludis."
- die "Please add paludisbuild to tty group"
- fi
- fi
- fi
-
-}
-
-pkg_setup() {
- enewgroup "paludisbuild"
- enewuser "paludisbuild" -1 -1 "/var/tmp/paludis" "paludisbuild,tty"
-
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- # Fix the script shebang on Ruby scripts.
- # https://bugs.gentoo.org/show_bug.cgi?id=439372#c2
- sed -i -e "1s/ruby/&${RUBY_VER/./}/" ruby/demos/*.rb || die
-
- epatch_user
-}
-
-src_configure() {
- local myconf=(
- --htmldir=/usr/share/doc/${PF}/html
-
- $(use_enable doc doxygen)
- $(use_enable test gtest)
- $(use_enable pbins)
- $(use_enable pink)
- $(use_enable python)
- $(use python && use_enable doc python-doc)
- $(use_enable ruby)
- $(use ruby && use_enable doc ruby-doc)
- --with-ruby-version="${RUBY_VER}"
- $(use_enable search-index)
- $(use_enable xml)
-
- --enable-vim
- --with-config-framework=eselect
- --with-environments=default,portage
- --with-vim-install-dir=/usr/share/vim/vimfiles
- )
-
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- prune_libtool_files
-
- dobashcomp bash-completion/cave
-
- insinto /usr/share/zsh/site-functions
- doins zsh-completion/_cave
-}
-
-src_test() {
- # Work around Portage bugs
- local -x PALUDIS_DO_NOTHING_SANDBOXY="portage sucks"
- local -x BASH_ENV=/dev/null
-
- if [[ ${EUID} == 0 ]] ; then
- # hate
- local -x PALUDIS_REDUCED_UID=0
- local -x PALUDIS_REDUCED_GID=0
- fi
-
- if ! nonfatal emake -k check ; then
- eerror "Tests failed. Looking for files for you to add to your bug report..."
- find "${S}" -type f -name '*.epicfail' -or -name '*.log' | while read a ; do
- eerror " $a"
- done
- die "Make check failed"
- fi
-}
-
-pkg_postinst() {
- local pm
- if [[ -f ${ROOT}/etc/env.d/50package-manager ]] ; then
- pm=$( source "${ROOT}"/etc/env.d/50package-manager ; echo "${PACKAGE_MANAGER}" )
- fi
-
- if [[ ${pm} != paludis ]] ; then
- elog "If you are using paludis or cave as your primary package manager,"
- elog "you should consider running:"
- elog " eselect package-manager set paludis"
- fi
-}