summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-01-25 14:52:02 -0800
committerMatt Turner <mattst88@gentoo.org>2017-01-25 15:14:17 -0800
commitbe6e5d346a1544500dcdae39e28d1f1a057a1717 (patch)
treeb032923e6b75671bce257bfb01340556e52b1884
parentmedia-libs/mesa: Drop bogus dependency on virtual/libelf. (diff)
downloadgentoo-be6e5d346a1544500dcdae39e28d1f1a057a1717.tar.gz
gentoo-be6e5d346a1544500dcdae39e28d1f1a057a1717.tar.bz2
gentoo-be6e5d346a1544500dcdae39e28d1f1a057a1717.zip
media-libs/mesa: Depend on >=llvm-3.9.0 if building radv.
Bug: https://bugs.gentoo.org/602292
-rw-r--r--media-libs/mesa/mesa-13.0.3.ebuild8
-rw-r--r--media-libs/mesa/mesa-17.0.0_rc2.ebuild8
-rw-r--r--media-libs/mesa/mesa-9999.ebuild8
3 files changed, 18 insertions, 6 deletions
diff --git a/media-libs/mesa/mesa-13.0.3.ebuild b/media-libs/mesa/mesa-13.0.3.ebuild
index 8b4dec3e3308..bc78b1f64d03 100644
--- a/media-libs/mesa/mesa-13.0.3.ebuild
+++ b/media-libs/mesa/mesa-13.0.3.ebuild
@@ -57,7 +57,8 @@ REQUIRED_USE="
gles2? ( egl )
vaapi? ( gallium )
vdpau? ( gallium )
- vulkan? ( || ( video_cards_i965 video_cards_radeonsi ) )
+ vulkan? ( || ( video_cards_i965 video_cards_radeonsi )
+ video_cards_radeonsi? ( llvm ) )
wayland? ( egl gbm )
xa? ( gallium )
video_cards_freedreno? ( gallium )
@@ -96,7 +97,10 @@ RDEPEND="
>=x11-libs/libxcb-1.9.3:=[${MULTILIB_USEDEP}]
x11-libs/libXfixes:=[${MULTILIB_USEDEP}]
llvm? (
- video_cards_radeonsi? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
+ video_cards_radeonsi? (
+ virtual/libelf:0=[${MULTILIB_USEDEP}]
+ vulkan? ( >=sys-devel/llvm-3.9.0:=[${MULTILIB_USEDEP}] )
+ )
>=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
)
nettle? ( dev-libs/nettle:=[${MULTILIB_USEDEP}] )
diff --git a/media-libs/mesa/mesa-17.0.0_rc2.ebuild b/media-libs/mesa/mesa-17.0.0_rc2.ebuild
index 6aec3354b8ec..d561cd162a48 100644
--- a/media-libs/mesa/mesa-17.0.0_rc2.ebuild
+++ b/media-libs/mesa/mesa-17.0.0_rc2.ebuild
@@ -55,7 +55,8 @@ REQUIRED_USE="
gles2? ( egl )
vaapi? ( gallium )
vdpau? ( gallium )
- vulkan? ( || ( video_cards_i965 video_cards_radeonsi ) )
+ vulkan? ( || ( video_cards_i965 video_cards_radeonsi )
+ video_cards_radeonsi? ( llvm ) )
wayland? ( egl gbm )
xa? ( gallium )
video_cards_freedreno? ( gallium )
@@ -96,7 +97,10 @@ RDEPEND="
>=x11-libs/libxcb-1.9.3:=[${MULTILIB_USEDEP}]
x11-libs/libXfixes:=[${MULTILIB_USEDEP}]
llvm? (
- video_cards_radeonsi? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
+ video_cards_radeonsi? (
+ virtual/libelf:0=[${MULTILIB_USEDEP}]
+ vulkan? ( >=sys-devel/llvm-3.9.0:=[${MULTILIB_USEDEP}] )
+ )
>=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
)
opencl? (
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 3096064b6862..189c696fba57 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -55,7 +55,8 @@ REQUIRED_USE="
gles2? ( egl )
vaapi? ( gallium )
vdpau? ( gallium )
- vulkan? ( || ( video_cards_i965 video_cards_radeonsi ) )
+ vulkan? ( || ( video_cards_i965 video_cards_radeonsi )
+ video_cards_radeonsi? ( llvm ) )
wayland? ( egl gbm )
xa? ( gallium )
video_cards_freedreno? ( gallium )
@@ -96,7 +97,10 @@ RDEPEND="
>=x11-libs/libxcb-1.9.3:=[${MULTILIB_USEDEP}]
x11-libs/libXfixes:=[${MULTILIB_USEDEP}]
llvm? (
- video_cards_radeonsi? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
+ video_cards_radeonsi? (
+ virtual/libelf:0=[${MULTILIB_USEDEP}]
+ vulkan? ( >=sys-devel/llvm-3.9.0:=[${MULTILIB_USEDEP}] )
+ )
>=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
)
opencl? (