summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-12-17 16:10:43 +0200
committerMart Raudsepp <leio@gentoo.org>2018-12-17 17:07:45 +0200
commitbe7e5cb92c0c0f6e76306737efc921e6c2e5d551 (patch)
tree88068d8715b9a0c361b10f821c6192c6bcbeed72
parentdev-libs/glib: add details about commented out test unit (diff)
downloadgentoo-be7e5cb92c0c0f6e76306737efc921e6c2e5d551.tar.gz
gentoo-be7e5cb92c0c0f6e76306737efc921e6c2e5d551.tar.bz2
gentoo-be7e5cb92c0c0f6e76306737efc921e6c2e5d551.zip
dev-util/sysprof: bump to 3.30.2
Signed-off-by: Mart Raudsepp <leio@gentoo.org> Package-Manager: Portage-2.3.52, Repoman-2.3.11
-rw-r--r--dev-util/sysprof/Manifest1
-rw-r--r--dev-util/sysprof/sysprof-3.30.2.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-util/sysprof/Manifest b/dev-util/sysprof/Manifest
index 75ff7d4efdfa..896392cf250f 100644
--- a/dev-util/sysprof/Manifest
+++ b/dev-util/sysprof/Manifest
@@ -1,3 +1,4 @@
DIST sysprof-3.24.1.tar.xz 595920 BLAKE2B 90582eab3fc12a0169c151ce0fad20b839841f77a31e5858f8d660f9b0f2630396bec3b239dd88baa3f6e3dd936bdd6d63a652e491a1d32f966a755f9099f160 SHA512 5d323bcb9923c511065132711963dc8856c4d837b4d7ccfae5cc5794be5ac8ad1dc42504025469199f4bfd6a6fad4d8f49b7b21cab6f0c9a954820182e75c7d0
DIST sysprof-3.26.1.tar.xz 609076 BLAKE2B fd10ce27b224100558ff5bb9c75cfffcb76b2331d2c4056bd73a9ace1ea155e61d705240acf6fefa805fba2333f6d439369d5b1cc16e0c537ab9fed408bf6d85 SHA512 ee03360e4971cd91129bac3cc9d2cf292d29aafe1cdacd078e404ee15c3ff02bcd0c0159502605c00eb2abd3a46917cf70458ad05e48b594eeb2835ead55c34c
DIST sysprof-3.28.1.tar.xz 380720 BLAKE2B 0a3b93659e421b717230bff6e90d20b28f8abc8491fddb51bc3f106b6cd8b038254e1fd0260c6eee2c2b83d77765be43f394d49bd34c054c36d6427ef419fefa SHA512 ca75c279bcb8cb37bffdba51d5b3481c3ece104847b64c0b8cb534468c9350a96c7224bf261ef892817e53aff2cff90a2b808f5db5a9afd6230721664b83809b
+DIST sysprof-3.30.2.tar.xz 393420 BLAKE2B 5e86a78c231d2d2c601198e066c463d8bec95ab1ae6d0f6678e6e80305b8a6d53c604ce54d9fc2a473e4679695cef709f0e1a9514f1091719f33a58b92c896eb SHA512 70c49f7c20742aad82c8d9b1e303d06ca5fd2d27a6868872d28affea22278d381bf3eb0d181cbd1bfa490bda2878c52748ac29273e9e608452e9bf4f29fd9e2a
diff --git a/dev-util/sysprof/sysprof-3.30.2.ebuild b/dev-util/sysprof/sysprof-3.30.2.ebuild
new file mode 100644
index 000000000000..e3dd7be49675
--- /dev/null
+++ b/dev-util/sysprof/sysprof-3.30.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome.org gnome2-utils meson systemd xdg
+
+DESCRIPTION="System-wide Linux Profiler"
+HOMEPAGE="http://sysprof.com/"
+
+LICENSE="GPL-3+ GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk systemd"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ sys-auth/polkit
+ gtk? ( >=x11-libs/gtk+-3.22.0:3 )
+ systemd? ( >=sys-apps/systemd-222 )
+"
+# libxml2 required for glib-compile-resources; appstream-glib for appdata.xml developer_name tag translation
+DEPEND="${RDEPEND}
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ >=sys-kernel/linux-headers-2.6.32
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # -Dwith_sysprofd=host currently unavailable from ebuild
+ local emesonargs=(
+ $(meson_use gtk enable_gtk)
+ -Dwith_sysprofd=$(usex systemd bundled none)
+ -Dsystemdunitdir=$(systemd_get_systemunitdir)
+ # -Ddebugdir
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+
+ elog "On many systems, especially amd64, it is typical that with a modern"
+ elog "toolchain -fomit-frame-pointer for gcc is the default, because"
+ elog "debugging is still possible thanks to gcc4/gdb location list feature."
+ elog "However sysprof is not able to construct call trees if frame pointers"
+ elog "are not present. Therefore -fno-omit-frame-pointer CFLAGS is suggested"
+ elog "for the libraries and applications involved in the profiling. That"
+ elog "means a CPU register is used for the frame pointer instead of other"
+ elog "purposes, which means a very minimal performance loss when there is"
+ elog "register pressure."
+ if ! use systemd; then
+ elog ""
+ elog "Without systemd, sysprof may not function when launched as a regular user,"
+ elog "thus suboptimal running from root account may be necessary."
+ if use gtk; then
+ elog "Under wayland, that limits the recording usage to sysprof-cli utility."
+ fi
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}