summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-09-23 12:22:10 +1000
committerMichael Palimaka <kensington@gentoo.org>2017-09-23 12:22:23 +1000
commitbe7f591c84d0b5b059a1bf5224fe0f20ac3421d8 (patch)
treece9f8d70802abf4a31bb426f0d0e0293022783cc
parentapp-admin/setools: drop old (diff)
downloadgentoo-be7f591c84d0b5b059a1bf5224fe0f20ac3421d8.tar.gz
gentoo-be7f591c84d0b5b059a1bf5224fe0f20ac3421d8.tar.bz2
gentoo-be7f591c84d0b5b059a1bf5224fe0f20ac3421d8.zip
app-text/qpdfview: remove qt4 support
Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--app-text/qpdfview/qpdfview-0.4.16.ebuild42
-rw-r--r--app-text/qpdfview/qpdfview-0.4.17_beta1.ebuild42
2 files changed, 32 insertions, 52 deletions
diff --git a/app-text/qpdfview/qpdfview-0.4.16.ebuild b/app-text/qpdfview/qpdfview-0.4.16.ebuild
index 472a947b0f7..89e07a090fb 100644
--- a/app-text/qpdfview/qpdfview-0.4.16.ebuild
+++ b/app-text/qpdfview/qpdfview-0.4.16.ebuild
@@ -13,43 +13,37 @@ SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux"
-IUSE="cups +dbus djvu fitz +pdf postscript qt5 +sqlite +svg synctex"
+IUSE="cups +dbus djvu fitz +pdf postscript +sqlite +svg synctex"
REQUIRED_USE="?? ( fitz pdf )"
RDEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
cups? ( net-print/cups )
+ dbus? ( dev-qt/qtdbus:5 )
djvu? ( app-text/djvu )
fitz? ( >=app-text/mupdf-1.7:= )
+ pdf? (
+ >=app-text/poppler-0.35[qt5]
+ dev-qt/qtxml:5
+ )
postscript? ( app-text/libspectre )
- !qt5? ( dev-qt/qtcore:4[iconv]
- dev-qt/qtgui:4
- sys-apps/file
- dbus? ( dev-qt/qtdbus:4 )
- pdf? ( >=app-text/poppler-0.35[qt4] )
- sqlite? ( dev-qt/qtsql:4[sqlite] )
- svg? ( dev-qt/qtsvg:4 ) )
- qt5? ( dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtprintsupport:5
- dev-qt/qtwidgets:5
- dbus? ( dev-qt/qtdbus:5 )
- pdf? ( >=app-text/poppler-0.35[qt5]
- dev-qt/qtxml:5 )
- sqlite? ( dev-qt/qtsql:5[sqlite] )
- svg? ( dev-qt/qtsvg:5 ) )
+ sqlite? ( dev-qt/qtsql:5[sqlite] )
+ svg? ( dev-qt/qtsvg:5 )
!svg? ( virtual/freedesktop-icon-theme )
synctex? ( app-text/texlive-core )"
DEPEND="${RDEPEND}
- qt5? ( dev-qt/linguist-tools:5 )
+ dev-qt/linguist-tools:5
virtual/pkgconfig"
DOCS=( CHANGES CONTRIBUTORS README TODO )
src_prepare() {
- local mylrelease="$(qt4_get_bindir)"/lrelease
- use qt5 && mylrelease="$(qt5_get_bindir)"/lrelease
+ local mylrelease="$(qt5_get_bindir)"/lrelease
prepare_locale() {
"${mylrelease}" "translations/${PN}_${1}.ts" || die "preparing ${1} locale failed"
@@ -83,11 +77,7 @@ src_configure() {
CONFIG+="${myconfig[@]}"
PLUGIN_INSTALL_PATH="${EPREFIX}/usr/$(get_libdir)/${PN}"
)
- if use qt5; then
- eqmake5 "${myqmakeargs[@]}"
- else
- eqmake4 "${myqmakeargs[@]}"
- fi
+ eqmake5 "${myqmakeargs[@]}"
}
src_install() {
diff --git a/app-text/qpdfview/qpdfview-0.4.17_beta1.ebuild b/app-text/qpdfview/qpdfview-0.4.17_beta1.ebuild
index 103b3111028..0002d29b3a0 100644
--- a/app-text/qpdfview/qpdfview-0.4.17_beta1.ebuild
+++ b/app-text/qpdfview/qpdfview-0.4.17_beta1.ebuild
@@ -13,36 +13,31 @@ SRC_URI="https://launchpad.net/${PN}/trunk/${PV/_/}/+download/${P/_/}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-IUSE="cups +dbus djvu fitz +pdf postscript qt5 +sqlite +svg synctex"
+IUSE="cups +dbus djvu fitz +pdf postscript +sqlite +svg synctex"
REQUIRED_USE="?? ( fitz pdf )"
RDEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
cups? ( net-print/cups )
+ dbus? ( dev-qt/qtdbus:5 )
djvu? ( app-text/djvu )
fitz? ( >=app-text/mupdf-1.7:= )
+ pdf? (
+ >=app-text/poppler-0.35[qt5]
+ dev-qt/qtxml:5
+ )
postscript? ( app-text/libspectre )
- !qt5? ( dev-qt/qtcore:4[iconv]
- dev-qt/qtgui:4
- sys-apps/file
- dbus? ( dev-qt/qtdbus:4 )
- pdf? ( >=app-text/poppler-0.35[qt4] )
- sqlite? ( dev-qt/qtsql:4[sqlite] )
- svg? ( dev-qt/qtsvg:4 ) )
- qt5? ( dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtprintsupport:5
- dev-qt/qtwidgets:5
- dbus? ( dev-qt/qtdbus:5 )
- pdf? ( >=app-text/poppler-0.35[qt5]
- dev-qt/qtxml:5 )
- sqlite? ( dev-qt/qtsql:5[sqlite] )
- svg? ( dev-qt/qtsvg:5 ) )
+ sqlite? ( dev-qt/qtsql:5[sqlite] )
+ svg? ( dev-qt/qtsvg:5 )
!svg? ( virtual/freedesktop-icon-theme )
synctex? ( app-text/texlive-core )"
DEPEND="${RDEPEND}
- qt5? ( dev-qt/linguist-tools:5 )
+ dev-qt/linguist-tools:5
virtual/pkgconfig"
DOCS=( CHANGES CONTRIBUTORS README TODO )
@@ -50,8 +45,7 @@ DOCS=( CHANGES CONTRIBUTORS README TODO )
S="${WORKDIR}/${P/_/}"
src_prepare() {
- local mylrelease="$(qt4_get_bindir)"/lrelease
- use qt5 && mylrelease="$(qt5_get_bindir)"/lrelease
+ local mylrelease="$(qt5_get_bindir)"/lrelease
prepare_locale() {
"${mylrelease}" "translations/${PN}_${1}.ts" || die "preparing ${1} locale failed"
@@ -85,11 +79,7 @@ src_configure() {
CONFIG+="${myconfig[@]}"
PLUGIN_INSTALL_PATH="${EPREFIX}/usr/$(get_libdir)/${PN}"
)
- if use qt5; then
- eqmake5 "${myqmakeargs[@]}"
- else
- eqmake4 "${myqmakeargs[@]}"
- fi
+ eqmake5 "${myqmakeargs[@]}"
}
src_install() {