summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcharIes17 <charles17@arcor.de>2018-01-28 11:59:39 +0100
committerAaron Bauman <bman@gentoo.org>2018-03-26 20:30:33 -0400
commitc042c34a51c0ca551c55d8c428c419e2e3685021 (patch)
treeb0d797ed9e2387339f6ce9ad0177684b323267ed
parentlxde-base/lxrandr: Remove old (diff)
downloadgentoo-c042c34a51c0ca551c55d8c428c419e2e3685021.tar.gz
gentoo-c042c34a51c0ca551c55d8c428c419e2e3685021.tar.bz2
gentoo-c042c34a51c0ca551c55d8c428c419e2e3685021.zip
lxde-base/lxappearance: Add locale handling
Package-Manager: Portage-2.3.19, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/6981
-rw-r--r--lxde-base/lxappearance/lxappearance-0.6.3-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/lxde-base/lxappearance/lxappearance-0.6.3-r1.ebuild b/lxde-base/lxappearance/lxappearance-0.6.3-r1.ebuild
new file mode 100644
index 000000000000..f2133695a5f9
--- /dev/null
+++ b/lxde-base/lxappearance/lxappearance-0.6.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PLOCALES="ar be bg ca cs da de el en_GB es et eu fa fi fo fr gl he hr hu id is
+it ja kk ko lg lt nl pa pl pt_BR pt ro ru sl sr@latin sr sv te tr tt_RU ug uk
+ur_PK ur vi zh_CN zh_TW"
+
+PLOCALE_BACKUP="en_GB"
+
+inherit l10n
+
+DESCRIPTION="LXDE GTK+ theme switcher"
+HOMEPAGE="https://wiki.lxde.org/en/LXAppearance"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="dbus"
+
+RDEPEND="x11-libs/gtk+:2
+ dbus? ( dev-libs/dbus-glib )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+src_prepare() {
+ default
+
+ export LINGUAS="${LINGUAS:-${PLOCALE_BACKUP}}"
+ l10n_get_locales > po/LINGUAS || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable dbus)
+}