summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-01-14 00:40:35 +0100
committerDavid Seifert <soap@gentoo.org>2016-01-14 00:41:49 +0100
commitc2cb1cec69d92ebe7dd90f896b1bfcb45a61724f (patch)
tree4dcf4a32d9f0ebdb2718369b8520a1f1da6ea500
parentdev-util/trace-cmd: version bump to 2.6 (diff)
downloadgentoo-c2cb1cec69d92ebe7dd90f896b1bfcb45a61724f.tar.gz
gentoo-c2cb1cec69d92ebe7dd90f896b1bfcb45a61724f.tar.bz2
gentoo-c2cb1cec69d92ebe7dd90f896b1bfcb45a61724f.zip
media-sound/toolame: add -std=gnu89 to CFLAGS to restore pre-GCC5 semantics
Gentoo-Bug: 571774 In addition, modernize to EAPI=6 and amend patches accordingly. Package-Manager: portage-2.2.26
-rw-r--r--media-sound/toolame/files/toolame-02l-gentoo.diff4
-rw-r--r--media-sound/toolame/toolame-02l-r4.ebuild36
2 files changed, 38 insertions, 2 deletions
diff --git a/media-sound/toolame/files/toolame-02l-gentoo.diff b/media-sound/toolame/files/toolame-02l-gentoo.diff
index 1b011600e7ef..f96020f0a815 100644
--- a/media-sound/toolame/files/toolame-02l-gentoo.diff
+++ b/media-sound/toolame/files/toolame-02l-gentoo.diff
@@ -1,5 +1,5 @@
---- Makefile 2003-03-02 08:07:02.000000000 +0100
-+++ Makefile.new 2003-04-14 14:00:10.000000000 +0200
+--- toolame-02l/Makefile 2003-03-02 08:07:02.000000000 +0100
++++ toolame-02l/Makefile.new 2003-04-14 14:00:10.000000000 +0200
@@ -1,6 +1,3 @@
-
-CC = gcc
diff --git a/media-sound/toolame/toolame-02l-r4.ebuild b/media-sound/toolame/toolame-02l-r4.ebuild
new file mode 100644
index 000000000000..19717aba0a5c
--- /dev/null
+++ b/media-sound/toolame/toolame-02l-r4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="tooLAME - an optimized mpeg 1/2 layer 2 audio encoder"
+HOMEPAGE="http://www.planckenergy.com"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-gentoo.diff"
+ "${FILESDIR}/${P}-uint.patch"
+ "${FILESDIR}/${P}-uint32_t.patch"
+)
+
+src_prepare() {
+ # fix #571774 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+
+ append-lfs-flags
+ tc-export CC
+
+ default
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README HISTORY FUTURE html/* text/*
+}