summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Ziak <0xe2.0x9a.0x9b@gmail.com>2018-10-11 12:45:01 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-18 21:20:40 +0200
commitc3c39d455dc7c2cbb6125d6735984229117489cb (patch)
tree2e930ddd8354c75242911f816c5a585fa47b04f9
parentmedia-gfx/ahoviewer: new package (diff)
downloadgentoo-c3c39d455dc7c2cbb6125d6735984229117489cb.tar.gz
gentoo-c3c39d455dc7c2cbb6125d6735984229117489cb.tar.bz2
gentoo-c3c39d455dc7c2cbb6125d6735984229117489cb.zip
app-emulation/fuse: bump to version 1.5.6
Signed-off-by: Jan Ziak <0xe2.0x9a.0x9b@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-emulation/fuse/Manifest1
-rw-r--r--app-emulation/fuse/fuse-1.5.6.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/app-emulation/fuse/Manifest b/app-emulation/fuse/Manifest
index f2a0c1aafbfa..6f8cc3a2a4c2 100644
--- a/app-emulation/fuse/Manifest
+++ b/app-emulation/fuse/Manifest
@@ -1,2 +1,3 @@
DIST fuse-1.5.3.tar.gz 1627487 BLAKE2B d942f0131ce713e8592abec6443015aca3f1ae73739f1db0eae84a19e4320fd8bffbd7d36afaf65b08cf059305f85a8854d39d46519ed7abd3705b11156d069c SHA512 6596f789a685c46752c46b2432953c0d9abb620b23541cdbfc066c224fcba47ac7be75db678e2ff76622a7d02cc81b7dfeae672dfdaee1085d2ae5f768a4d8c0
DIST fuse-1.5.5.tar.gz 1629577 BLAKE2B b4765047507049b2fa3547d47384df2c5e6de75b74b7aa8d3549ca47ae6f3dad53a37fc48112db86426ce3d2d84711aa029d158c75eba89214761ed82d7ab57a SHA512 186635b632df9767b9ffcbba484370adc47833bd06240474db9c4dfe88b03209e15fc0c86a2f200b2cc7bd95ad93bf1f93f38d7f669b5c163f68e80802fb1041
+DIST fuse-1.5.6.tar.gz 1634711 BLAKE2B a581c106c668f0342b4a3b4ebbc0e92e750806e59d067798e23da02284cbb9a17cf580c5b6369144863fbf64b12326ea2982e4d83e87354d62ff51926e3293de SHA512 84312e4f83883b36d06f2b96ded1bfc71675cba71a0848f4cbb5a233a1d1c06466013d2655d759397f32d6d67d6ba26b2b6a5041796cb9143cd0b354a88fd589
diff --git a/app-emulation/fuse/fuse-1.5.6.ebuild b/app-emulation/fuse/fuse-1.5.6.ebuild
new file mode 100644
index 000000000000..0e1754ea0792
--- /dev/null
+++ b/app-emulation/fuse/fuse-1.5.6.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Free Unix Spectrum Emulator by Philip Kendall"
+HOMEPAGE="http://fuse-emulator.sourceforge.net"
+SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa ao backend-fbcon backend-sdl backend-svga backend-X gpm joystick memlimit png xml"
+
+# Only one UI back-end can be enabled at a time
+REQUIRED_USE="?? ( backend-fbcon backend-sdl backend-svga backend-X )"
+
+RDEPEND="
+ >=app-emulation/libspectrum-1.4.4
+ dev-libs/glib:2
+ alsa? ( media-libs/alsa-lib )
+ ao? ( media-libs/libao )
+ backend-sdl? ( media-libs/libsdl )
+ backend-svga? ( media-libs/svgalib )
+ backend-X? ( x11-libs/libX11 x11-libs/libXext )
+ !backend-fbcon? ( !backend-sdl? ( !backend-svga? ( !backend-X? ( x11-libs/gtk+:3 ) ) ) )
+ gpm? ( sys-libs/gpm )
+ joystick? ( media-libs/libjsw )
+ png? ( media-libs/libpng:0= sys-libs/zlib )
+ xml? ( dev-libs/libxml2:2 )"
+DEPEND="${RDEPEND}
+ backend-fbcon? ( virtual/linux-sources )
+ dev-lang/perl
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README THANKS )
+
+src_configure() {
+ local myconf=(
+ --without-win32
+ $(use_with alsa)
+ $(use_with ao libao)
+ $(use_with gpm)
+ $(use_with joystick)
+ $(use_enable joystick ui-joystick)
+ $(use_enable memlimit smallmem)
+ $(use_with png)
+ $(use_with xml libxml2)
+ )
+
+ if use backend-sdl; then
+ myconf+=("--with-sdl")
+ elif use backend-X; then
+ myconf+=("--without-gtk")
+ elif use backend-svga; then
+ myconf+=("--with-svgalib")
+ elif use backend-fbcon; then
+ myconf+=("--with-fb")
+ else
+ myconf+=("--with-gtk")
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ emake test
+}