summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-07-03 07:47:20 +0200
committerHans de Graaff <graaff@gentoo.org>2016-07-03 07:47:20 +0200
commitc695e2d9353944fc80ac05b938fe919e77552691 (patch)
tree45d392c8e67297677be57edfaef3af7ae072c68e
parentdev-ruby/rspec-mocks: add rspec 3.5 (diff)
downloadgentoo-c695e2d9353944fc80ac05b938fe919e77552691.tar.gz
gentoo-c695e2d9353944fc80ac05b938fe919e77552691.tar.bz2
gentoo-c695e2d9353944fc80ac05b938fe919e77552691.zip
dev-ruby/rspec-expectations: add rspec 3.5
Package-Manager: portage-2.2.28
-rw-r--r--dev-ruby/rspec-expectations/Manifest1
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-3.5.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-ruby/rspec-expectations/Manifest b/dev-ruby/rspec-expectations/Manifest
index c05fbf539850..55d0fe343718 100644
--- a/dev-ruby/rspec-expectations/Manifest
+++ b/dev-ruby/rspec-expectations/Manifest
@@ -2,3 +2,4 @@ DIST rspec-expectations-2.14.5-git.tgz 93680 SHA256 ceba7a62ad87285f1ea01db4798e
DIST rspec-expectations-2.99.2-git.tgz 106884 SHA256 4c1b38198d214ab2d4e297fdfbd89d3c3ae20c6b144882e53e935cfbc9878f68 SHA512 6042cafe225b2b16df458c7bf69e1694b637afcac6f6195e35a0be199432610457ccaa3e7e4bd114b27a7a6c3d530d94f4c0603c65f469cbadc55bd3f75b6f3a WHIRLPOOL 4a390f55bac3180a876bd59f58ce7c2ed87611b94c9610c950dc138ef14c8966e62d79aa4f63771c373760d0b9f4f51a9aaa6cbc4fc600573c6cb12ddc0e278d
DIST rspec-expectations-3.3.1-git.tgz 171117 SHA256 a40feb73c5c54fd6464ca262af4be50ef9d5e4a785b5ae7862946da42837e112 SHA512 fe0e5fc4e00c8d51866bc9699bc25b1e702c765c5443abbebe2f016833c6f09f9f8f35d86520b59d51ad0a196551f68c39a5ec707658826af838ed274f4986ff WHIRLPOOL 5dc55d62ec1df5add711c07470d2d7020b875bf43a57788ceb84b05807ec9d3b2e395fde16f14c06d265e8c36b44e9a9c9da306c049a019289a1bc3d265e18e1
DIST rspec-expectations-3.4.0-git.tgz 181527 SHA256 4cfdedf39382d27335208fc1ce7efbf3babd3212e021ece5593e39feb3e51556 SHA512 688fcee04517e1354ce7d180c9e8c8e55614261af416b80dfc663293f9d66348fc2c17dc9b31aec7bc12fd9045d6507d9f11017bb5a757e41dbcaea18efa684f WHIRLPOOL 3d9a8f9b7515433b80dc70ba922813f0b2564bd0e1a0f1fe6dd370befef76a8453b1ce59b8fede435a99f8f604a24a56c158bd5c0be5bc3627c0b2181193ca16
+DIST rspec-expectations-3.5.0-git.tgz 187600 SHA256 edbd7dec2b1e685b12e3a14c3ea4d8bb3c5d82fe0f69afeea9c9f4d10da03c1d SHA512 e6077549a028de0e34cdd50d93552ca3ee0f30bb550e9df20d391f287beb57070dcb3a5104627e7adb55689e7b102c91b7d3a3b944b8c4ff1235761140f2dce0 WHIRLPOOL d173b832c43e723b0a46caa72f45fa27f8c611567eca544ad6e30e661ca32edca063ba4cd621fb411c527f64371b9e1c04b58192b330878704de2a47b31dc451
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-3.5.0.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-3.5.0.ebuild
new file mode 100644
index 000000000000..58165ecd5f50
--- /dev/null
+++ b/dev-ruby/rspec-expectations/rspec-expectations-3.5.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec-expectations"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc64 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+SUBVERSION="$(get_version_component_range 1-2)"
+
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.2.0 <dev-ruby/diff-lcs-2
+ =dev-ruby/rspec-support-${SUBVERSION}*"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-mocks-3.2.0:3
+ >=dev-ruby/rspec-support-3.5.0:3
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm -f Gemfile || die
+
+ # fix up the gemspecs
+ sed -i \
+ -e '/git ls/d' \
+ -e '/add_development_dependency/d' \
+ "${RUBY_FAKEGEM_GEMSPEC}" || die
+}