summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-10-06 08:40:31 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-06 09:10:39 +0200
commitc7552c942ebdc70cce60ea8e00ed89ece39fb855 (patch)
treee59a9100f78c223e78a0a0dd618c861c191921b7
parentmedia-gfx/valentina: updated live ebuild dependencies (diff)
downloadgentoo-c7552c942ebdc70cce60ea8e00ed89ece39fb855.tar.gz
gentoo-c7552c942ebdc70cce60ea8e00ed89ece39fb855.tar.bz2
gentoo-c7552c942ebdc70cce60ea8e00ed89ece39fb855.zip
dev-util/sysdig: Bump to 0.24.1, bugfix
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-util/sysdig/Manifest1
-rw-r--r--dev-util/sysdig/sysdig-0.24.1.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/dev-util/sysdig/Manifest b/dev-util/sysdig/Manifest
index 9db66838d256..967b1b9ac734 100644
--- a/dev-util/sysdig/Manifest
+++ b/dev-util/sysdig/Manifest
@@ -1,2 +1,3 @@
DIST sysdig-0.23.1.tar.gz 830420 BLAKE2B 31a8c4cd8b570a308c81b4df53494cff2619d05724e509634671968025ebee0e46c5e59a7c877e6d9f1f1eba86a8a27a0cd9c5b66e75723ec8eec66c6782d4c0 SHA512 059a564a5d31381efae4bc50d2b83f83a1d051f1cfb9fa6bfb75a341305149073a6eb3b9a3ce4da12fa293e75b71f8b30c9021ac8d4c4a2f59a40e35a5ffd482
DIST sysdig-0.24.0.tar.gz 846171 BLAKE2B fc65c6df7351e1e1f4afd168cf9eaaed8d714539822ede1ce1941ead191b0d6e9898bd1da36a78737d4662b8e47090d63978441ce01fe30f13c504a3fa09eb5c SHA512 ff8162fbd5941a7a5532e8c1d0300acdd2d7ae85044600021f12e76f3752b50c46c894ea2007d0467761927403a784b85cfc000e735004e5fdbd48c31c20071e
+DIST sysdig-0.24.1.tar.gz 846153 BLAKE2B bc64317e02526d9729c9fb3738f2982f4b425cdb43c64f77944938186cde4ed2d8d2649984efe0055bbaed250b08bda4008272805024e1d8993e17bc93509663 SHA512 a89ce82527b47104161668e134387a04f4a6753adcd881df25410b629603b58fc8f675de6941f4911ad2da42ffbfd46b38f9cc9837c0809c559fee9a739a204a
diff --git a/dev-util/sysdig/sysdig-0.24.1.ebuild b/dev-util/sysdig/sysdig-0.24.1.ebuild
new file mode 100644
index 000000000000..3ba452c42e38
--- /dev/null
+++ b/dev-util/sysdig/sysdig-0.24.1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+MODULES_OPTIONAL_USE=modules
+inherit linux-mod bash-completion-r1 cmake-utils
+
+DESCRIPTION="A system exploration and troubleshooting tool"
+HOMEPAGE="https://www.sysdig.org/"
+SRC_URI="https://github.com/draios/sysdig/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0
+ modules? ( || ( MIT GPL-2 ) )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl +modules"
+
+RDEPEND="
+ app-misc/jq:0=
+ dev-cpp/tbb:0=
+ dev-lang/luajit:2=
+ >=dev-libs/jsoncpp-0.6_pre:0=
+ dev-libs/libb64:0=
+ sys-libs/ncurses:0=
+ sys-libs/zlib:0=
+ libressl? ( dev-libs/libressl:0= )
+ !libressl? ( dev-libs/openssl:0= )
+ net-misc/curl:0="
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/os-headers"
+
+# needed for the kernel module
+CONFIG_CHECK="HAVE_SYSCALL_TRACEPOINTS ~TRACEPOINTS"
+
+pkg_pretend() {
+ linux-mod_pkg_setup
+}
+
+pkg_setup() {
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ sed -i -e 's:-ggdb::' CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ # we will use linux-mod for that
+ -DBUILD_DRIVER=OFF
+ # libscap examples are not installed or really useful
+ -DBUILD_LIBSCAP_EXAMPLES=OFF
+
+ # unbundle the deps
+ -DUSE_BUNDLED_DEPS=OFF
+ )
+
+ cmake-utils_src_configure
+
+ # setup linux-mod ugliness
+ MODULE_NAMES="sysdig-probe(extra:${S}/driver:)"
+ BUILD_PARAMS='KERNELDIR="${KERNEL_DIR}"'
+ BUILD_TARGETS="all"
+
+ if use modules; then
+ cmake-utils_src_make configure_driver
+
+ cp "${BUILD_DIR}"/driver/Makefile.dkms driver/Makefile || die
+ fi
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ linux-mod_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ linux-mod_src_install
+
+ # remove sources
+ rm -r "${ED%/}"/usr/src || die
+
+ # move bashcomp to the proper location
+ dobashcomp "${ED%/}"/usr/etc/bash_completion.d/sysdig || die
+ rm -r "${ED%/}"/usr/etc || die
+}