summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-12-22 21:28:23 +0100
committerManuel Rüger <mrueg@gentoo.org>2015-12-22 21:28:23 +0100
commitc779ef6b4112051fd17f3250c01e78d80d3461fd (patch)
treec13df904f134680df68b86518d16f6c9fb46b8a4
parentdev-db/percona-server: Version bump wrt bug 569008 (diff)
downloadgentoo-c779ef6b4112051fd17f3250c01e78d80d3461fd.tar.gz
gentoo-c779ef6b4112051fd17f3250c01e78d80d3461fd.tar.bz2
gentoo-c779ef6b4112051fd17f3250c01e78d80d3461fd.zip
dev-util/pycharm-community: Version bump
Gentoo-Bug: 564766 Package-Manager: portage-2.2.26
-rw-r--r--dev-util/pycharm-community/Manifest1
-rw-r--r--dev-util/pycharm-community/pycharm-community-5.0.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/pycharm-community/Manifest b/dev-util/pycharm-community/Manifest
index bdc3a128fa07..f58625905757 100644
--- a/dev-util/pycharm-community/Manifest
+++ b/dev-util/pycharm-community/Manifest
@@ -3,3 +3,4 @@ DIST pycharm-community-4.0.6.tar.gz 121278114 SHA256 7aa0ed3d743ed6886329671d2e5
DIST pycharm-community-4.5.3.tar.gz 121605129 SHA256 205247b94965d9499e55d13ec701364475ff823d9353d967744750f6ceadc38d SHA512 0ae316890d6e348024f974a81cca9669c61f005a7af0cd0ef4d2f051fcb71cebbe372446f3a660f9c2a87837d7986809493499b34311a175542751d4f8597753 WHIRLPOOL e3895326751e6fd97a6ec60fc3933fc07b61337668dd18662ab22bb85f41fac1fca2511bf8eccfa0946dffa5f51f9cb24fda6019c88c88e07f281e390e6a37d9
DIST pycharm-community-4.5.4.tar.gz 121580731 SHA256 6bdd344eb88ee50cf29e98278c87faad0d1a23a7ec84c1794b956d2633024228 SHA512 e0c90fd84d60e1ac644c2b29aef484c1768cf8832c70cbc1a7905b64e0ef0fd7ec50665b9b15fcdaad762852e42103487b59fc4c8d1e711fd3a30123f8c959eb WHIRLPOOL d3725d9f3d983edf111f8aeb903bced2df643e9b39dcff59f21c176a16d9304dfe833ee542e204d1a4f5cdfadb33025587a669f190202bbae83cd9d102250c08
DIST pycharm-community-5.0.1.tar.gz 134214228 SHA256 8e8b276954b8cc5e5afa79918c50cf60fc21bf5cddce6a6fa2e232627c8da392 SHA512 4f5d193b30e3d30c1bff7f2212ef061595e1f31587c16f2a527d85962ac500d86b4be8abe631f219386ec893693999248fdf92f3bbcd115f3593513e60df2fdd WHIRLPOOL b3b5d49541c4a9c1f6acecac017fc84794b6b33b0d8995a58143258641fe9737c226fe2d488b9f9ace364265885542cb51c07e12d34e7f70027b8d15d9104f31
+DIST pycharm-community-5.0.2.tar.gz 136420461 SHA256 eadc36ae55237b783fbc528b6007e1755606ef7a95b7cc8dec27f44a829e545b SHA512 f8eabd233a70ea27f8eeb8b2307b749673c64a3b1a897c773665959dccfbc43a1f62afab4e9be117e29cfa7d0608ec3cf1a87b4b0d2da44b9c83cf8205d1cdbb WHIRLPOOL acd6948edd78ec17beb9f264985619c662d113b7d8f6c9c549b958d780e974019466eb5e1060705be5f1e75581c106a92bf95ad958357197f4fc0bc3db79f8b9
diff --git a/dev-util/pycharm-community/pycharm-community-5.0.2.ebuild b/dev-util/pycharm-community/pycharm-community-5.0.2.ebuild
new file mode 100644
index 000000000000..2d6231557096
--- /dev/null
+++ b/dev-util/pycharm-community/pycharm-community-5.0.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils readme.gentoo
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=""
+
+RESTRICT="mirror strip"
+QA_PREBUILT="/opt/${PN}/bin/fsnotifier
+ /opt/${PN}/bin/fsnotifier64"
+
+MY_PN=${PN/-community/}
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r *
+
+ fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+ dosym /opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+ newicon "bin/${MY_PN}.png" ${PN}.png
+ make_desktop_entry ${PN} "${PN}" "${PN}"
+
+ readme.gentoo_src_install
+}