summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2020-11-07 19:22:15 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-11-07 19:22:15 -0800
commitc881bd5d1112779307f4878d5209802b97d1726f (patch)
tree30ccece78a7207a01598ff58af7260e53f10572a
parentnet-firewall/nftables: Remove old (diff)
downloadgentoo-c881bd5d1112779307f4878d5209802b97d1726f.tar.gz
gentoo-c881bd5d1112779307f4878d5209802b97d1726f.tar.bz2
gentoo-c881bd5d1112779307f4878d5209802b97d1726f.zip
dev-python/libtmux-0.8.5: Version bump
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/libtmux/Manifest1
-rw-r--r--dev-python/libtmux/libtmux-0.8.5.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/libtmux/Manifest b/dev-python/libtmux/Manifest
index 16965cb128da..214dc945e343 100644
--- a/dev-python/libtmux/Manifest
+++ b/dev-python/libtmux/Manifest
@@ -1 +1,2 @@
DIST libtmux-v0.8.3.tar.gz 131928 BLAKE2B 7979dc907d5c7805cf56422aa0fed554c89f0b50cf1f13b150809a1c7e24b0eab125701eada0431212afccc26f6479642c886b3f701c8c2ffc9c3ebb7d08c4cc SHA512 f7c5a84f16b400db672318d3c0b79cd8f328a0096d32349f6ce9360d72eecd75ed9915af5c37950adadd81943130b543716d718366522efee7780813a2c1a5d6
+DIST libtmux-v0.8.5.tar.gz 222445 BLAKE2B 5af148555eb89c66bdc66f3f214967f7e901d9b86ea85e02a9fba64f2eb3559828519ba8120eaee5eb86ec75bee2e599a08384dd096de8dc0969129c58172c1e SHA512 d456725c3ca41a672ee5239bfb5f42a262674638d308fa141627995be8b8fe348bb8713b735eb05c5a3cc73f35fe3f6fac12024f6254c950a3048b2e07606363
diff --git a/dev-python/libtmux/libtmux-0.8.5.ebuild b/dev-python/libtmux/libtmux-0.8.5.ebuild
new file mode 100644
index 000000000000..10eaf095c176
--- /dev/null
+++ b/dev-python/libtmux/libtmux-0.8.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="python api for tmux"
+HOMEPAGE="https://libtmux.git-pull.com/"
+SRC_URI="https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz -> ${PN}-v${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND=">=app-misc/tmux-3.0a"
+BDEPEND="
+ test? (
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ local issues="https://github.com/tmux-python/libtmux/issues/"
+ sed -r -i "s|:issue:\`([[:digit:]]+)\`|\`issue \1 ${issues}\1\`|" CHANGES || die
+ rm requirements/doc.txt || die
+
+ distutils-r1_python_prepare_all
+}