summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-12-07 16:48:38 -0500
committerBrian Evans <grknight@gentoo.org>2016-12-07 16:49:37 -0500
commitcc773f6098a44577bd3ac197c6e78a2db85241e6 (patch)
tree2812314be0b22c65426cdacf99c6cc62c6dd000c
parentdev-php/suhosin: Drop old revision (diff)
downloadgentoo-cc773f6098a44577bd3ac197c6e78a2db85241e6.tar.gz
gentoo-cc773f6098a44577bd3ac197c6e78a2db85241e6.tar.bz2
gentoo-cc773f6098a44577bd3ac197c6e78a2db85241e6.zip
dev-php/xcache: Revbump to drop php 5.5 dependencies
This package has not been ported and fails with PHP 7.0. Patches are welcome, but this package is in danger of being dropped when PHP 5.6 becomes obsolete. Package-Manager: portage-2.3.2
-rw-r--r--dev-php/xcache/xcache-3.2.0-r2.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-php/xcache/xcache-3.2.0-r2.ebuild b/dev-php/xcache/xcache-3.2.0-r2.ebuild
new file mode 100644
index 000000000000..dff4e7a56685
--- /dev/null
+++ b/dev-php/xcache/xcache-3.2.0-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PHP_EXT_NAME="xcache"
+PHP_EXT_SAPIS="apache2 cgi fpm"
+USE_PHP="php5-6"
+
+inherit php-ext-source-r3
+
+DESCRIPTION="A fast and stable PHP opcode cacher"
+HOMEPAGE="http://xcache.lighttpd.net/"
+SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="coverage"
+
+# make test would just run php's test and as such need the full php source
+RESTRICT="test"
+
+DEPEND="
+ !dev-php/eaccelerator
+ !dev-php/pecl-apc
+ virtual/httpd-php:*
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-xcache=shared
+ --enable-xcache-constant \
+ --enable-xcache-optimizer \
+ $(use_enable coverage xcache-coverager) \
+ --enable-xcache-assembler \
+ --enable-xcache-encoder \
+ --enable-xcache-decoder )
+
+ php-ext-source-r3_src_configure
+}
+
+src_install() {
+ php-ext-source-r3_src_install
+
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins lib/Decompiler.class.php
+
+ # Install the admin interface somewhere where it can be
+ # copied/symlinked into a document root.
+ insinto "/usr/share/${PN}"
+ doins -r htdocs
+}
+
+pkg_postinst() {
+ elog "The lib/Decompiler.class.php file shipped with this release"
+ elog "was installed into ${PHP_EXT_SHARED_DIR}. The htdocs/ admin"
+ elog "interface directory can be found under ${EPREFIX}/usr/share/${PN}."
+}