summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-06-02 19:43:23 -0400
committerAaron Bauman <bman@gentoo.org>2018-06-02 22:58:19 -0400
commitd039804b084030b139e693f41d43f3a5bed25ee6 (patch)
treeb8ec6d40f5d70ca9886a50776881a4ba3584683c
parentsys-cluster/rgmanager: drop old EAPI (diff)
downloadgentoo-d039804b084030b139e693f41d43f3a5bed25ee6.tar.gz
gentoo-d039804b084030b139e693f41d43f3a5bed25ee6.tar.bz2
gentoo-d039804b084030b139e693f41d43f3a5bed25ee6.zip
sys-cluster/ipvsadm: drop old EAPI
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--sys-cluster/ipvsadm/Manifest2
-rw-r--r--sys-cluster/ipvsadm/ipvsadm-1.21-r1.ebuild51
-rw-r--r--sys-cluster/ipvsadm/ipvsadm-1.24.ebuild54
3 files changed, 0 insertions, 107 deletions
diff --git a/sys-cluster/ipvsadm/Manifest b/sys-cluster/ipvsadm/Manifest
index 39853536929..cc6ea43e31c 100644
--- a/sys-cluster/ipvsadm/Manifest
+++ b/sys-cluster/ipvsadm/Manifest
@@ -1,5 +1,3 @@
-DIST ipvsadm-1.21-11.tar.gz 34030 BLAKE2B d00313d9cb2ef5d683b7bfd51f49158b16f916da38ff3dcd6c11f26e62a1bbd910b5d9a83637c29b3cf522337a1b4092f39efc4a6efded7ab185a56202bf13a3 SHA512 55a50b4a06798b035481b4d8080ff8b64772802a564f91e7ff9fc7179ff8ed687681615a22b4c51b99065b574108b6a2c616e9acf54877dfd46c221e67f99048
-DIST ipvsadm-1.24.tar.gz 32007 BLAKE2B d133f73f4ec58b35dc3a6d88664bd89e9b1e10e9577429775b05e230519671a8ae82f331f3834fed3d967df4687d5cb4a45aa45bca3790467cdf3c65a22e3425 SHA512 f472e55d78901de3b8f07dec0ff6e32b5aa301dc0dc62f34fe168511c8e2af26704fb66936540eb1173d7a0280428a2e6e48f9efadd3e33050dd881e666e1041
DIST ipvsadm-1.26.tar.gz 41700 BLAKE2B ef8b089bd4d21297ae6fde01a9214cf07633cc286765e6f8110b04589c5d9b6dc4624457899c4ea48ddd08b495a9c090b26d1dc5094b5fb7cafcd5342c729caf SHA512 873e23a6bdaabc153b00f1ede3853c947e8c8cfb4e18364d55197c74f26cc883ca469e074a90f377fbfd5e73e0cd6c1fe414c9f7a5c28b0d4431af58056eced4
DIST ipvsadm-1.27.tar.xz 38196 BLAKE2B 1b8a72b11c14a909b8b7459c459195d32bb7944ed4a01d963e2b85e8279c5d7d2fd095d9c23473c64dc15881a2b22b439b39c10b2019b3183f54e22535a258a9 SHA512 cf982b7981674c91d1b7516de7b55cf378b306ce4a53e13976b8eeb8610015c4fa4aa9d251bc4d329db8e05c1862863160af2d3c63b76263f290087cffdf1b80
DIST ipvsadm-1.28.tar.xz 38600 BLAKE2B 2a892f858324788b425f7c5aa6ce6a1548c6cd166977d1d36a5236061d1a6ce7e31f6bc1e24a7d53a57406e468271ccebc01330de6be9784c1a955b60eb89d16 SHA512 a1e10ce30751d9439f832e221e5c41b338f87dcc94a0b21329d908a9164f8882049af9d9d918b764b36c30e353d5b8db49d7088e60c24e4748713c06cccf7035
diff --git a/sys-cluster/ipvsadm/ipvsadm-1.21-r1.ebuild b/sys-cluster/ipvsadm/ipvsadm-1.21-r1.ebuild
deleted file mode 100644
index ad66846c10f..00000000000
--- a/sys-cluster/ipvsadm/ipvsadm-1.21-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit linux-info
-
-PATCHLEVEL="11"
-MY_PV="${PV}-${PATCHLEVEL}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="utility to administer the IP virtual server services"
-HOMEPAGE="http://linuxvirtualserver.org"
-LICENSE="GPL-2"
-DEPEND=">=sys-libs/ncurses-5.2"
-
-SRC_URI="http://www.linuxvirtualserver.org/software/kernel-2.4/${MY_P}.tar.gz"
-
-SLOT="0"
-KEYWORDS="~ppc ~ppc64 x86"
-IUSE=""
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- if kernel_is -ge 2 6; then
- eerror "${P} does not support 2.6 kernels, please try newer versions"
- die "wrong kernel version"
- fi
-}
-
-src_compile() {
- emake || die "error compiling source"
-}
-
-src_install() {
- into /
- dosbin ipvsadm ipvsadm-save ipvsadm-restore || die
-
- doman ipvsadm.8 ipvsadm-save.8 ipvsadm-restore.8
-
- newinitd "${FILESDIR}"/ipvsadm-init ipvsadm || die
- keepdir /var/lib/ipvsadm
-
- dolib.a libipvs/libipvs.a || die
-
- insinto /usr/include/ipvs
- newins libipvs/libipvs.h ipvs.h || die
-
- einfo "You will need a kernel that has ipvs patches to use LVS"
-}
diff --git a/sys-cluster/ipvsadm/ipvsadm-1.24.ebuild b/sys-cluster/ipvsadm/ipvsadm-1.24.ebuild
deleted file mode 100644
index 8f263601620..00000000000
--- a/sys-cluster/ipvsadm/ipvsadm-1.24.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit linux-info toolchain-funcs
-
-DESCRIPTION="utility to administer the IP virtual server services offered by the Linux kernel"
-HOMEPAGE="http://linuxvirtualserver.org/"
-SRC_URI="http://www.linuxvirtualserver.org/software/kernel-2.5/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ia64 ~ppc64 s390 sparc x86"
-IUSE=""
-
-RDEPEND=">=sys-libs/ncurses-5.2"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- if kernel_is 2 4; then
- eerror "${P} supports only 2.6 kernels, please try ${PN}-1.21 for 2.4 kernels"
- die "wrong kernel version"
- fi
-}
-
-src_compile() {
- emake \
- -j1 \
- INCLUDE="-I${KV_DIR}/include -I.. -I." \
- CFLAGS="${CFLAGS}" \
- CC="$(tc-getCC)" \
- || die "error compiling source"
-}
-
-src_install() {
- into /
- dosbin ipvsadm ipvsadm-save ipvsadm-restore || die
-
- doman ipvsadm.8 ipvsadm-save.8 ipvsadm-restore.8 || die
-
- newinitd "${FILESDIR}"/ipvsadm-init ipvsadm
- keepdir /var/lib/ipvsadm
-
- dolib.a libipvs/libipvs.a || die
-
- insinto /usr/include/ipvs
- newins libipvs/libipvs.h ipvs.h || die
-}
-
-pkg_postinst() {
- einfo "You will need a kernel that has ipvs patches to use LVS."
- einfo "This version is specifically for 2.6 kernels."
-}