summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-08 07:59:27 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:46:51 +0100
commitd376ff98cff5b165d943e6d55a590592bd4ee078 (patch)
treeb78dc95aff8535a16689db8186c678a936a82306
parentsys-fs/traydevice: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-d376ff98cff5b165d943e6d55a590592bd4ee078.tar.gz
gentoo-d376ff98cff5b165d943e6d55a590592bd4ee078.tar.bz2
gentoo-d376ff98cff5b165d943e6d55a590592bd4ee078.zip
www-apps/trac: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--www-apps/trac/trac-1.0.9-r1.ebuild (renamed from www-apps/trac/trac-1.0.9.ebuild)40
-rw-r--r--www-apps/trac/trac-1.2.1-r1.ebuild (renamed from www-apps/trac/trac-1.2.1.ebuild)36
2 files changed, 40 insertions, 36 deletions
diff --git a/www-apps/trac/trac-1.0.9.ebuild b/www-apps/trac/trac-1.0.9-r1.ebuild
index 4925adedf91..92856efa6ec 100644
--- a/www-apps/trac/trac-1.0.9.ebuild
+++ b/www-apps/trac/trac-1.0.9-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -24,25 +24,27 @@ IUSE="cgi fastcgi i18n +highlight +restructuredtext mysql postgres +sqlite subve
REQUIRED_USE="|| ( mysql postgres sqlite )"
RDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/genshi[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- i18n? ( >=dev-python/Babel-0.9.5[${PYTHON_USEDEP}] )
- highlight? (
- || (
- dev-python/pygments[${PYTHON_USEDEP}]
- app-text/silvercity
- app-text/pytextile
- app-text/enscript
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_MULTI_USEDEP}]
+ dev-python/genshi[${PYTHON_MULTI_USEDEP}]
+ dev-python/pytz[${PYTHON_MULTI_USEDEP}]
+ i18n? ( >=dev-python/Babel-0.9.5[${PYTHON_MULTI_USEDEP}] )
+ highlight? (
+ || (
+ dev-python/pygments[${PYTHON_MULTI_USEDEP}]
+ app-text/silvercity
+ app-text/pytextile
+ app-text/enscript
+ )
)
- )
- restructuredtext? ( dev-python/docutils[${PYTHON_USEDEP}] )
- cgi? ( virtual/httpd-cgi )
- fastcgi? ( virtual/httpd-fastcgi )
- mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
- postgres? ( >=dev-python/psycopg-2[${PYTHON_USEDEP}] )
- sqlite? ( >=dev-db/sqlite-3.3.4:3 )
- subversion? ( dev-vcs/subversion[python,${PYTHON_USEDEP}] )
+ restructuredtext? ( dev-python/docutils[${PYTHON_MULTI_USEDEP}] )
+ cgi? ( virtual/httpd-cgi )
+ fastcgi? ( virtual/httpd-fastcgi )
+ mysql? ( dev-python/mysql-python[${PYTHON_MULTI_USEDEP}] )
+ postgres? ( >=dev-python/psycopg-2[${PYTHON_MULTI_USEDEP}] )
+ sqlite? ( >=dev-db/sqlite-3.3.4:3 )
+ subversion? ( dev-vcs/subversion[python,${PYTHON_MULTI_USEDEP}] )
+ ')
"
DEPEND="${RDEPEND}"
diff --git a/www-apps/trac/trac-1.2.1.ebuild b/www-apps/trac/trac-1.2.1-r1.ebuild
index 94523e6929b..d80396e3d00 100644
--- a/www-apps/trac/trac-1.2.1.ebuild
+++ b/www-apps/trac/trac-1.2.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -24,23 +24,25 @@ IUSE="cgi fastcgi i18n +highlight +restructuredtext mysql postgres +sqlite subve
REQUIRED_USE="|| ( mysql postgres sqlite )"
RDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/genshi[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- i18n? ( >=dev-python/Babel-0.9.5[${PYTHON_USEDEP}] )
- highlight? (
- || (
- dev-python/pygments[${PYTHON_USEDEP}]
- app-text/silvercity
- app-text/pytextile
- app-text/enscript
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_MULTI_USEDEP}]
+ dev-python/genshi[${PYTHON_MULTI_USEDEP}]
+ dev-python/pytz[${PYTHON_MULTI_USEDEP}]
+ i18n? ( >=dev-python/Babel-0.9.5[${PYTHON_MULTI_USEDEP}] )
+ highlight? (
+ || (
+ dev-python/pygments[${PYTHON_MULTI_USEDEP}]
+ app-text/silvercity
+ app-text/pytextile
+ app-text/enscript
+ )
)
- )
- restructuredtext? ( dev-python/docutils[${PYTHON_USEDEP}] )
- mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
- postgres? ( >=dev-python/psycopg-2[${PYTHON_USEDEP}] )
- sqlite? ( >=dev-db/sqlite-3.3.4:3 )
- subversion? ( dev-vcs/subversion[python,${PYTHON_USEDEP}] )
+ restructuredtext? ( dev-python/docutils[${PYTHON_MULTI_USEDEP}] )
+ mysql? ( dev-python/mysql-python[${PYTHON_MULTI_USEDEP}] )
+ postgres? ( >=dev-python/psycopg-2[${PYTHON_MULTI_USEDEP}] )
+ sqlite? ( >=dev-db/sqlite-3.3.4:3 )
+ subversion? ( dev-vcs/subversion[python,${PYTHON_MULTI_USEDEP}] )
+ ')
"
DEPEND="${RDEPEND}"