summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-07-02 19:05:02 +0200
committerPacho Ramos <pacho@gentoo.org>2016-07-02 19:11:35 +0200
commitd48d302bf0f41531885ed3764c4a6d7c951b61b1 (patch)
treeffdbf8e0106d149411cb3d83dc0c86440965a75c
parentnet-libs/glib-networking: Version bump (diff)
downloadgentoo-d48d302bf0f41531885ed3764c4a6d7c951b61b1.tar.gz
gentoo-d48d302bf0f41531885ed3764c4a6d7c951b61b1.tar.bz2
gentoo-d48d302bf0f41531885ed3764c4a6d7c951b61b1.zip
net-libs/gnome-online-accounts: Drop old
Package-Manager: portage-2.3.0_rc1
-rw-r--r--net-libs/gnome-online-accounts/Manifest2
-rw-r--r--net-libs/gnome-online-accounts/files/gnome-online-accounts-3.16.3-parallel-make.patch34
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.16.4.1.ebuild88
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.18.3.ebuild83
4 files changed, 0 insertions, 207 deletions
diff --git a/net-libs/gnome-online-accounts/Manifest b/net-libs/gnome-online-accounts/Manifest
index 1ec1e393d17..0ef0a0db34f 100644
--- a/net-libs/gnome-online-accounts/Manifest
+++ b/net-libs/gnome-online-accounts/Manifest
@@ -1,3 +1 @@
-DIST gnome-online-accounts-3.16.4.1.tar.xz 1440252 SHA256 68c688730a4a0be0a29e77106a78681fd0ea2c4e1aabafe4df7e20a22dbdb120 SHA512 3c563f422afc30994f7d3ac1102a3ace3b0c4ae645e76d4e40566a8aa01324f47737d978352a18e51e268ab3d707fc707ce7d5f0c8c281ebe3c9f86042a4f6b9 WHIRLPOOL 4697f67b55a7b85641efeed101afd384e4b19d9c920b871bdfcf0e6058b27850a771ba1da354b33ceab302ec87d4b6ce46a243637e401abc4e85dbcf3e449feb
-DIST gnome-online-accounts-3.18.3.tar.xz 1475580 SHA256 bfb983831af8b1fbd81b70befda7683a38f86ca4cc911f763ae31207306e3827 SHA512 8305ee3cafdf81c7b534d76d2f8b92dfc6bd7acfc27cb02f74f901b4513d2742815a377e523b7d767b1a2e26a2899312ed86bd00e1aedc9c7ecff924f4d91bde WHIRLPOOL 62aafdc8ebb33cc6f0353a378330bb1bdbdd364503fdc86f2b79065a1ec5c5c7634dd8268a275b1f10e20fa3a3b8db1d45f159457e3bd7e5b41071e441c28246
DIST gnome-online-accounts-3.18.4.tar.xz 1384756 SHA256 9f23460aa6b1d8a63a8f3e979cba791cc88b5e07116f07da59fdcea09d79c74d SHA512 1d78d8720d3547e782a9c9b1fee5ec794c8a0ec56d94f690adc1cce9d4f20da07b85a7c6e657b591153db667b3580d8900217e789144ac2e40eb963a7ac8d1a8 WHIRLPOOL 5459b9670c555a331c1c89583abd81836b8da2369355a97784fa370473341c49d5543d88870c49a8f47afd72a11feb27e3bfdb081b10fce8eb1a057eab279d02
diff --git a/net-libs/gnome-online-accounts/files/gnome-online-accounts-3.16.3-parallel-make.patch b/net-libs/gnome-online-accounts/files/gnome-online-accounts-3.16.3-parallel-make.patch
deleted file mode 100644
index 7d7cec31c05..00000000000
--- a/net-libs/gnome-online-accounts/files/gnome-online-accounts-3.16.3-parallel-make.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 8de9eb8f452ee7e6d780c29ebb946567d900c181 Mon Sep 17 00:00:00 2001
-From: Alexandre Rostovtsev <tetromino@gentoo.org>
-Date: Sat, 13 Jun 2015 12:41:15 -0400
-Subject: [PATCH] build: fix webextension parallel install failure
-
-libgoa-backend-1.0 must be installed before libgoawebextension; unpleasant
-automake syntax required.
-
-https://bugzilla.gnome.org/show_bug.cgi?id=750897
----
- src/goabackend/Makefile.am | 7 +++++++
- 1 file changed, 7 insertions(+)
-
-diff --git a/src/goabackend/Makefile.am b/src/goabackend/Makefile.am
-index 8c14774..06467ec 100644
---- a/src/goabackend/Makefile.am
-+++ b/src/goabackend/Makefile.am
-@@ -166,6 +166,13 @@ libgoawebextension_la_LDFLAGS = \
- -no-undefined \
- $(NULL)
-
-+# Force installation order: libgoa-backend-1.0 must be installed first, othwerwise
-+# libtool will incorrectly relink libgoawebextension.la under parallel make install.
-+# Requires ugly automake syntax - see http://debbugs.gnu.org/cgi/bugreport.cgi?bug=7328
-+
-+installwebextensionLTLIBRARIES = install-webextensionLTLIBRARIES
-+$(installwebextensionLTLIBRARIES): install-libLTLIBRARIES
-+
- # ----------------------------------------------------------------------------------------------------
-
- BUILT_SOURCES = \
---
-2.4.3
-
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.16.4.1.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.16.4.1.ebuild
deleted file mode 100644
index 875bb6acaba..00000000000
--- a/net-libs/gnome-online-accounts/gnome-online-accounts-3.16.4.1.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="yes"
-GNOME2_LA_PUNT="yes"
-
-inherit autotools eutils gnome2
-
-DESCRIPTION="GNOME framework for accessing online accounts"
-HOMEPAGE="https://wiki.gnome.org/Projects/GnomeOnlineAccounts"
-
-LICENSE="LGPL-2+"
-SLOT="0/1"
-IUSE="gnome +introspection kerberos" # telepathy"
-KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
-
-# pango used in goaeditablelabel
-# libsoup used in goaoauthprovider
-# goa kerberos provider is incompatible with app-crypt/heimdal, see
-# https://bugzilla.gnome.org/show_bug.cgi?id=692250
-# json-glib-0.16 needed for bug #485092
-RDEPEND="
- >=dev-libs/glib-2.35:2
- >=app-crypt/libsecret-0.5
- >=dev-libs/json-glib-0.16
- dev-libs/libxml2:2
- >=net-libs/libsoup-2.42:2.4
- net-libs/rest:0.7
- net-libs/telepathy-glib
- >=net-libs/webkit-gtk-2.7.2:4
- >=x11-libs/gtk+-3.11.1:3
- x11-libs/pango
-
- introspection? ( >=dev-libs/gobject-introspection-0.6.2:= )
- kerberos? (
- app-crypt/gcr:0=
- app-crypt/mit-krb5 )
-"
-# telepathy? ( net-libs/telepathy-glib )
-# goa-daemon can launch gnome-control-center
-PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2[gnome-online-accounts(+)] )"
-
-DEPEND="${RDEPEND}
- dev-libs/libxslt
- >=dev-util/gtk-doc-am-1.3
- >=dev-util/gdbus-codegen-2.30.0
- >=dev-util/intltool-0.50.1
- sys-devel/gettext
- virtual/pkgconfig
-
- dev-libs/gobject-introspection-common
- gnome-base/gnome-common
-"
-# eautoreconf needs gobject-introspection-common, gnome-common
-
-# Due to sub-configure
-QA_CONFIGURE_OPTIONS=".*"
-
-src_prepare() {
- # https://bugzilla.gnome.org/show_bug.cgi?id=750897
- epatch "${FILESDIR}"/${PN}-3.16.3-parallel-make.patch
- eautoreconf
- gnome2_src_prepare
-}
-
-src_configure() {
- # TODO: Give users a way to set the G/FB/Windows Live secrets
- # telepathy optional support is really badly done, bug #494456
- gnome2_src_configure \
- --disable-static \
- --enable-documentation \
- --enable-exchange \
- --enable-facebook \
- --enable-flickr \
- --enable-foursquare \
- --enable-imap-smtp \
- --enable-media-server \
- --enable-owncloud \
- --enable-pocket \
- --enable-telepathy \
- --enable-windows-live \
- $(use_enable kerberos)
- #$(use_enable telepathy)
- # gudev & cheese from sub-configure is overriden
- # by top level configure, and disabled so leave it like that
-}
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.18.3.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.18.3.ebuild
deleted file mode 100644
index 96e2dc18ce7..00000000000
--- a/net-libs/gnome-online-accounts/gnome-online-accounts-3.18.3.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="yes"
-GNOME2_LA_PUNT="yes"
-
-inherit gnome2
-
-DESCRIPTION="GNOME framework for accessing online accounts"
-HOMEPAGE="https://wiki.gnome.org/Projects/GnomeOnlineAccounts"
-
-LICENSE="LGPL-2+"
-SLOT="0/1"
-IUSE="gnome +introspection kerberos" # telepathy"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-
-# pango used in goaeditablelabel
-# libsoup used in goaoauthprovider
-# goa kerberos provider is incompatible with app-crypt/heimdal, see
-# https://bugzilla.gnome.org/show_bug.cgi?id=692250
-# json-glib-0.16 needed for bug #485092
-RDEPEND="
- >=dev-libs/glib-2.35:2
- >=app-crypt/libsecret-0.5
- >=dev-libs/json-glib-0.16
- dev-libs/libxml2:2
- >=net-libs/libsoup-2.42:2.4
- net-libs/rest:0.7
- net-libs/telepathy-glib
- >=net-libs/webkit-gtk-2.7.2:4
- >=x11-libs/gtk+-3.11.1:3
- x11-libs/pango
-
- introspection? ( >=dev-libs/gobject-introspection-0.6.2:= )
- kerberos? (
- app-crypt/gcr:0=
- app-crypt/mit-krb5 )
-"
-# telepathy? ( net-libs/telepathy-glib )
-# goa-daemon can launch gnome-control-center
-PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2[gnome-online-accounts(+)] )"
-
-DEPEND="${RDEPEND}
- dev-libs/libxslt
- >=dev-util/gtk-doc-am-1.3
- >=dev-util/gdbus-codegen-2.30.0
- >=dev-util/intltool-0.50.1
- sys-devel/gettext
- virtual/pkgconfig
-
- dev-libs/gobject-introspection-common
- gnome-base/gnome-common
-"
-# eautoreconf needs gobject-introspection-common, gnome-common
-
-# Due to sub-configure
-QA_CONFIGURE_OPTIONS=".*"
-
-src_configure() {
- # TODO: Give users a way to set the G/FB/Windows Live secrets
- # telepathy optional support is really a badly done, bug #494456
- gnome2_src_configure \
- --disable-static \
- --enable-backend \
- --enable-documentation \
- --enable-exchange \
- --enable-facebook \
- --enable-flickr \
- --enable-foursquare \
- --enable-imap-smtp \
- --enable-lastfm \
- --enable-media-server \
- --enable-owncloud \
- --enable-pocket \
- --enable-telepathy \
- --enable-windows-live \
- $(use_enable kerberos)
- #$(use_enable telepathy)
- # gudev & cheese from sub-configure is overriden
- # by top level configure, and disabled so leave it like that
-}