summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-01-05 16:22:03 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-01-05 16:34:46 -0500
commitd6d393bf2e8fa74b57c39cc4faad1be1bf359ca9 (patch)
treea4e31075ff7e0175e744815f41c65fd63c56cc2f
parentdev-php/symfony-dependency-injection: replace v2.1.0 with v2.8.15. (diff)
downloadgentoo-d6d393bf2e8fa74b57c39cc4faad1be1bf359ca9.tar.gz
gentoo-d6d393bf2e8fa74b57c39cc4faad1be1bf359ca9.tar.bz2
gentoo-d6d393bf2e8fa74b57c39cc4faad1be1bf359ca9.zip
dev-php/phpdepend: new version 2.3.2 sans bundled dependencies.
Now that we have a framework for installing Composer packages, we don't need to bundle the Symfony components that phpdepend uses. This new version switches back to a source distribution and adds the requisite RDEPENDs. In addition, we now install phpdepend under /usr/share/phpdepend as opposed to /usr/share/php/phpdepend. The latter is part of PHP's "include" search path, and is only meant for library code. Gentoo-Bug: 573340 Package-Manager: portage-2.3.0
-rw-r--r--dev-php/phpdepend/Manifest1
-rw-r--r--dev-php/phpdepend/files/autoload.php19
-rw-r--r--dev-php/phpdepend/phpdepend-2.3.2.ebuild50
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-php/phpdepend/Manifest b/dev-php/phpdepend/Manifest
index 34dba0518075..05b0378a2232 100644
--- a/dev-php/phpdepend/Manifest
+++ b/dev-php/phpdepend/Manifest
@@ -1,2 +1,3 @@
DIST PHP_Depend-1.1.1.tgz 181421 SHA256 64a03e82f6b38b4bd0187a27c2cc2bf47c76790b0f4e806dcdeab36ccc6e40f9 SHA512 688e8d0000a14fcc5eb4469d02177c6894f9172d2ae3813712c0af745f75327b6434a1a770d1c299bfce7c380fe5aeb3b9f9de26f4bf984d733437142bf7621b WHIRLPOOL f492e67b6e77985face1b50814dcbe4744d08cd83b8abfac8bc36254f4b67a866a53d3e15a9020a4a2ded7d5c12bbf36b949b2590aa778c8f5bd4ee7371679b6
DIST phpdepend-2.2.2.phar 677194 SHA256 fdf8439b1485a6e8f02817e31621b5f929aad43dac9a672d076b054ecd354e4c SHA512 47519aa9f60b2dd393794fc6588f10f247b035367d514234d1e84bb564ff4ebd148dd299342722e4629847b0c0b625ba61a30bbe374215e4731a6d8187374ccc WHIRLPOOL df88d89480577ee662a553884642fbbebe00ae6764c2754ded10e237a54bd1da1d9199874158d0c7bf2e46bd98296596fb5cda4bd96407a40f04c25439a5a4b8
+DIST phpdepend-2.3.2.tar.gz 187985 SHA256 6edbb892ece8a9e811d9bee071442ca9b393ac3a4110b3d1db45e0c9c0b03887 SHA512 00c9af24f9e17f1935d2d0315b4204d47d4a6d1ebcf4e22e9860ff4eb9292e25da7171f2a95b2ba545872b55042f3ac6c495105f67635fdd1386e96494f8ccdd WHIRLPOOL 42bd82efca09fd672c6c087a8067f02f9b8d6717df2023ab38499f8833a81a93833940e466707f985cdd938c6d86075ad526af02e4fe53582c23b3e392b64ca1
diff --git a/dev-php/phpdepend/files/autoload.php b/dev-php/phpdepend/files/autoload.php
new file mode 100644
index 000000000000..ce186c4f3d86
--- /dev/null
+++ b/dev-php/phpdepend/files/autoload.php
@@ -0,0 +1,19 @@
+<?php
+$vendor_dir = '/usr/share/php';
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once("${vendor_dir}/Fedora/Autoloader/autoload.php");
+}
+
+\Fedora\Autoloader\Autoload::addPsr4(
+ 'PDepend\\',
+ __DIR__ . '/../src/main/php/PDepend'
+);
+
+
+\Fedora\Autoloader\Dependencies::required(
+ array(
+ "${vendor_dir}/Symfony/Component/Config/autoload.php",
+ "${vendor_dir}/Symfony/Component/DependencyInjection/autoload.php",
+ "${vendor_dir}/Symfony/Component/Filesystem/autoload.php"
+ )
+);
diff --git a/dev-php/phpdepend/phpdepend-2.3.2.ebuild b/dev-php/phpdepend/phpdepend-2.3.2.ebuild
new file mode 100644
index 000000000000..8d893a7c583c
--- /dev/null
+++ b/dev-php/phpdepend/phpdepend-2.3.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN=pdepend
+
+DESCRIPTION="Static code analysis for PHP"
+HOMEPAGE="http://www.pdepend.org/"
+
+# The test suite is absent from the release tarballs because
+# the only build system that Composer understands is "cp -r".
+# To obtain the tests, we would need to grab a VCS snapshot.
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Warning: the "range" dependencies below only work so long
+# as the libraries they refer to are not slotted.
+RDEPEND="dev-lang/php
+ dev-php/fedora-autoloader
+ ( >=dev-php/symfony-config-2.3.0 <dev-php/symfony-config-3 )
+ ( >=dev-php/symfony-dependency-injection-2.3.0
+ <dev-php/symfony-dependency-injection-3 )
+ <dev-php/symfony-filesystem-3"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+ dodoc CHANGELOG
+
+ # The executable will only look for autoload.php in one place, so we
+ # create an (otherwise pointless) vendor directory to house it.
+ insinto "/usr/share/${PN}/vendor"
+ doins "${FILESDIR}/autoload.php"
+
+ insinto "/usr/share/${PN}/src"
+ doins -r src/main
+
+ # The executable uses relative include paths, so the one users will
+ # actually run needs to be symlinked into the source tree.
+ exeinto "/usr/share/${PN}/src/bin"
+ doexe "src/bin/${MY_PN}"
+ dosym "/usr/share/${PN}/src/bin/${MY_PN}" "/usr/bin/${MY_PN}"
+}