summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2017-11-21 14:31:11 -0500
committerIan Stakenvicius <axs@gentoo.org>2017-11-21 14:31:50 -0500
commitd6f144825d2c355ac84e6d24631d170a8502f064 (patch)
treee0ef3887df3f848fabf70b548abdff57ed3db3aa
parentnet-fs/samba: upstream version bumps (diff)
downloadgentoo-d6f144825d2c355ac84e6d24631d170a8502f064.tar.gz
gentoo-d6f144825d2c355ac84e6d24631d170a8502f064.tar.bz2
gentoo-d6f144825d2c355ac84e6d24631d170a8502f064.zip
sys-cluster/torque-6.0.3: fix an empty-string comparison error
Bug: http://bugs.gentoo.org/638346 Package-Manager: Portage-2.3.13, Repoman-2.3.3
-rw-r--r--sys-cluster/torque/files/torque-6.0.3-fix-emptystring-comparison.patch21
-rw-r--r--sys-cluster/torque/torque-6.0.3.ebuild1
2 files changed, 22 insertions, 0 deletions
diff --git a/sys-cluster/torque/files/torque-6.0.3-fix-emptystring-comparison.patch b/sys-cluster/torque/files/torque-6.0.3-fix-emptystring-comparison.patch
new file mode 100644
index 000000000000..0666eda15937
--- /dev/null
+++ b/sys-cluster/torque/files/torque-6.0.3-fix-emptystring-comparison.patch
@@ -0,0 +1,21 @@
+--- a/src/lib/Libattr/req.cpp 2017-01-24 18:35:27.000000000 -0500
++++ b/src/lib/Libattr/req.cpp 2017-11-21 13:40:27.201964749 -0500
+@@ -1037,17 +1037,17 @@
+ error = "Bad tasks value: '";
+ error += submission_str;
+ error += "'";
+ return(PBSE_BAD_PARAMETER);
+ }
+
+ if (*current == ':')
+ current++;
+- else if (current != '\0')
++ else if (*current != '\0')
+ {
+ error = "Invalid task specification";
+ return(PBSE_BAD_PARAMETER);
+ }
+
+ while ((current != NULL) &&
+ (*current != '\0'))
+ {
diff --git a/sys-cluster/torque/torque-6.0.3.ebuild b/sys-cluster/torque/torque-6.0.3.ebuild
index 74409b48eef8..ec9563e95bfa 100644
--- a/sys-cluster/torque/torque-6.0.3.ebuild
+++ b/sys-cluster/torque/torque-6.0.3.ebuild
@@ -81,6 +81,7 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-emptystring-comparison.patch
# We install to a valid location, no need to muck with ld.so.conf
# --without-loadlibfile is supposed to do this for us...
sed -i '/mk_default_ld_lib_file || return 1/d' buildutils/pbs_mkdirs.in || die