summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlec Ten Harmsel <alec@alectenharmsel.com>2019-04-24 14:30:21 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2019-05-21 09:52:26 -0400
commitd7c7ccd0f43b62f064d6d0bb57186db7cf6ddd18 (patch)
treea9cca07ce463ef07ec41a078fb45a9a59047bc93
parentnet-misc/memcached: 1.5.15 bump (diff)
downloadgentoo-d7c7ccd0f43b62f064d6d0bb57186db7cf6ddd18.tar.gz
gentoo-d7c7ccd0f43b62f064d6d0bb57186db7cf6ddd18.tar.bz2
gentoo-d7c7ccd0f43b62f064d6d0bb57186db7cf6ddd18.zip
app-office/gnucash: Append -Wno-error for 3.3+
GCC 8.3.0 issues some warnings for Gnucash 3.3+, causing build failures. Package-Manager: Portage-2.3.62, Repoman-2.3.11 Signed-off-by: Alec Ten Harmsel <alec@alectenharmsel.com> Closes: https://bugs.gentoo.org/684286 Closes: https://github.com/gentoo/gentoo/pull/11817 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
-rw-r--r--app-office/gnucash/gnucash-3.3-r1.ebuild4
-rw-r--r--app-office/gnucash/gnucash-3.3.ebuild4
-rw-r--r--app-office/gnucash/gnucash-3.4.ebuild4
-rw-r--r--app-office/gnucash/gnucash-3.5.ebuild2
4 files changed, 10 insertions, 4 deletions
diff --git a/app-office/gnucash/gnucash-3.3-r1.ebuild b/app-office/gnucash/gnucash-3.3-r1.ebuild
index 982eb4a96333..89dcc50498b5 100644
--- a/app-office/gnucash/gnucash-3.3-r1.ebuild
+++ b/app-office/gnucash/gnucash-3.3-r1.ebuild
@@ -7,7 +7,7 @@ EAPI=6
GV="1.8.0"
PYTHON_COMPAT=( python3_{5,6} )
-inherit cmake-utils gnome2-utils python-single-r1 xdg-utils
+inherit cmake-utils flag-o-matic gnome2-utils python-single-r1 xdg-utils
DESCRIPTION="A personal finance manager"
HOMEPAGE="http://www.gnucash.org/"
@@ -109,6 +109,8 @@ src_configure() {
-DWITH_GNUCASH=$(usex gui)
)
+ append-cflags -Wno-error
+ append-cxxflags -Wno-error
cmake-utils_src_configure
}
diff --git a/app-office/gnucash/gnucash-3.3.ebuild b/app-office/gnucash/gnucash-3.3.ebuild
index cdbe0c78c640..6d5c46b0c02e 100644
--- a/app-office/gnucash/gnucash-3.3.ebuild
+++ b/app-office/gnucash/gnucash-3.3.ebuild
@@ -7,7 +7,7 @@ EAPI=6
GV="1.8.0"
PYTHON_COMPAT=( python3_{5,6} )
-inherit cmake-utils gnome2-utils python-single-r1 xdg-utils
+inherit cmake-utils flag-o-matic gnome2-utils python-single-r1 xdg-utils
DESCRIPTION="A personal finance manager"
HOMEPAGE="http://www.gnucash.org/"
@@ -107,6 +107,8 @@ src_configure() {
-DWITH_GNUCASH=$(usex gui)
)
+ append-cflags -Wno-error
+ append-cxxflags -Wno-error
cmake-utils_src_configure
}
diff --git a/app-office/gnucash/gnucash-3.4.ebuild b/app-office/gnucash/gnucash-3.4.ebuild
index 85fac5c295af..b7de02ad0aa0 100644
--- a/app-office/gnucash/gnucash-3.4.ebuild
+++ b/app-office/gnucash/gnucash-3.4.ebuild
@@ -7,7 +7,7 @@ EAPI=6
GV="1.8.0"
PYTHON_COMPAT=( python3_{5,6} )
-inherit cmake-utils gnome2-utils python-single-r1 xdg-utils
+inherit cmake-utils flag-o-matic gnome2-utils python-single-r1 xdg-utils
DESCRIPTION="A personal finance manager"
HOMEPAGE="http://www.gnucash.org/"
@@ -120,6 +120,8 @@ src_configure() {
-DWITH_GNUCASH=$(usex gui)
)
+ append-cflags -Wno-error
+ append-cxxflags -Wno-error
cmake-utils_src_configure
}
diff --git a/app-office/gnucash/gnucash-3.5.ebuild b/app-office/gnucash/gnucash-3.5.ebuild
index ca794fbd46ee..e7521d2945db 100644
--- a/app-office/gnucash/gnucash-3.5.ebuild
+++ b/app-office/gnucash/gnucash-3.5.ebuild
@@ -7,7 +7,7 @@ EAPI=6
GV="1.8.0"
PYTHON_COMPAT=( python3_{5,6} )
-inherit cmake-utils gnome2-utils python-single-r1 xdg-utils
+inherit cmake-utils flag-o-matic gnome2-utils python-single-r1 xdg-utils
DESCRIPTION="A personal finance manager"
HOMEPAGE="http://www.gnucash.org/"