summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-06-13 17:45:27 +0200
committerPacho Ramos <pacho@gentoo.org>2020-06-13 17:45:27 +0200
commitd880bd35a65a8aae3571c155a91ecf368c45b64e (patch)
tree922b1544edc2f680076e6c537ac34e0374e7d2b4
parentsys-apps/accountsservice: Bump to 0.6.55 (diff)
downloadgentoo-d880bd35a65a8aae3571c155a91ecf368c45b64e.tar.gz
gentoo-d880bd35a65a8aae3571c155a91ecf368c45b64e.tar.bz2
gentoo-d880bd35a65a8aae3571c155a91ecf368c45b64e.zip
sci-chemistry/chemex: Bump to 2018.10.3
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--sci-chemistry/chemex/Manifest1
-rw-r--r--sci-chemistry/chemex/chemex-2018.10.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sci-chemistry/chemex/Manifest b/sci-chemistry/chemex/Manifest
index 21f984a5160f..af7880bd0fdc 100644
--- a/sci-chemistry/chemex/Manifest
+++ b/sci-chemistry/chemex/Manifest
@@ -1,2 +1,3 @@
DIST chemex-0.6.1.tar.gz 1449216 BLAKE2B 6b7f7597b09cd43b9bec89b6359d1f650fdd7d4f3a373e706da80dafaf438417458f34af6bc378442b5b4a84cb8222103ebc8026c85583e8dece3fad0dc77204 SHA512 40f538ef9c162759c7a6863886da8d46746ac362fc19154f0a5f3dd8703f7fea7397c3f34092c86dbce486c452e0d3b09a76e4c11ae119834d7ca4912e7f3fdf
DIST chemex-2018.10.2.tar.gz 546575 BLAKE2B c36ae3bc152459844633276ab286b6f750ed5b2538c4289ceb75de9a081ad74fe346a79357fd6fc2f8972722b3520473262c4d623e46d6a4b30395962164a51f SHA512 f8ed017c0881ea9188e150456827e2c6302bdfe546c8058bd0261e43d941fbd1ac9e6abf1621d82107a4f6bd4e9aa4bc70c46e42dc98eabf2dba45a4fa78f77e
+DIST chemex-2018.10.3.tar.gz 546696 BLAKE2B d283cfb94118686f1974780249641e0ea6f86cdb854c4a256897e361a300a94506813a5035ee2f300fca13263e8452b77e7a0817436cbd620ba16d801a541af7 SHA512 784bd03b354724d6aa52d663c6f661f865d4ef7ca345573bc8aae9ef63e5dbb3e65abba364de3ff441b78adfa588344c718809c5880b3fc70d8ed24be06a0826
diff --git a/sci-chemistry/chemex/chemex-2018.10.3.ebuild b/sci-chemistry/chemex/chemex-2018.10.3.ebuild
new file mode 100644
index 000000000000..d0634c88451f
--- /dev/null
+++ b/sci-chemistry/chemex/chemex-2018.10.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DISTUTILS_SINGLE_IMPL="yes"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Program to fit chemical exchange induced shift and relaxation data"
+HOMEPAGE="https://github.com/gbouvignies/chemex"
+SRC_URI="https://github.com/gbouvignies/chemex/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/asteval-0.9.11[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/lmfit-0.9.11[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/matplotlib-1.1[${PYTHON_MULTI_USEDEP}]
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_MULTI_USEDEP}]
+ >=sci-libs/scipy-0.11[${PYTHON_MULTI_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/ChemEx-${PV}"
+
+src_prepare() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ py.test -v -v || die
+}