summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2016-01-24 21:25:22 +0100
committerJauhien Piatlicki <jauhien@gentoo.org>2016-01-24 23:25:44 +0100
commitdcd9fb34cf2edc8a25ca4a6b49d3fead14b9b8b0 (patch)
tree32d0e9eb7c0920983b870a78ea63e0f741797746
parentapp-admin/consul-replicate: add consul to SRC_URI (diff)
parentnet-p2p/qbittorrent: version bump & new 9999 ebuild (diff)
downloadgentoo-dcd9fb34cf2edc8a25ca4a6b49d3fead14b9b8b0.tar.gz
gentoo-dcd9fb34cf2edc8a25ca4a6b49d3fead14b9b8b0.tar.bz2
gentoo-dcd9fb34cf2edc8a25ca4a6b49d3fead14b9b8b0.zip
Merge remote-tracking branch 'RobinDX/qbit'
net-p2p/qbittorrent: version bump & new 9999 ebuild Also add python3 support
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/qbittorrent-3.3.3.ebuild86
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild15
3 files changed, 96 insertions, 6 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index 6c0c5e0e8861..2cfa9cb10a31 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -5,3 +5,4 @@ DIST qbittorrent-3.2.3.tar.xz 2638708 SHA256 86a79f3772bd06736a4be104180187d76c5
DIST qbittorrent-3.2.4.tar.xz 2664248 SHA256 7fc128e2809c3be4ea543cfaeefd922e0327cc430330eaad0d3ec7616df51871 SHA512 c86098d791b64bd5f0ef6b465cf3eb6f1016402b33b18ba927279f521d768aa973d3f233794adb63820c5bca7e67672bf3c64fe65a7e5bf513219f860d2b2141 WHIRLPOOL c5690fdf01a8841978404e61369a16da13dd27c151618cadbb4e16add7d5377d980d9a94cea68f82005c88bd4b637a23f0ea6fb2615c3921302c5847e0763272
DIST qbittorrent-3.2.5.tar.xz 2665980 SHA256 98f69c7324276c7c144738eb36b21a2d28d7f01a327104568f020887626e822b SHA512 a98c1cf8607558990d0698c50d35cd217bceeb4deffe69c590f902b1a9dabc5431496805614dbd3bb734f764c309023ede2f8a5cb014f40796301fa14ba63e90 WHIRLPOOL 6539bde802919351836d1bb2d880d5b28d51c97b109674f2ae3e54c9aa9ab52c5e58436371a34b7388d119d041cf9b2a597656e338808243309cbf631e03fe2b
DIST qbittorrent-3.3.2.tar.xz 2782172 SHA256 e9330a63e0939fef79c70d5a66dba616f00206a70386efbb82fb7c620a19af58 SHA512 2c09c1bbf18dfc181998343845e0f8164c29cb97eeccf3a7ab25753e8ccaa11cfb7372cf0ff1fc2a8c232a9ab4381a23c88aef791e37a3a7b4c0b92b537e25e6 WHIRLPOOL a2bf3f6aee46dc5bc58357ea8eb214b9a69116f470faa0a4b5aed9fc0ffdd340712a1424b128ab96273e75d6b1c83707765d01c0089ec550040bb63df236176e
+DIST qbittorrent-3.3.3.tar.xz 2782616 SHA256 9c8d8bdc3fb2632019cb3ee5f811baaa41b41fe7ce542c753c6771bcc110db53 SHA512 2dd954e2518a2a99e271bf62d6db38a4e1788bb91c8b7552b94aab25dfb7b6cc7b4eb0ae49bb50d524127e8a357ea07b022c3a6e3b0593f6d2e7a2ce3abf6260 WHIRLPOOL e794a50215f33c2088b4782fd8733e11c33b42a45b5df2424bdf0fcee3c0929445f0d47b1e8b3526341f4ee9a4b8cd081da54a0c3019f79dea9b50a3bb5dcbad
diff --git a/net-p2p/qbittorrent/qbittorrent-3.3.3.ebuild b/net-p2p/qbittorrent/qbittorrent-3.3.3.ebuild
new file mode 100644
index 000000000000..10b4254df36b
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-3.3.3.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+inherit eutils python-r1 qt4-r2
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+
+MY_P=${P/_}
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+else
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus debug qt4 qt5 webui +X"
+REQUIRED_USE="
+ ^^ ( qt4 qt5 )
+ dbus? ( X )
+"
+
+CDEPEND="
+ dev-libs/boost:=
+ >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt4?,qt5?,X?]
+ >=net-libs/rb_libtorrent-1.0.6
+ sys-libs/zlib
+ qt4? (
+ dev-qt/qtcore:4
+ dbus? ( dev-qt/qtdbus:4 )
+ X? ( dev-qt/qtgui:4 )
+ )
+ qt5? (
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtxml:5
+ dbus? ( dev-qt/qtdbus:5 )
+ X? ( dev-qt/qtgui:5
+ dev-qt/qtwidgets:5 )
+ )
+"
+DEPEND="${CDEPEND}
+ qt5? ( dev-qt/linguist-tools:5 )
+ virtual/pkgconfig
+"
+RDEPEND="${CDEPEND}
+ ${PYTHON_DEPS}"
+
+S=${WORKDIR}/${MY_P}
+DOCS=(AUTHORS Changelog README.md TODO)
+
+src_prepare() {
+ epatch_user
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ # Custom configure script, econf fails
+ local myconf=(
+ ./configure
+ --prefix="${EPREFIX}/usr"
+ --with-qtsingleapplication=system
+ $(use dbus || echo --disable-qt-dbus)
+ $(use debug && echo --enable-debug)
+ $(use qt4 && echo --with-qt4)
+ $(use webui || echo --disable-webui)
+ $(use X || echo --disable-gui)
+ )
+
+ "${myconf[@]}" || die "configure failed"
+
+ if use qt4 ;then
+ eqmake4
+ elif use qt5 ;then
+ eqmake5
+ fi
+}
+
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index b67c5a0b6b4c..0804614e8685 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -3,8 +3,8 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
inherit eutils python-r1 qt4-r2
DESCRIPTION="BitTorrent client in C++ and Qt"
@@ -21,7 +21,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+dbus debug +qt4 qt5 webui +X"
+IUSE="+dbus debug qt4 qt5 webui +X"
REQUIRED_USE="
^^ ( qt4 qt5 )
dbus? ( X )
@@ -70,13 +70,16 @@ src_configure() {
--with-qtsingleapplication=system
$(use dbus || echo --disable-qt-dbus)
$(use debug && echo --enable-debug)
- $(use qt5 && echo --with-qt5)
+ $(use qt4 && echo --with-qt4)
$(use webui || echo --disable-webui)
$(use X || echo --disable-gui)
)
- echo "${myconf[@]}"
"${myconf[@]}" || die "configure failed"
- use qt4 && eqmake4
- use qt5 && eqmake5
+
+ if use qt4 ;then
+ eqmake4
+ elif use qt5 ;then
+ eqmake5
+ fi
}