summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2017-12-12 09:25:38 +0500
committerPatrice Clement <monsieurp@gentoo.org>2017-12-12 21:22:23 +0100
commitddef2e2c59110a1f09eee125e4c5088436bc1622 (patch)
tree9d0bac633b52125ace62c3ec590a646efa8c6b5d
parentwww-client/firefox: x86 stable (bug #639854) (diff)
downloadgentoo-ddef2e2c59110a1f09eee125e4c5088436bc1622.tar.gz
gentoo-ddef2e2c59110a1f09eee125e4c5088436bc1622.tar.bz2
gentoo-ddef2e2c59110a1f09eee125e4c5088436bc1622.zip
dev-python/construct: version bump to 2.8.17.
Package-Manager: Portage-2.3.13, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/6527
-rw-r--r--dev-python/construct/Manifest1
-rw-r--r--dev-python/construct/construct-2.8.17.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/construct/Manifest b/dev-python/construct/Manifest
index eb294e20faed..783fb929146d 100644
--- a/dev-python/construct/Manifest
+++ b/dev-python/construct/Manifest
@@ -1,2 +1,3 @@
DIST construct-2.8.14.tar.gz 719633 BLAKE2B cba727069463277cb6340571745d9dc896eb4b47090e66000233bf61b9d47ccb07300c0c9a38d0fc6bda14d810d3b68cc6bf67d8032fc33015496ba37f370c31 SHA512 ada1853ff9559f19dbb153ef4b60a6daf58dadaf0524fcb35c4a38e8c0a476acfbeec2f4d02ebfa1858c9d2660ffc8695d7ff8055a23e8dc40aca8290c53ac69
DIST construct-2.8.16.tar.gz 719786 BLAKE2B 44d90014136612080f4a97fa32845b7610bb2378ecf0ba81b105e265874c3d05c18a70f98a6cba1eaec69b5b68887b0611b7aadd4188c196c99fd15c2b0ca294 SHA512 6128da944b323b58f79a9b386fd9dba65fdcc31ce8da2b6cafebfe2f126031dd77ffcfe4885020b6122304acf0b0f87792ddf79669517b21ac1f49952c2c46ee
+DIST construct-2.8.17.tar.gz 705812 BLAKE2B 3178f7f59fb893bc521c88b7ba51d6bd83cca37c1a243e602dcc2ac41a2cb7335e2cf69e7dff3b130e974ff9dbd01a12004423c3a88fc8e88c784c665437e901 SHA512 5bca40d7f33f336ab2a66546027c8bf24bf1b0125bcf425063b3bab14b1e3a96577d602db1eb73cb0ee99f90d92af6e24fcbd228912c0a70de6b2bd7d33e75be
diff --git a/dev-python/construct/construct-2.8.17.ebuild b/dev-python/construct/construct-2.8.17.ebuild
new file mode 100644
index 000000000000..84474d2334ba
--- /dev/null
+++ b/dev-python/construct/construct-2.8.17.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A powerful declarative parser for binary data"
+HOMEPAGE="http://construct.readthedocs.io/ https://pypi.python.org/pypi/construct"
+SRC_URI="https://github.com/construct/construct/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -vv || die "Tests failed under ${EPYTHON}"
+}