summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2019-12-10 10:56:35 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-10 10:56:50 -0800
commite07bbe5cf2db48528fae860865a2f697d7d49aa3 (patch)
tree81ea406081e4e61755e703ab426699e03e023966
parentprofiles/package.mask: last-rite media-gfx/tic98 (diff)
downloadgentoo-e07bbe5cf2db48528fae860865a2f697d7d49aa3.tar.gz
gentoo-e07bbe5cf2db48528fae860865a2f697d7d49aa3.tar.bz2
gentoo-e07bbe5cf2db48528fae860865a2f697d7d49aa3.zip
net-firewall/arptables-0.0.5: Version bump
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--net-firewall/arptables/Manifest1
-rw-r--r--net-firewall/arptables/arptables-0.0.5.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/net-firewall/arptables/Manifest b/net-firewall/arptables/Manifest
index b23638061848..32ec8d117646 100644
--- a/net-firewall/arptables/Manifest
+++ b/net-firewall/arptables/Manifest
@@ -1 +1,2 @@
+DIST arptables-0.0.5.tar.gz 52247 BLAKE2B 860aac1af315f188ecb7f17956f9225c2a9ec007882d102be8edc9fecc9400928f4200e95283f0ecc27c4c3ae0b409887445ed79a330cef2e2d00444db83c01f SHA512 fe7f909b45a1bdc435a8307352fe2dc9c292bb7c6cf4a4d13cc2728f447b3da14a07a4dd6dc25b7872895e4e26561681f1fed25ce517102ae762701bcbcbf104
DIST arptables-v0.0.4.tar.gz 45380 BLAKE2B a256aa280aa65fae8c5b17477fedb3fed4973e8d76746d5832184858b77111eb22bec63211a1ddfb74d25bdc23b0f237caf5ac7effa85433d0f63c51e23a3ef1 SHA512 bd84e93ab5e0a038753aa17dae9e1f48364f2d2b1492dce2edac117e21edd5aa912be7b9e21bf4fb3698031d2f765a75fa067fe10ce20a1c8951ae7efcc5dbbd
diff --git a/net-firewall/arptables/arptables-0.0.5.ebuild b/net-firewall/arptables/arptables-0.0.5.ebuild
new file mode 100644
index 000000000000..8484f81cf19b
--- /dev/null
+++ b/net-firewall/arptables/arptables-0.0.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="set up, maintain, and inspect the tables of ARP rules in the Linux kernel"
+HOMEPAGE="http://ebtables.sourceforge.net/"
+SRC_URI="ftp://ftp.netfilter.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_compile() {
+ # -O0 does not work and at least -O2 is required, bug #240752
+ emake CC="$(tc-getCC)" COPT_FLAGS="-O2 ${CFLAGS//-O0/-O2}"
+ sed -e 's:__EXEC_PATH__:/sbin:g' \
+ -i arptables-save arptables-restore || die "sed failed"
+}
+
+src_install() {
+ emake \
+ PREFIX="${ED}"/ \
+ LIBDIR="${ED}/$(get_libdir)" \
+ SYSCONFIGDIR="${ED}"/etc \
+ MANDIR="${ED}"/usr/share/man \
+ install
+
+ dosym arptables-legacy /sbin/arptables
+ newman arptables-legacy.8 arptables.8
+}