summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-02-11 23:27:50 +0100
committerJohannes Huber <johu@gentoo.org>2017-02-11 23:29:06 +0100
commite120f7ba188750bef64363d813e426c0e92d0a4c (patch)
tree8c231e25f60d07907c2d6f19ba1e6ad6cba689ce
parentmedia-libs/vigra: Remove old (diff)
downloadgentoo-e120f7ba188750bef64363d813e426c0e92d0a4c.tar.gz
gentoo-e120f7ba188750bef64363d813e426c0e92d0a4c.tar.bz2
gentoo-e120f7ba188750bef64363d813e426c0e92d0a4c.zip
net-fs/smbtad: EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--net-fs/smbtad/smbtad-1.2.6.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/net-fs/smbtad/smbtad-1.2.6.ebuild b/net-fs/smbtad/smbtad-1.2.6.ebuild
index b664b8b50281..f013ad811321 100644
--- a/net-fs/smbtad/smbtad-1.2.6.ebuild
+++ b/net-fs/smbtad/smbtad-1.2.6.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
inherit cmake-utils
@@ -27,9 +27,11 @@ RDEPEND="${DEPEND}
)
"
-DOCS="README AUTHORS"
+DOCS=( README AUTHORS )
src_prepare() {
+ cmake-utils_src_prepare
+
sed -i \
-e '/CMAKE_C_FLAGS/d' \
CMakeLists.txt || die
@@ -37,7 +39,7 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
- $(cmake-utils_use debug)
+ -DDebug=$(usex debug)
)
cmake-utils_src_configure