summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-09 14:41:07 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-09 14:56:38 +0100
commite1990c1ca74c3ea1b44d76c59326e9ec8fbec6d8 (patch)
tree7a98132f1c2321eb8fb8b4039de4fb4864fa7753
parentsys-devel/binutils-hppa64: add RESTRICT="!test? ( test )" (diff)
downloadgentoo-e1990c1ca74c3ea1b44d76c59326e9ec8fbec6d8.tar.gz
gentoo-e1990c1ca74c3ea1b44d76c59326e9ec8fbec6d8.tar.bz2
gentoo-e1990c1ca74c3ea1b44d76c59326e9ec8fbec6d8.zip
net-nds/led: Bump to EAPI 7
Closes: https://bugs.gentoo.org/697234 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--net-nds/led/led-1.111.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/net-nds/led/led-1.111.ebuild b/net-nds/led/led-1.111.ebuild
index dbd214b97ef8..441a72ed409c 100644
--- a/net-nds/led/led-1.111.ebuild
+++ b/net-nds/led/led-1.111.ebuild
@@ -1,26 +1,30 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils
-DESCRIPTION="led is a general purpose LDAP editor"
+DESCRIPTION="A general purpose LDAP editor"
HOMEPAGE="http://led.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-DEPEND=">=dev-lang/perl-5.6.1
+RDEPEND=">=dev-lang/perl-5.6.1
dev-perl/perl-ldap
dev-perl/URI
virtual/perl-Digest-MD5
dev-perl/Authen-SASL"
+DEPEND=${RDEPEND}
-src_compile() {
+src_configure() {
# non-standard configure system!
- perl Configure --prefix=/usr --generic --rfc2307 --shadow --iplanet
+ perl Configure --prefix=/usr --generic --rfc2307 --shadow --iplanet || die
+}
+
+src_compile() {
# parallel make bad
emake -j1
}