summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-01-08 08:42:20 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-01-08 08:44:55 +0100
commite3c76788f1276fd1f331b9e7fc02e844c100da4f (patch)
tree8ae1c2e66e56189de2bfa765f8ec0a16f63350f4
parentnet-analyzer/braa: EAPI=7 (diff)
downloadgentoo-e3c76788f1276fd1f331b9e7fc02e844c100da4f.tar.gz
gentoo-e3c76788f1276fd1f331b9e7fc02e844c100da4f.tar.bz2
gentoo-e3c76788f1276fd1f331b9e7fc02e844c100da4f.zip
x11-wm/icewm: Bump to version 1.6.4
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--x11-wm/icewm/Manifest1
-rw-r--r--x11-wm/icewm/icewm-1.6.4.ebuild137
2 files changed, 138 insertions, 0 deletions
diff --git a/x11-wm/icewm/Manifest b/x11-wm/icewm/Manifest
index b1110a635485..0e20bc02e1c8 100644
--- a/x11-wm/icewm/Manifest
+++ b/x11-wm/icewm/Manifest
@@ -1,3 +1,4 @@
DIST icewm-1.5.5.tar.xz 1707656 BLAKE2B 670ab4d1c1648faa24c848ddb04f3e353a3acd8e9a105837229d00ca344a61b3432d7b23b89dc054e220797cfd56d6504ad233d8793a3a5d95d9943c79017797 SHA512 5d75d33bf6e45ea0b46ace5173d825e9d1a12318cf7a5319b20ea704b019f6c09391f0f199b0fac678ba0f160d8236fc1cfee5d3b47d1895b7ba3721ff62a05e
DIST icewm-1.6.2.tar.lz 1673647 BLAKE2B 006424aa005483b85ca36bd4447ce814ca81cd7243fc8045242a02355c2b35e9cbf6de0f1225d9b5e7685aca2961a731f060f7442250ef4f1527594233e8eac8 SHA512 0da78b9caf5cbbd8f944b4c89a15cb8b0e998de2075b09f65338d23027cbf024bbb9cfe9fffbe5d9606f11832090cb6552be2693cca5a62c011024f36ec1a0f9
DIST icewm-1.6.3.tar.lz 1678149 BLAKE2B cfb41b104f0e64172b1aa983b542dc42b6369061ad4365547b14f4f96bccba6610c9b4324ccdc691421354c387c37fa80e525658139ba4213b6ea8d86448e3cf SHA512 18d77695c22131fac98172c09e27c014c10e908f4fc0cbeeb376b9308a659f0a51b466c80fc39875d8e0cf52fd6b385e636faf96c55fcb80b2cb9c1d0eb57e41
+DIST icewm-1.6.4.tar.lz 1684348 BLAKE2B 63d2c609277f78ca438720c8f38108cf5b8f82361810773a79f42b161ccfb598f468cb6352ed3e1c7d523869ba6152be09e8f4ee008f300431dbe4fde4dc0325 SHA512 6a8c3b2e561c4471759b0566a4c5dc390f4abd6f266ab738a80a21445dffe9f45b24eca898507ff7c9b84ea12331262b81967b5a76be0b19e737842a66bcb000
diff --git a/x11-wm/icewm/icewm-1.6.4.ebuild b/x11-wm/icewm/icewm-1.6.4.ebuild
new file mode 100644
index 000000000000..342a1affae01
--- /dev/null
+++ b/x11-wm/icewm/icewm-1.6.4.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools unpacker
+
+DESCRIPTION="Ice Window Manager with Themes"
+HOMEPAGE="https://ice-wm.org/ https://github.com/ice-wm/icewm"
+LICENSE="GPL-2"
+SRC_URI="https://github.com/ice-wm/icewm/releases/download/${PV}/${P}.tar.lz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="+alsa ao bidi debug +gdk-pixbuf nls truetype uclibc xinerama"
+
+# Tests broken in all versions, patches welcome, bug #323907, #389533
+RESTRICT="test"
+
+REQUIRED_USE="|| ( alsa ao )"
+
+#fix for icewm preversion package names
+S="${WORKDIR}/${P/_}"
+
+# These are the core dependencies of icewm.
+# Look into configure.ac and search for PKG_CHECK_MODULES([CORE]
+CORE_DEPEND="
+ media-libs/fontconfig
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrender
+"
+
+RDEPEND="
+ ${CORE_DEPEND}
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXft
+ x11-libs/libXpm
+ x11-libs/libXrandr
+ alsa? (
+ media-libs/alsa-lib
+ media-libs/libsndfile[alsa]
+ )
+ ao? (
+ media-libs/libao
+ media-libs/libsndfile
+ )
+ bidi? ( dev-libs/fribidi )
+ gdk-pixbuf? (
+ x11-libs/gdk-pixbuf:2[X]
+ )
+ !gdk-pixbuf? (
+ media-libs/libpng:0=
+ virtual/jpeg
+ )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="
+ ${RDEPEND}
+ $(unpacker_src_uri_depends)
+ dev-libs/glib:2
+ gnome-base/librsvg
+ x11-base/xorg-proto
+ gdk-pixbuf? ( gnome-base/librsvg:2 )
+"
+
+BDEPEND="
+ app-text/asciidoc
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.19.6 )
+"
+
+src_prepare() {
+ # Fix bug #486710 - TODO: Still needed?
+ #use uclibc && PATCHES+=( "${FILESDIR}/${PN}-1.3.8-uclibc.patch" )
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local icesound
+ if use alsa && use ao ; then
+ icesound="alsa,ao"
+ elif use alsa ; then
+ icesound="alsa"
+ elif use ao ; then
+ icesound="ao"
+ fi
+
+ local myconf=(
+ --enable-logevents
+ --enable-xrandr
+ --with-cfgdir=/etc/icewm
+ --with-docdir=/usr/share/doc/${PF}/html
+ --with-icesound="${icesound}"
+ --with-libdir=/usr/share/icewm
+ $(use_enable bidi fribidi)
+ $(use_enable debug)
+ $(use_enable gdk-pixbuf)
+ $(use_enable nls i18n)
+ $(use_enable nls)
+ $(use_enable xinerama)
+ )
+ if use truetype ; then
+ myconf+=(
+ --enable-shape
+ )
+ else
+ myconf+=(
+ --disable-xfreetype
+ --enable-corefonts
+ )
+ fi
+
+ econf "${myconf[@]}"
+
+ sed -i "s:/icewm-\$(VERSION)::" src/Makefile || die
+ sed -i "s:ungif:gif:" src/Makefile || die "libungif fix failed"
+}
+
+src_install(){
+ local DOCS=( AUTHORS ChangeLog NEWS README.md TODO VERSION )
+
+ default
+
+ docinto html
+ dodoc doc/icewm.html
+ dodoc man/*.html
+
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}/icewm"
+}