summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-23 18:53:24 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-23 18:53:24 +0100
commite3da491ab853bdd310286411feadd4de961a3821 (patch)
treeab43b1950aae7fa7e116edfec8e7882e3c4e535a
parentmedia-libs/mlt: Restrict IUSE=opencv to <media-libs/opencv-4.5.1 (diff)
downloadgentoo-e3da491ab853bdd310286411feadd4de961a3821.tar.gz
gentoo-e3da491ab853bdd310286411feadd4de961a3821.tar.bz2
gentoo-e3da491ab853bdd310286411feadd4de961a3821.zip
media-sound/supercollider: Supposedly fix build with boost-1.74
Bug: https://bugs.gentoo.org/760489 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-sound/supercollider/files/supercollider-3.11.2-boost-1.74.patch39
-rw-r--r--media-sound/supercollider/supercollider-3.11.2.ebuild9
2 files changed, 43 insertions, 5 deletions
diff --git a/media-sound/supercollider/files/supercollider-3.11.2-boost-1.74.patch b/media-sound/supercollider/files/supercollider-3.11.2-boost-1.74.patch
new file mode 100644
index 000000000000..1e1ca8b7e195
--- /dev/null
+++ b/media-sound/supercollider/files/supercollider-3.11.2-boost-1.74.patch
@@ -0,0 +1,39 @@
+From cc873049ff9249a33567e4cbcdeffeb6806a30d6 Mon Sep 17 00:00:00 2001
+From: brianlheim <self@brianlheim.com>
+Date: Tue, 25 Aug 2020 17:14:29 -0500
+Subject: [PATCH] remove workarounds for old boost versions
+
+we don't need to support boost pre-1.70 anymore, and tcp::socket::executor_type was always the right typealias to use
+---
+ server/supernova/sc/sc_osc_handler.hpp | 10 +---------
+ 1 file changed, 1 insertion(+), 9 deletions(-)
+
+diff --git a/server/supernova/sc/sc_osc_handler.hpp b/server/supernova/sc/sc_osc_handler.hpp
+index f17e99a557..676c94dbf1 100644
+--- a/server/supernova/sc/sc_osc_handler.hpp
++++ b/server/supernova/sc/sc_osc_handler.hpp
+@@ -234,11 +234,7 @@ class sc_osc_handler : private detail::network_thread, public sc_notify_observer
+ class tcp_connection : public nova_endpoint {
+ public:
+ using pointer = std::shared_ptr<tcp_connection>;
+-#if BOOST_VERSION >= 107000
+- using executor = boost::asio::executor;
+-#else
+- using executor = boost::asio::io_context::executor_type;
+-#endif
++ using executor = tcp::socket::executor_type;
+
+ static pointer create(const executor& executor) { return pointer(new tcp_connection(executor)); }
+
+@@ -249,11 +245,7 @@ class sc_osc_handler : private detail::network_thread, public sc_notify_observer
+ bool operator==(tcp_connection const& rhs) const { return &rhs == this; }
+
+ private:
+-#if BOOST_VERSION >= 107000
+ tcp_connection(const executor& executor): socket_(executor) {}
+-#else
+- tcp_connection(const executor& executor): socket_(executor.context()) {}
+-#endif
+
+ void send(const char* data, size_t length) override final;
+
diff --git a/media-sound/supercollider/supercollider-3.11.2.ebuild b/media-sound/supercollider/supercollider-3.11.2.ebuild
index 288d5aa5c6b9..22651297c886 100644
--- a/media-sound/supercollider/supercollider-3.11.2.ebuild
+++ b/media-sound/supercollider/supercollider-3.11.2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit cmake flag-o-matic readme.gentoo-r1 xdg-utils
-DESCRIPTION="An environment and a programming language for real time audio synthesis."
+DESCRIPTION="Environment and programming language for real time audio synthesis"
HOMEPAGE="https://supercollider.github.io/"
SRC_URI="https://github.com/supercollider/supercollider/releases/download/Version-${PV}/SuperCollider-${PV}-Source.tar.bz2"
@@ -57,9 +57,7 @@ DEPEND="${RDEPEND}
dev-libs/icu
emacs? ( >=app-editors/emacs-23.1:* )
gedit? ( app-editors/gedit )
- qt5? (
- dev-qt/qtconcurrent:5
- )
+ qt5? ( dev-qt/qtconcurrent:5 )
vim? ( app-editors/vim )
"
@@ -67,6 +65,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-3.10.2-no-ccache.patch
"${FILESDIR}"/${P}-fewer-qt-deps.patch # Upstream PR 4991
"${FILESDIR}"/${P}-fix-libscsynth-linker-issue.patch # Upstream issue 4992
+ "${FILESDIR}"/${P}-boost-1.74.patch # bug 760489
)
S="${WORKDIR}/SuperCollider-${PV}-Source"